VirtualBox

Ticket #9 (closed defect: worksforme)

Opened 7 years ago

Last modified 4 years ago

FreeBSD cannot be installed. Page Fault.

Reported by: grub Owned by:
Priority: major Component: VMM
Version: VirtualBox 1.3.8 Keywords: Freebsd Cannot be installed
Cc: Guest type: BSD
Host type: other

Description

I get the following error while trying to install FreeBSD. Page Fault rebooting in 15 seconds.

The issue is probably already known to the developers. It would be great if this issue is resolved.

Change History

comment:1 Changed 7 years ago by achimha

With the next version, the situation is already better. However, FreeBSD 6.2 still doesn't fully work. We are working on a fix.

comment:2 follow-up: ↓ 3 Changed 7 years ago by techie

The same is with PC-BSD fork  http://www.pcbsd.org/

comment:3 in reply to: ↑ 2 Changed 7 years ago by skrzat

The same is with FreeNAS (based on FreeBSD) running on VB 1.3.6 (host Windows XP Pro)

Fatal trap 12: page fault while in kernel mode

comment:4 Changed 7 years ago by jeanfrancis

Same here with FreeBSD, with current SVN version (Gentoo/x86_64)...

comment:5 Changed 7 years ago by sandervl73

I've fixed a few problems and FreeBSD seems a lot more stable now. Not sure if all problems are solved though. Try current SVN. (wait a bit for the next sync)

comment:6 Changed 7 years ago by sandervl73

  • Version changed from VirtualBox 1.3.2 to VirtualBox 1.3.8

comment:7 Changed 7 years ago by jeanfrancis

Hi !

I still got a page fault, but after 9 minutes instead of 2-3 minutes. However, it seems to be a bit better :)

Thanks for all your work :)

comment:8 Changed 7 years ago by sandervl73

I've managed to reproduce those page faults too, but it's a lot harder now.

comment:9 Changed 7 years ago by jeanfrancis

Well, I tried to install twice, and I got it twice.. I may try a bit more in the next week. (I never used BSD before)...

By the way, WinXP on VirtualBox rocks :D

comment:10 Changed 7 years ago by techie

I tried it several times with FreeBSD 6.2 and with 6.1 on Win2000 with dynamic disk and I always get page fault sooner or later. I've never succeeded in passing the installation level.

comment:11 Changed 7 years ago by sandervl73

Looks like I finally got the nasty bug. Wait for the next OSE sync to try it out.

comment:12 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Appears to be fixed now. OSE SVN is up-to-date.

comment:13 Changed 7 years ago by techie

Thanks!

comment:14 Changed 6 years ago by skibrianski

  • Status changed from closed to reopened
  • Resolution fixed deleted

I still get this error sporatically on booting my FreeBSD 6.2 host on a debian hardy install:

ski@ganiodayo:~$ cat /proc/version ; cat /etc/issue ; dpkg -l | grep virtualbox Linux version 2.6.24-17-generic (buildd@crested) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Thu May 1 13:57:17 UTC 2008 Ubuntu 8.04 \n \l

ii virtualbox-ose 1.5.6-dfsg-6ubuntu1 x86 virtualization solution - binaries ii virtualbox-ose-modules-2.6.24-17-generic 24.0.1 virtualbox-ose module for linux-image-2.6.24 ii virtualbox-ose-modules-generic 24.0.1 virtualbox-ose module for linux-image-generi

Any news on this front? Is it fixed in 1.6.x ?

Thanks

comment:15 Changed 6 years ago by skibrianski

Since the error I was getting was immediately after probing of acd0, and the error seems not to happen when an iso is mounted there, I simply created an empty iso file using genisoimage and left it attached to the VM. A hack, but it works.

comment:16 Changed 6 years ago by frank

  • Guest type changed from other to BSD

comment:17 Changed 6 years ago by frank

  • Component changed from other to VMM

comment:18 Changed 5 years ago by attoparsec

Many changes have been made to the VMM, some specifically fixing FreeBSD-related problems. It works here on Ubuntu 8.10. Could you please try 2.1.2 and report back? Thanks!

comment:19 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

No response, closing. Note that BSD guests will currently only properly executed if the host supports VT-x or AMD-V.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use