VirtualBox

Ticket #10 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

auto-resize guest display doesn't work when the guest os resume from suspend mode.

Reported by: victor Owned by:
Priority: minor Component: other
Version: VirtualBox 1.4.0 Keywords: auto-resize
Cc: Guest type: other
Host type: other

Description

I test it under windows 2000 pro and windows xp pro chinese version.

Change History

comment:1 in reply to: ↑ description Changed 7 years ago by tfim

Is there any reason why this is marked critical?

comment:2 Changed 7 years ago by umoeller

  • Priority changed from critical to minor

comment:3 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in svn, next release will contain the fix.

comment:4 Changed 7 years ago by oblivion

  • Status changed from closed to reopened
  • Resolution fixed deleted

I still see this bug in virtualbox 1.4.0 (host: debian testing, guest: windows xp). After resuming the menu item "Auto-resize Guest Display" is grayed out, Host+G doesn't work either. Prior to the first suspend it just works.

comment:5 follow-up: ↓ 6 Changed 7 years ago by frank

Did you update the guest additions of your guest?

comment:6 in reply to: ↑ 5 Changed 7 years ago by oblivion

Yes, I have installed guest additions v1.4.0. In addition to the above I also observe this with guest additions v1.4.0 in a linux guest OS (kubuntu 7.04).

comment:7 Changed 7 years ago by shendric

This is also seems to be a problem when the VirtualBox window is maximized. When maximized, switching to full screen does not resize the display to fill the screen, it just centers what was showing before switching to full screen. When not maximized, switching to full screen works normally. I'm using 1.4.0 as well.

comment:8 Changed 7 years ago by kenken

I can confirm this behaviour. It seems that the guest must request the Auto-resize feature, and does so only at boot time. Thus it never works after a resume. I am refering to VirtualBox suspend/resume (save machine state), not host or guest suspend/resume features.

The resize problem appears as well, but does so regardless of suspend/resume. It is another bug though, and it appears that it is fixed in current svn:  http://www.virtualbox.org/changeset/2700

Host Ubuntu 7.04, Guest WinXP Pro SP2.

comment:9 Changed 7 years ago by cromo

I can also confirm the behaviour. "Auto-resize Guest Display" is grayed out here as well after resuming the machine state.

comment:10 Changed 7 years ago by michael

  • Version changed from VirtualBox 1.3.2 to VirtualBox 1.4.0

comment:11 Changed 7 years ago by michael003

This is fixed for me in VirtualBox 1.5.0. Host: Ubuntu Gutsy AMD64 Guest: Windows XP Professional Guest Additions 1.5.0 installed in guest.

comment:12 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use