VirtualBox

Ticket #8903 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VM won't start if VT-x enabled (OSX Lion)

Reported by: doggkruse Owned by:
Priority: major Component: host support
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

VM hangs on a black screen, never gets to the "bios" screen. Disabling acceleration allows the VM to boot.

Attachments

VBox.log Download (76.2 KB) - added by doggkruse 3 years ago.
this VM was suspended at start but exhibits the same issue

Change History

comment:1 Changed 3 years ago by doggkruse

Reverting to 4.06 solves the problem.

comment:2 Changed 3 years ago by frank

Could you attach a VBox.log file for such a VM session?

comment:3 Changed 3 years ago by frank

FYI, we did several tests and so far were not able to reproduce your problem.

comment:4 Changed 3 years ago by frank

  • Priority changed from blocker to major

Oh, are you running Lion by any chance?

Changed 3 years ago by doggkruse

this VM was suspended at start but exhibits the same issue

comment:5 Changed 3 years ago by doggkruse

Yes this is Lion build 11A459e

comment:6 Changed 3 years ago by frank

  • Summary changed from 4.08 VM won't start if VT-x enabled (OSX) to VM won't start if VT-x enabled (OSX Lion)

In that case this is expected as Lion is not yet supported.

comment:7 Changed 3 years ago by grahamperrin

… watching.

comment:8 Changed 3 years ago by Xaositek

Disabling VT-x will cause DP4 (Update 1) to completely lock up.

Processor 2.7 GHz Intel Core i7 Memory 8 GB 1067 MHz DDR3 Software Mac OS X Lion 10.7 (11A494a)

comment:9 Changed 3 years ago by frank

VT-x with Lion should work fine with VBox 4.0.10 which was just released.

comment:10 Changed 3 years ago by Xaositek

Perfect! Works marvelously!

comment:11 Changed 3 years ago by frank

Thanks for the feedback! Note that there are still issues for the non-VT-x mode but on OSX you should never need to run a VM without VT-x.

comment:12 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 4.0.12 and 4.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use