VirtualBox

Ticket #8826 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Bad HD Writes in OEL5.6 => Fixed in SVN

Reported by: paul.lienhard Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I'm getting regular invalid writes to the disk (reads seem to be OK) when running OEL 5.6 and giving it a large hunk of memory (6144megs) but do not see the problem when giving it 2048megs or less. The error occurs with the "use host I/O cache" option both on and off.

I've written a shell script to reproduce the error and have seen it occur on multiple host machines (although all windows 7 64bit) on virtual box 4.0.4 and 4.0.6, and have run memtest to confirm that it's not bad RAM.

Attachments

VBox.log Download (48.1 KB) - added by paul.lienhard 3 years ago.
VBox.log from a running machine that had had the write to hd error
bug.sh Download (510 bytes) - added by paul.lienhard 3 years ago.
A quick shell script that writes a 1meg file from /dev/random and then does a cp then diff 1700 times, and then repeates 100 times.

Change History

Changed 3 years ago by paul.lienhard

VBox.log from a running machine that had had the write to hd error

Changed 3 years ago by paul.lienhard

A quick shell script that writes a 1meg file from /dev/random and then does a cp then diff 1700 times, and then repeates 100 times.

comment:1 Changed 3 years ago by paul.lienhard

The issue seems to be within the SATA Controller, when I swap the .vdi over from the SATA controller to the IDE controller the issue goes away.

comment:2 Changed 3 years ago by frank

I assume the guest kernel is 64-bit as well?

comment:3 Changed 3 years ago by frank

Thanks for the testcase, we were able to reproduce this bug. Question is still if this is related to Oracle Linux 5 guests or if the same happens with other guests as well. We will do more tests.

comment:4 Changed 3 years ago by frank

We think we found and fixed the bug. Could you install  this test build and check if your problem is fixed?

comment:5 Changed 3 years ago by paul.lienhard

That definitely fixed it for me, Thanks a ton!

comment:6 Changed 3 years ago by frank

  • Summary changed from Bad HD Writes in OEL5.6 to Bad HD Writes in OEL5.6 => Fixed in SVN

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use