VirtualBox

Ticket #8803 (closed defect: worksforme)

Opened 3 years ago

Last modified 10 months ago

VM does not recognize multicore CPU

Reported by: glelli Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.0.6 Keywords: Multicore; CPU; linux
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

The boot procedure hangs up when setting a number of CPUs higher than 1.

The host OS is Win7 SP1 Professional. The guest OS is Ubuntu 10.10.

Note: The virtual machine was created without specifying the number of CPUs (4 in my case) and does not give any problem (except for its slowness) if I use a single-CPU setting.

Attachments

UBUNTU 32bit-2011-04-28-12-54-26.log Download (62.3 KB) - added by glelli 3 years ago.
Vbox.log
UBUNTU 32bit-2011-04-28-14-59-54.log Download (62.4 KB) - added by glelli 3 years ago.
Vbox.log (update)
Print screen.doc Download (215.0 KB) - added by glelli 3 years ago.
Screen capture
VBox.log Download (69.6 KB) - added by JoseM11 10 months ago.

Change History

Changed 3 years ago by glelli

Vbox.log

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

Where does the guest boot hang? Please

  1. Enable the 1st serial device for that VM and attach it to a host file.
  2. Boot the guest into GRUB and edit the kernel command line.
  3. Remove quiet splash
  4. Add ignore_loglevel console=ttyS0

Then boot the guest and attach the resulting file with the serial output to this ticket.

comment:2 in reply to: ↑ 1 Changed 3 years ago by glelli

Replying to frank:

Where does the guest boot hang? Please

  1. Enable the 1st serial device for that VM and attach it to a host file.
  2. Boot the guest into GRUB and edit the kernel command line.
  3. Remove quiet splash
  4. Add ignore_loglevel console=ttyS0

Then boot the guest and attach the resulting file with the serial output to this ticket.

Hi Frank,

The VM does not even start if I set more than 1 CPU. I've uploaded a new log file, together with a screen capture.

Could you please suggest me also how to boot the guest into GRUB?

Many thanks,

Giovanni

Changed 3 years ago by glelli

Vbox.log (update)

Changed 3 years ago by glelli

Screen capture

comment:3 follow-up: ↓ 4 Changed 3 years ago by frank

Ah! The problem is that the VT-x extension of you host computer is disabled. Reboot your host, go into the BIOS and search for a setting virtualization technology or something like that -- enable that setting. Sometimes a BIOS upgrade is necessary.

comment:4 in reply to: ↑ 3 Changed 3 years ago by glelli

Replying to frank:

Ah! The problem is that the VT-x extension of you host computer is disabled. Reboot your host, go into the BIOS and search for a setting virtualization technology or something like that -- enable that setting. Sometimes a BIOS upgrade is necessary.

OK, great!

Now it works! Thank you very much!

Giovanni

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

comment:6 Changed 10 months ago by JoseM11

I am having a problem running on Virtual BOx on a windows OS 7 Enterprise. The guest OS is Ubuntu 10.10.

I have created the virtual machine without specifying the number of CPUS. Before I start the virtual machine I had changed the number of CPUS to 4. (my windows box has 4 CPUS and 8 virtual cpus). I have read the thread above and check that the BIOS had the VT-x enabled. In fact the settings for the virtual machine states that VT-x/AMD-V is enabled and also that Nested Paging is enabled.

My processor is Intel Core i7-3720QM

I have tried to run a very simple mpi program using that prints the number of tasks it believes it has

mpirun -np 2 a.out

and it reports that I have only 1 CPU and of course 1 tasks.

The above line appears to run in serial.

Not sure what or if I am doing something wrong.

How do I make mpi to realize that I have 4 cores. Not sure if this is a Virtual Box issue or an mpi issue.

Can anyone help?

Changed 10 months ago by JoseM11

comment:7 Changed 10 months ago by frank

  • Description modified (diff)

Your VM has definitely 4 virtual CPUs running. Just use

cat /proc/cpuinfo

in the guest to verify that. Your mpi problem is something else and I suggest you to go to the forums (forums.virtualbox.org) to ask for help.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use