VirtualBox

Ticket #8792 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Reverting to snapshot results in machine dropped from the domain

Reported by: vadimrapp Owned by:
Priority: major Component: network
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have Windows XP virtual machine enrolled in Active Directory domain. I create a snapshot, then continue working. Then several weeks later I revert to the saved snapshot. When I run the machine, it's not found in the domain; when I logon as domain user, I receive message that computer account was not found; I have to remove the machine from domain and re-enroll again.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

I doubt that this is a VirtualBox bug. When you restore a snapshot then the complete VM state is restored as well. For instance, if there was some information exchanged by an change hands protocol, the VM side is no longer aware of this information. I can imagine that the AD service complains about that.

comment:2 Changed 3 years ago by vadimrapp

  • Status changed from closed to reopened
  • Resolution invalid deleted

With all due respect, I don't think that closing bug report without any investigation or attempt to reproduce, based solely on "I doubt" and "I can imagine" is wrong. Even if factors indeed exist outside of VB that cause this problem, it would help to find them and maybe write a KB article, so users would know what to expect and how to avoid this inconvenience.

comment:3 Changed 3 years ago by mjlucas

There is already a KB article from the makers of the operating system. Machines have a password to talk to Active Directory, they change this often so if you revert a snapshot it has a old password and therefore is refused by AD.

 http://support.microsoft.com/kb/154501

comment:4 Changed 3 years ago by poetzsch

  • Status changed from reopened to closed
  • Resolution set to invalid

Thanks mjlucas for this useful info.

Although, we really like to be helpful in whatever we can, we already have enough bugs open which are directly connected to VirtualBox and need to be solved. You could always use the  forum for asking such questions. The people there are very friendly and eager to help ;)

comment:5 Changed 3 years ago by poetzsch

Now that we know the reason, I added an entry to our Troubleshoot section in the manual, pointing to the KB article of MS.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use