VirtualBox

Ticket #877 (new defect)

Opened 6 years ago

Last modified 5 years ago

100% CPU load with Windows XP guest and iTunesHelper

Reported by: Nil Owned by:
Priority: minor Component: VMM
Version: VirtualBox 1.5.2 Keywords: itunes ituneshelper windows xp cpu usage high 100%
Cc: Guest type: other
Host type: other

Description

Host: Ubuntu Gutsy i386 Guest: Windows XP Professional SP2

After installing iTunes 7.5 from Apple's website I have noticed that VirtualBox uses 100% of the CPU. This is a dual core system (Core Duo T2500 @ 2.0 GHz) so actually only one core at once is at 100%, but I suppose that it would use almost 100% on a single core machine. This obviously makes the machine heat up too. Since I'm new to VirtualBox and I've used it for less than a week, I was unsure about if the VM always used the 100% of the CPU or not, so I first tried to disable tickless (nohz=off) on the host and ACPI on the guest too but that didn't help. Then I noticed that if I logged off the session in the guest CPU usage dropped, so I deduced it should be a Windows process or service what was causing the problem and found it to be iTunesHelper, however in the Windows Task Manager CPU usage for iTunesHelper was around 0-2% as expected so I understand it is a virtual machine issue. After disabling iTunesHelper in the registry so it doesn't load at logon CPU usage was normal again. Then I switched back to ACPI and re-enabled tickless and everything is fine now with iTunesHelper disabled.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to VMM

comment:2 Changed 6 years ago by rvugts

I can confirm having seen exactly the same problem on version 2.0.2 with the following configuration:

Host: Ubuntu Hardy Heron i386 Guest: Windows XP Professional SP3

As soon as I killed iTunesHelper CPU usage dropped to normal levels.

comment:3 Changed 5 years ago by petekalo

I am having the same thing, Intrepid Ibex.

comment:4 Changed 5 years ago by dbkr

Confirmed on Gentoo: Linux 2.6.25-gentoo-r5 #5 SMP x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz GenuineIntel GNU/Linux, virtualbox 2.0.6 (from virtualbox-bin package, ie. official binaries). Just updated guest additions.

comment:5 Changed 5 years ago by anirde

Confirmed on opensuse 11.1 x86_64

CPU: model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ VBox 2.1.2 (non-ose)  http://download.virtualbox.org/virtualbox/2.1.2/VirtualBox-2.1.2_41885_openSUSE111-1.x86_64.rpm Kernel:2.6.27.7-9-default Guest. Windows XP Pro (SP3)

The difference are: After starting the Windows guest (Guest is idle), one core have permanently >75% CPU load. If i run an application the load are everytime 100% for one core. I think that isn't normaly.

comment:6 Changed 5 years ago by noahsmybro

I'm seeing almost the exact same thing here.

Dell Inspiron 8500 Pentium 4m - 2.4ghz, 512Mb RAM (shared with VGA)

OpenSUSE 11.1 x86.

VirtualBox 2.1.2 (non-OSE) GUEST: Windows XP SP2, with VM Additions installed. Given the pitiful RAM situation, I've allotted 228Mb to the guest, with 12Mb for the video memory. (I ordered 2Gb for the laptop this afternoon.)

I've reduced the graphics settings on the guest drastically to lessen the load - 8-bit, 1024x768, Windows settings set to Max Performance (so GUI looks like Win2k). In the VM settings I've enabled 3D Acceleration.

Windows seems to load and run fine, with CPU at approx. 27-30% with nothing running. The moment I try to start iTunes 8.0, the CPU immediately hits 100% and remains there until the iTunes process is killed.

Note that killing iTunesHelper doesn't seem to help, on my computer. Also, Task Manager does NOT show iTunes consuming any significant resources, reinforcing what Nil wrote above.

My goal is to be able to connect a new iPod Nano and sync it with music on the laptop. Initially, I'd installed whatever VirtualBox was included on the OpenSUSE 11.1 DVD. I think it was 2.0.6 OSE, but am unsure. Using that version of VB, I COULD run iTunes, no problem.

The iPod Nano wasn't detected when I plugged it in to the USB port on the laptop, and while trying to solve that I uninstalled VB, and then downloaded the latest version from the VB website - 2.1.2 non-OSE. I suspect that's when iTunes stopped working properly, fwiw.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use