VirtualBox

Ticket #878 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

compiz + seamless mode : guest/host window layering behaves incorrectly

Reported by: prurigro Owned by: umoeller
Priority: minor Component: GUI/compiz
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

When using 'compiz' and 'virtualbox in seamless mode', the layering of linux windows and the virtualbox layer behave incorrectly. When you click the title bar of a linux window, it moves/remains behind the virtualbox layer. It only works properly when clicking the body of a linux window, where the window moves in front of the virtualbox layer as it should.

Change History

comment:1 Changed 6 years ago by prurigro

interesting-- I'm not totally sure whats causing it now. The problem happened on two computers, one using amd64 and one is 32bit and both in totally different environments. I assumed based on this that the problem was continuous, however after rebooting this computer, the problem went away. I have to wonder based on this if there is a trigger, possibly using the nvidia settings application for example? I'll follow up when I run into the error again

comment:2 Changed 6 years ago by prurigro

ok, I restarted virtualbox without any changes to anything else and the problem is back. Also, the problem has occured on the first run of virtual box when I tested on my other computer, so its difficult to say why it worked properly once

Theres something I should point out btw; I have compiz animate the layer changing of a window. When I click the title bar of the linux window and it attempts to (but doesn't) come to the front, the animation occurs on the entire virtualbox layer in a way that suggests it thinks that its coming to the foreground. Normally however, when virtualbox comes to the foreground, no animation occurs.

comment:3 Changed 6 years ago by markba

Appears on every computer I have (Dell desktop and HP laptop, both on Ubuntu 7.10), so seamless mode is useless to me. After disabling desktop effects (compiz), everything works fine.

comment:4 Changed 6 years ago by umoeller

  • Owner set to umoeller
  • Status changed from new to assigned

I can reproduce this. Assigned internal bug #2661.

comment:5 Changed 6 years ago by frank

  • Component changed from other to GUI/compiz

comment:6 Changed 4 years ago by umoeller

  • Status changed from assigned to closed
  • Resolution set to fixed

I can no longer reproduce this. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use