VirtualBox

Ticket #8754 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VM inaccesible afetr crash

Reported by: noelbk Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Host system running VirtualBox 4.0.4r70112 on Windows 7 64 bit

I created a snapshot of a running machine (Windows Server 2008, 64 bit), restored the snapshot, VirtualBox crashed with no error dialog. Now when I open Virtual box it says "The selected virtual machine is inaccessible". When I try to remove the old disk in Virtual Media Manager, I get this:

Result Code: VBOX_E_OBJECT_IN_USE (0x80BB000C) Component: Medium Interface: IMedium {9edda847-1279-4b0a-9af7-9d66251ccc18}

I also tried this on the command line:

"c:/Program Files/Oracle/VirtualBox/VBoxManage.exe" closemedium disk "./Server2008 Oracle ArcSDE.vdi" VBoxManage.exe: error: Cannot close medium 'c:\noel\.VirtualBox\HardDisks\Server2008 Oracle ArcSDE.vdi' because it has 1 child media VBoxManage.exe: error: Details: code VBOX_E_OBJECT_IN_USE (0x80bb000c), component Medium, interface IMedium, callee IUnknown Context: "Close()" at line 1182 of file VBoxManageDisk.cpp

How do I flip the "in-use" bit on a disk?

Attachments

VBox.log Download (107.2 KB) - added by noelbk 3 years ago.
latest log file

Change History

Changed 3 years ago by noelbk

latest log file

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

As a result of this bug your .xml / .vbox files are somehow corrupted. You have to repair them probably manually. That bug might have been fixed in the meantime, however, we still get reports that restore snapshot does not work reliable but this is reported elsewhere, for example in #8363.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use