VirtualBox

Ticket #8706 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Unable to import exported VMs when shared folder location does not exist on new machine.

Reported by: lward07 Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Currently whenever I try to export a VM (ova format from a Windows installation) that has shared folders setup and then import it in Linux I get the error:

Failed to import appliance /tmp/vm.ova

Shared folder path 'C:\shared' is not absolute

Result Code: NS_ERROR_INVALID_ARG (0x80070057) Component: SharedFolder Interface: ISharedFolder {8388da11-b559-4574-a5b7-2bd7acd5cef8}

This path is obviously not a valid Linux path, but I do not think this should prevent the import of the VM. It would be nice if when importing a VM in the "Appliance Import Settings" screen you could choose to remap the paths of the shared folders at the time of import. This would allow people to build VMs meant to be distributed to multiple users and allow the users importing them to map shared folders in a way that makes sense for their system. Currently they would be stuck unable to import at all.

Change History

comment:1 Changed 3 years ago by hnhn

This is still valid in 4.0.8. I'm trying to import Solaris .ova created on Windows (having shared folder c:\something) on Solaris and it's failing. I also don't think that non-existant shared folder should be a stopper for appliance import. The folder is *not* listed in the 'Appliance import settings', so I don't see a way to work around this problem.

I would really appreciate some workaround (if not a quick fix ;) for this.

comment:2 Changed 3 years ago by burnchar

Still an issue in 4.1 This is probably a duplicate of 7941

comment:3 Changed 3 years ago by sentin3l

Confirmation - still a problem in 4.1. Duplicate of #7941.

comment:4 Changed 3 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use