VirtualBox

Ticket #8685 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Host & Guest freeze VB 4.0.4 Debian Squeeze SUN X2200

Reported by: mng Owned by:
Priority: blocker Component: VMM/HWACCM
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

We did a lot of research here but we did not find any solution yet. We are using VirtualBox 4.0.4 on a SUN X2200 Server, 8GB RAM, 2x Opteron 2214 Dualcore, Debian Squeeze 6.0.1, 2x 250GB HDD Soft-Raid 1. Guest is Debian Squeeze, 512MB RAM, nothing special, started via VBoxHeadless. Host and guest freeze from time to time, reboot / hardware reset of the host is needed then. Usually we are using remote connection via SSH to connect to the host. When it freezes we sometimes can still access it from the console via ELOM. We then see a lot of headless processes, but they are not consuming much IO, RAM or CPU. We did not find anything special in the VBox logfiles yet. This happens since 4.x, with 3.x it was fine. Please help as this is blocking usage of VirtualBox for us.

Attachments

VBox.log.tar.gz Download (31.5 KB) - added by mng 3 years ago.
see VBox.log.3
VBox.log.3 Download (69.6 KB) - added by mng 3 years ago.
some VRDE logs

Change History

comment:1 Changed 3 years ago by frank

Please attach a VBox.log file of such a blocking VM session.

Changed 3 years ago by mng

see VBox.log.3

comment:2 Changed 3 years ago by mng

For us it seems like there is nothing related to the freeze in the log file?

comment:3 Changed 3 years ago by frank

Right, I don't see a problem either in the log files. So far I have no idea.

comment:4 Changed 3 years ago by mng

I'll try to grab more information when it freezes the next time. What about if we gave you SSH access to the machine during a maintenance window? Would it help?

comment:5 Changed 3 years ago by frank

I don't think so. We had to reproduce this issue here and when your box is frozen, remote ssh would probably not work anyway...

Changed 3 years ago by mng

some VRDE logs

comment:6 Changed 3 years ago by mng

hi frank - so far it seems like it may be related to VRDE, at least one VM had several log entries related to that... maybe i should add that we were also using vboxweb & php virtual box. today we disabled both to see if it will be stable without it. by the way: it crashes with a kernel panic which i can see in the elom console, but unfortunately i cannot scroll up to see the root cause and it doesnt log anything in messages, kern.log etc...

comment:7 Changed 3 years ago by mng

FYI: we updated to 4.0.6 but it still happens

comment:8 Changed 3 years ago by mng

we also turned VRDE off now: VBoxManage modifyvm test --vrde off

comment:9 Changed 3 years ago by mng

ok, some more news: turning VRDE off didn't help. BUT: today i was able to grab some output from the ELOM console and it looks like a problem related to the kernel, at least we get "BUG: unable to handle kernel paging request". currently i am trying to replace the kernel 2.6.32-5 shipped with debian squeeze with the latest stable release from kernel.org 2.6.38.4

comment:10 Changed 3 years ago by frank

  • Component changed from other to VMM/HWACCM

comment:11 Changed 3 years ago by codeslingercompsalot

hmm, perhaps it would help to try configuring the guest for 1 cpu, no PAE and use IDE instead of SATA. this seems to have helped with some similar problems. see for instance bug #8511

comment:12 Changed 3 years ago by frank

Still relevant with VBox 4.1.4?

comment:13 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use