VirtualBox

Ticket #8608 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

fedora 14 32bit get frozen while updating and setting change

Reported by: john.doe Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I`ve set the settings of the fedora machine from 1CPU to 4 CPU and the RAM from 1024MB to 4096MB, with activating IO APIC.

Fedora starts up normally, but was very slow during running. Starting an update -> fetching package list, get fedora frozen.

Attachments

fedora 14 32-bit-2011-03-22-12-56-21.log Download (75.5 KB) - added by john.doe 3 years ago.

Change History

Changed 3 years ago by john.doe

comment:1 Changed 3 years ago by frank

Could you check if  this build fixes your problem? We fixed a bug which caused memory corruption in guests with SATA controller and high amount of guest RAM.

comment:2 Changed 3 years ago by frank

Actually the guest froze is most probably a duplicate of #7930. In that case there should be crash messages in the host kernel log. Disabling either nested paging or PAE for the guest will workaround this bug. But it would be still interesting if you could test the test build mentioned above.

comment:3 Changed 3 years ago by frank

Forget my last comment. The bug I mentioned is only relevant for VT-x (Intel processors).

comment:4 Changed 3 years ago by maninred2

O.K and sorry the testbuild is gone and obsolete with the release of 4.0.8.

Under 4.0.8 there are still problems with multicore configurations, so far. This affects fedora, ubuntu,lubuntu, biolinux,... it is ubiquitous. Can´t remember what is with Windows->I think 2 cores was more or less o.k with windows7(I´ve done so). I was never brave enough to try more-> would be properly cause the same problems I guess.

comment:5 Changed 3 years ago by frank

VBox 4.0.10 contains timer fixes for SMP Linux guests so it would be worth a try.

comment:6 Changed 3 years ago by maninred2

Fixed -> Close it!

Just tested with fedora14: all works fine: a little delay is still there, but that is all.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use