VirtualBox

Ticket #8527 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Bug in Intel HD Audio, AC'97 => Fixed in SVN

Reported by: dj_bushido Owned by:
Priority: major Component: audio
Version: VirtualBox 4.0.4 Keywords: Intel HD, AC'97
Cc: Guest type: Linux
Host type: Linux

Description

In the VirtualBox 4 branch (4.0.0, 4.0.2, 4.0.4) I'm getting an a bug in the Intel HD Audio and AC'97 Audio. I can recreate this error in both Ubuntu 10.04 and Fedora 14. The host is RHEL5.4. I am using the ALSA backend, and have not tested OSS (Pulse is not installed). The issue does not come up with SoundBlaster, but then audio is disabled (guest doesn't support it?). By any means, Intel and AC'97 do not work in the 4.0 branch. I haven't seen any related bugs on the forum or bug list, but if I'm not on point with this, please let me know. I have attached the logfile, but the coredump was 2.5 MB and didn't fit on the attachment list. How should I submit it?

Attachments

UbuntuVM-2011-03-09-11-11-59.log Download (74.0 KB) - added by dj_bushido 3 years ago.
Logfile from the Ubuntu VM
VBox.log Download (52.0 KB) - added by dj_bushido 3 years ago.
Run of Ubuntu 10.04 with Alsa + Intel HD Audio enabled
VBox.2.log Download (52.1 KB) - added by dj_bushido 3 years ago.
Run of Ubuntu 10.04 with Alsa + ICH AC 97 Audio enabled

Change History

Changed 3 years ago by dj_bushido

Logfile from the Ubuntu VM

comment:1 follow-up: ↓ 2 Changed 3 years ago by Hachiman

Could you please clarify a bit step to reproduce? Please, contact me with e-mail at [vasily _do_ levchenko _at_ oracle _dot_ com] to get instructions how to provide the core file.

comment:2 in reply to: ↑ 1 Changed 3 years ago by Hachiman

Instruction how to upload the core file was sent.

comment:3 Changed 3 years ago by dj_bushido

I have sent the coredump in, and wanted to check and make sure that it was received successfully.

comment:4 follow-up: ↓ 5 Changed 3 years ago by Hachiman

I've received the core file and am investigating it currently. Thanks for reporting.

comment:5 in reply to: ↑ 4 Changed 3 years ago by Hachiman

Replying to Hachiman:

I've received the core file and am investigating it currently. Thanks for reporting.

Could you please a clarify a bit. When does this crash happens? Do you just launch the VM with enabled sound and it crashes or you do some actions before the crash.

comment:6 Changed 3 years ago by dj_bushido

The bug is visible on login. The boot process seems to go without a hitch, but about 5-10 seconds after the user logs in (these were both automated logins, no password entry) then the machine crashes.

comment:7 Changed 3 years ago by Hachiman

Could you please add log file of VM run with HDA and Ac'97 configurations?

Changed 3 years ago by dj_bushido

Run of Ubuntu 10.04 with Alsa + Intel HD Audio enabled

Changed 3 years ago by dj_bushido

Run of Ubuntu 10.04 with Alsa + ICH AC 97 Audio enabled

comment:8 Changed 3 years ago by dj_bushido

The requested log files have been added. I can also do a coredump of the two runs if necessary.

comment:9 Changed 3 years ago by Hachiman

Thanks, for logs. Core file you've provided is enough for now.

comment:10 Changed 3 years ago by Hachiman

It looks like the issue happens PCM_IN isn't initialized. How difficult for you to enable PulseAudio on your host? There could be several potential reasons for crushing, trying with Pulse will cut some of them. BTW, did it happen on 3.2 for you?

comment:11 Changed 3 years ago by dj_bushido

It did not happen in the 3.x branch of VirtualBox, it is specifically the 4.x branch (I tested all 3 versions) that is running into this issue.

I can look at trying to install PulseAudio, I'm not quite sure how hard it would be to install offhand, but I'll get back to you with the results of that.

comment:12 Changed 3 years ago by frank

  • Summary changed from Bug in Intel HD Audio, AC'97 to Bug in Intel HD Audio, AC'97 => Fixed in SVN

We found and fixed the problem. The fix will be available with the next maintenance release! Thanks for the report!

comment:13 follow-up: ↓ 14 Changed 3 years ago by dj_bushido

Since I'm curious, may I ask what the issue was? Also to confirm, you don't need me to install pulse for additional testing, correct?

comment:14 in reply to: ↑ 13 Changed 3 years ago by Hachiman

Replying to dj_bushido:

Since I'm curious, may I ask what the issue was?

The problem was in filter driver, had been added recently (in 4.0 branch). We were able to reproduce the issue and found more generic approach to fix it. The main root cause was lack of verification that sound backend is ready to operate, before do some operation with it. In your case, PCM_IN line wasn't up, that was provoking sigfault.

Also to confirm, you don't need me to install pulse for additional testing, correct?

right.

comment:15 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use