VirtualBox

Ticket #8462 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Gentoo guest Freezes during compile

Reported by: kwhat Owned by:
Priority: major Component: guest smp
Version: VirtualBox 4.0.4 Keywords: gentoo compile
Cc: Guest type: Linux
Host type: Linux

Description

There appears to be a thread deadlock issue when using Gentoo guests to compile software. This issue only occurs if the virtual cpu's are increased past 1. It makes no difference if there are 2 or 8 cpus allocated to the guest. I am pretty sure this is not limited to Gentoo guests however it is very easy to reproduce using Gentoo.

Steps to reproduce: Setup a vm with more than 1 virtual cpu (more the merrier) Set make -j to something like the number of cpu's +1 Start compiling something large (emerge -v --emptytree world) and wait.

It usually goes though several packages before it locks up. The best I can tell this is a thread dead lock issue and not something like a kernel panic. I have attached the kernel config that I am using to duplicate the issue.

Attachments

linux-2.6.36-gentoo-r5.config Download (47.3 KB) - added by kwhat 3 years ago.
Kernel 2.6.36 configuration file.
VBox.log Download (86.6 KB) - added by kwhat 3 years ago.
Log file after issue occurred and hard shutdown initiated.

Change History

Changed 3 years ago by kwhat

Kernel 2.6.36 configuration file.

comment:1 Changed 3 years ago by protogenes

I second that report. The guest locks up and the host CPU is completely busy. It once happened during Ubuntu 10.10 boot as well and the kernel reported a soft lockup, I assume the same for my gentoo guest (will try later). The only way to work with my VM is to only use one CPU.

host: Windows 7 Professional x64
guest: gentoo x64 2.6.36-gentoo-r8

comment:2 Changed 3 years ago by frank

Please attach a VBox.log file of such a VM session.

Changed 3 years ago by kwhat

Log file after issue occurred and hard shutdown initiated.

comment:3 Changed 3 years ago by frank

Sounds related to #7619.

comment:4 Changed 3 years ago by kwhat

Could be related...

I tried the workaround for apci=off and that seems to have worked for this issue. I also worked around the problem by disabling acpi in the kernel directly. Using nolapic_timer caused a non-boot situation. I did not try noapic or nolapic.

comment:5 Changed 3 years ago by frank

Is this problem still relevant with VBox 4.0.12?

comment:6 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:7 Changed 2 years ago by GaretJax

I have VBox 4.1.10 and I'm still affected by this bug.

I'm working on a specific task right now and I can't update to 4.1.12, but I'll do so as soon as possible and report here if there are any changes!

comment:8 Changed 2 years ago by GaretJax

Still freezing on 4.1.14

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use