VirtualBox

Ticket #7619 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Linux guest freezes randomly with four virtual processors

Reported by: akats Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Meerkat guest freezes randomly when I give it four virtual processors on my Core i7 machine. It works fine(for me) with two virtual processors. This is discussed on the forum here:  http://forums.virtualbox.org/viewtopic.php?f=3&t=35214

At first, I'd have trouble typing -- I'd have to type a character twice for it to show up in a window, or sometimes I'd type it once, and five copies would show up in the window. Same thing with mouse clicking. Then it would no longer be able to open new windows. At this point it might still allow me to choose shutdown from the top menu, but it would not actually shut down or reset. I'd have to hard-reset it from the VBox menu.

I am attaching a log, but I am not sure if it's from the correct session.

Attachments

Meerkat64-2010-10-20-12-05-32.log Download (84.7 KB) - added by akats 4 years ago.
log
strate-panic.GIF Download (17.9 KB) - added by justindossey 3 years ago.
partial kernel panic screenshot
vbox_cpus.txt Download (1.3 KB) - added by IPW 3 years ago.
cat /proc/cpuinfo for IPW
default.txt Download (40.0 KB) - added by hwti 3 years ago.
dmesg output with "apic=debug" kernel command line
nolapic_timer.txt Download (41.2 KB) - added by hwti 3 years ago.
dmesg output with "apic=debug nolapic_timer" kernel command line
dmesg.dschaefer.txt Download (38.5 KB) - added by dschaefer 3 years ago.
This time with the apic=debug setting really turned on.
dmesg.McMagnus.txt Download (33.8 KB) - added by McMagnus 3 years ago.
As requested by frank
ata_errors.hwti.txt Download (1.7 KB) - added by hwti 3 years ago.
ata errors seen with HPET enabled

Change History

Changed 4 years ago by akats

log

comment:1 follow-up: ↓ 75 Changed 4 years ago by Gremlyn1

Just wanted to chime in that this is a problem for me as well. I'm running a WinXP host (Core2Duo 2.67GHz, 2GB RAM) with a Maverick guest. I was seeing this issue with 2 CPUs assigned to my vbox guest, and after backing down to 1 CPU the issue seems to be gone.

comment:2 Changed 3 years ago by jfboily

I also experience this problem. HOST: Windows 7 x64, core i5, 6GB RAM. GUEST: ubuntu 10.10 32bits. Hangs randomly when using more than 1 processors. Works fine with only 1 proc.

comment:3 Changed 3 years ago by eteq

I'm experiencing the same: Windows 7 x64 host, core i7, 8GB RAM Guest: Ubuntu 10.10 64-bit.

comment:4 Changed 3 years ago by elirov

Me too! Same exact config as eteq. 1 or 2 cores work fine. Any more and everything starts to slow down and eventually hard hangs.

comment:5 Changed 3 years ago by dschaefer

Ditto. Windows 7 64 bit host, dual core, random freezing running Fedora 13 guest with > 1 core, especially using network. Guest seems to be running, and the cursor is moving, but the X windows are all frozen.

comment:6 Changed 3 years ago by arencambre

Me, too. (Note to Trac maintainers: I would have just added myself to the CC for this issue instead of this post, but looks like you're not allowing this.)

comment:7 Changed 3 years ago by justindossey

I have this problem too. Linux host, Linux guest. Things I tried:

  • different Ethernet drivers (I tried e1000 server, e1000 desktop, virtio-net)
  • different guest Linux kernels (2.6.32, 2.6.34, 2.6.35)

Reducing the number of virtual CPUs on the guest from 4 to 2 helped considerably-- with 4 cores, the guest would crash within a few hours, but with 2, the guest has been stable for 18 hours so far. I have a screenshot of a panic (I actually got panics on 2.6.32) but I couldn't get the magic SysRq key to work, so I only have the last 24 lines or so of it.

Changed 3 years ago by justindossey

partial kernel panic screenshot

comment:8 Changed 3 years ago by elirov

On mine, in addition to the hangs etc, the windows screensaver refuses to start when the virtualbox Ubuntu guest is given more than 2 cores. Hope that helps someone debug this...

My virtualbox has been up for days now on 2 cores. No stability problems.

comment:9 Changed 3 years ago by arencambre

I have my problem with 2 CPUs. Reducing to 1 CPU might have fixed--at least no problems today!

comment:10 Changed 3 years ago by eteq

I turned it down to 2 cores and still got the freezes after a while, but then I turned off Nested Paging, and now it doesn't seem to happen any more (although no guarantee that's the cause). So perhaps that's a workaround?

comment:11 Changed 3 years ago by frank

If you can indeed could isolate this issue to nested paging then this would be indeed helpful. Could you do some more tests to substantiate your observation? Also, users which observe this problem on a [b]Linux hostb could send me (frank _dot_ mehnert _at_ oracle _dot_ com) a  core dump taken when the guest is frozen. I can tell you an FTP server is necessary.

comment:12 Changed 3 years ago by frank

  • Component changed from VM control to guest smp

comment:13 Changed 3 years ago by eteq

Hmm... I still have yet to have it freeze on my in 2 cores w/ nested paging on, but it just happened now with 4 cores and nested paging. I would guess this means NP is not (at least exclusively) the culprit - I had earlier observed that it happens less often with 2 vs 4 cores, even with NP on. So while disabling NP may be helping, it didn't completely fix it.

comment:14 Changed 3 years ago by g15

Running with two processors and Nested Paging disabled did not help me. I run VB on a dual core processor.

comment:15 Changed 3 years ago by eteq

Some more information based on things I've noticed recently:

  • The problem usually happens when I come back to the guest after not using it for a while. This usually (although not always?) includes hibernating the host. Anyone else see an association with either downtime or hibernation?
  • I happen to have the system monitor running the most recent time the freeze happened:  http://dl.dropbox.com/u/8683962/zerocpu.png - the interesting thing here is the CPU - the CPUs drop to exactly 0% and stay there for a little while before the freeze occurs.

comment:16 Changed 3 years ago by loadpi

running i7 8Gb vaio ubuntu 10.10 64bit host and ubuntu 10.10 32bit guest:

Nested Paging does not make a difference, hangs with or without.

Down to 1 vcpu now - 2-4 does not work (seems more cpus the quicker it happens).

It has happened:

  • when host came back from locked screen saver (no load)
  • after startup about 5-30 minutes in (pretty heavy load)

Sequence:

  • keys go first
  • then gnome-terminal stops getting to bash (a quick test)
  • then processes just freeze
  • and eventually everything snuffs it.

comment:17 follow-up: ↓ 18 Changed 3 years ago by citral

I find that disabling guest additions prevents the crashes. For what that is worth.

comment:18 in reply to: ↑ 17 Changed 3 years ago by dschaefer

Replying to citral:

I find that disabling guest additions prevents the crashes. For what that is worth.

I had a freeze at install time before guest additions so I'm not sure it's that.

But man, it happens all the time, in my environment at least (Win 7 64 host, Fedora guests). I'm surprised it the vbox team hasn't see it. Has me worried about where this is going, especially with the Oracle logo at the bottom of this page...

comment:19 Changed 3 years ago by extproxy

Ever since I upgraded my VM to Ubuntu 10.10, Virtualbox has been practically unusable due to this bug. I've even given up using Virtualbox 3.2.10 and have moved on to the less performant VMware player. I'm anxiously waiting for a fix to this bug and the next virtual box upgrade. Is the virtualbox team even looking at this issue. Seems like its been over a month since its been open and yet no serious efforts in attempting to fix the issue.

comment:20 Changed 3 years ago by razie

Hey - this is really annoying. It is working fine with 1 CPU but...obviously slower. I have been waiting for over 6 weeks on this bug, checking back frequently but there has been no progress.

Is this not considered high? do you need more people to vote for this or how do things work?

comment:21 follow-up: ↓ 27 Changed 3 years ago by klaus

Everything in the public bug tracker is handled on a best effort basis. Staging votes doesn't help. Also keep in mind that there are over 2600 tickets open. We can't acknowledge all or provide an update every minute.

comment:22 Changed 3 years ago by loadpi

My issue seems have been fixed with 3.2.12 - been running 4 vcpus for the whole of yesterday - thanks.

comment:23 Changed 3 years ago by g15

Well, it did not work for me. With two cpus it hung after sometimes as usual. However I clicked on the ACPI Shutdown menu in VB and the shutdown option in Ubuntu came up. When I selected restart there, I got a message saying the power management application was not responding. I had to switch off the VM finally. I guess the problem is related to power saving/sleep like mentioned in one of the posts above.

comment:24 Changed 3 years ago by dschaefer

Same here, 3.2.12 did *NOT* fix the issue for me. It's hard to guess what it is.

comment:25 Changed 3 years ago by loadpi

Both 10.10 host and guest fully up to date apt wise and installed the 3.2.12 vbox guest additions. Strange - been working for the 2nd day now

Base Memory:3584 MB Processor(s):4 VT-x/AMD-V:Enabled Nested Paging:Enabled

comment:26 Changed 3 years ago by dschaefer

OK. But the original defect mentions Windows hosts, not Linux. This could be specific to the host type. And in my case, I'm running Windows 7 64 bit.

comment:27 in reply to: ↑ 21 Changed 3 years ago by Gremlyn1

Replying to klaus:

Everything in the public bug tracker is handled on a best effort basis. Staging votes doesn't help. Also keep in mind that there are over 2600 tickets open. We can't acknowledge all or provide an update every minute.

I think we'd just like to know that this is being looked in to. It's obviously a prevalent bug and quite a big one at that.

comment:28 Changed 3 years ago by g15

Just noticed that even without any programs running, if I just put the laptop on standby or hibernate and then resume Ubuntu hangs. So definitely it must be related to the power management. Can any confirm this?

comment:29 follow-up: ↓ 30 Changed 3 years ago by dschaefer

Here's some good news. I am not seeing the problem with vbox 4.0 beta 2. I've been pounding it pretty hard with an Android build which always triggered it in 3.2 and so far so good.

comment:30 in reply to: ↑ 29 Changed 3 years ago by elirov

Yes. I'm seeing the same thing. Looks like 4.0 beta2 might solve this.

I hadn't realized that you could download the binary directly. Here's the link in case anyone is looking for the binary versions:

 http://download.virtualbox.org/virtualbox/4.0.0_BETA2

Haven't had any other problems with the beta yet either, so I think I'll be using this going forward.

comment:31 Changed 3 years ago by dschaefer

Yes, they are announcing the betas on their twitter account :). @virtualbox

I'm still running good after a few hours. And it looks pretty too.

comment:32 Changed 3 years ago by elirov

Oops.. Spoke to soon. Just got the same hang again on 4.0B2...

comment:33 Changed 3 years ago by elirov

It seems to happen when I work in Eclipse (which takes lots of ram). Suddenly, everything slows down, and within a 10-20 seconds, I can't even type in a terminal any more. Interestingly, I can still minimize windows for a few more seconds, until everything just freezes completely.

The host is fine through all this. I just "poweroff" the guest and start over.

comment:34 Changed 3 years ago by dschaefer

Damn. Same here. Lasted quite a bit longer. Doing lots of Android builds. Worked for quite a while longer than before, but alas, frozen.

BTW, seeing the same failure behavior as elirov. I can see disk activity too after the GUI freezes and then all stops.

comment:35 Changed 3 years ago by arencambre

Are we sure this isn't the Ubuntu guest's fault?

comment:36 Changed 3 years ago by dschaefer

I'm using Fedora and saw it both with Fedora 13 and 14. I actually believe it's something wrong in the drivers installed by the Additions. But I'm all guesses at this point.

comment:37 Changed 3 years ago by justindossey

Absolutely sure it's not the guest additions, and I'm pretty sure it's not the guest kernel either. I've tried four different 2.6 kernels on Gentoo guest (gentoo host), and I get the hang with and without additions. Drop to 1 CPU and it's rock-solid.

comment:38 Changed 3 years ago by arencambre

This issue's title needs adjustment. Per some reports here, this issue's title needs changing. Some of us are reporting problems with >1 processor.

comment:39 in reply to: ↑ description Changed 3 years ago by ezs

I'm having the same problem. I have an i7 870 Windows 7 host, with 4 CPUs but hyperthreading makes it look like 8 CPUs. When using VirtualBox 3.2, with 8 or 4 virtual CPUs, my guest Ubuntu 10.10 would crash frequently. I have tried with nested paging turned off for both 8 and 4 CPUs. As an aside, it is interesting that my performance seemed better with 4 CPUs than with 8 (when not crashing)...

The symptoms were the same as described previously - things slow down, then I can't type in some windows, but I can type (although the text shows up slowly) in others, and I can minimize some but not all windows, and then gradually I can't do anything in the guest and I need to reboot the guest.

Now I have 2 CPUs and VirtualBox 4.0, and I haven't noticed the problem, but I'm scared to raise the number of CPUs since the crash is quite annoying. However, performance is definitely slower with 2 CPUs than with 4.

Any updates on solutions to this perplexing problem?

comment:40 Changed 3 years ago by swoter

VirtualBox: 4.0.0-69151
Hardware: Core i7 970
Host: Windows 7 x64
Guest: Ubuntu 10.10 x64
Problem: Ubuntu freezes when using 5,6,7,8,9,10,11,12 virtual processors!
Note: Ubuntu 10.10 x64 works stably with 12 processors in native installation.

comment:41 Changed 3 years ago by hanasaki

config0: seeing this on fedora 11 32bit host(4core intel) with ubuntu 10.10 32 guest (2cpu) config1: seeing this on ubuntu 10.10 64bit (2core) with ubuntu 10.10 32bit guest (2cpu) searching revealed that guest kernel option nohz=false has helped some. This seems to have helped some systems of mine with config1 however one running hudson and apacheds still locks at times.

comment:42 Changed 3 years ago by chrisyunker

I had the _exact_ same experience as described the report above.

Virtualbox 4.0.0 r69151 I'm running Windows 7 x64 host OS. The guest OS is Ubuntu 10.10 x64. I'm running the image at 3 CPUs when I saw the problem (Never saw the problem with 1 CPU, however I didn't really run it that long to be sure) PIIX3 chipset (default config).

Note: I noticed a newer version of Vbox, even though when I "check for newer version" it says I'm running the latest. So I'll see if that fixes the probem. Also, I'll try switching to ICH9 chipset to see if that helps.

comment:43 Changed 3 years ago by flyerlevrai

Same issue here with window 7 32bits (Host) and Ubuntu 10.10 32 bits (guest) when I assign 2 cores to the guest on an intel core2 duo p8800.

The VM is stable if I decrease the guest to one core.

comment:44 Changed 3 years ago by McMagnus

Having the same issue here:

Vaio Z i7 M620 6GB Windows 7 64 bit host

Ubuntu 10.4 guest with 2GB RAM and 4 cores assigned.

It sometimes happens after a long period of sleep/hibernate such as overnight. I often save the guest state and sleep/hibernate the host. Then the next morning I resume the guest and after a few minutes - several hours, it freezes gradually like described here. It has also happened if I sleep/hibernate the host without first saving the guest state.

It just happened and I see some more info. I can switch between Window/fullscreen, but I see nothing in seamless mode (except the tiny menu), no scale mode either. And another thing, if I hover the mouse over an icon in the guest's menu bar it lights up and it shows a tooltip, so the guest isn't completely dead. But key strokes doesn't seem to get there. If I activate the window, ALT+TAB doesn't show anything.

If I now click the terminal icon in the guest's menu bar, it depresses but no terminal is opened. After that, it's even more dead and doesn't highlight the icons anymore. However, the tooltip over the resource manager icon in the menu bar still works and even the graphics in the icon still scrolls (eventhough it's pretty hard to make it show anything else than 0% CPU)

Annoying bug, but very hard to reproduce reliably. Let me know if I can try a debug version if you want more info.

comment:45 Changed 3 years ago by xic1971

I had the same issue with

CPU: Core i3-540 VirtualBox: 4.0.2 Host: Windows 7 x64 Guests: Ubuntu 10.04/Debian 6.0

It happened if I assigned two cores to the guest. It would freeze or crash sooner or later with the symptoms described as above. The keyboard went first and then everything stopped. One core would be OK.

I solved the problem by booting the guest with acpi=off.

One observation is that this only happens to Intel CPUS. I have two other AMD PCs (Phenom X4 and Phenom II X4) and they are fine with the same setup. So it might have something to do with Vt-x. Hyper-threading does not seem to be the problem since this happens to Core2Duo (no HT) as well.

comment:46 Changed 3 years ago by jr

Same issue

CPU: Intel i7-870 VirtualBox 4.0.2 Host: Windows 7 x64 Guest: Ubuntu 10.10 x64

comment:47 Changed 3 years ago by jr

Workround with starting the guest Linux system with acpi=off works fine for me.

comment:48 Changed 3 years ago by frank

And your guest still detects more than one processor with ACPI off and it runs stable?

comment:49 Changed 3 years ago by jr

@frank Yes, it detects all assigned processors and runs stable.

Changed 3 years ago by IPW

cat /proc/cpuinfo for IPW

comment:50 Changed 3 years ago by IPW

Same problem, Would run for maybe a few hours before quite a rapid slow down and then freeze when using more than one cpu.
Booting with acpi=off and now no problems yet. (uptime 1 day 10 Hours)

Intel Core2 Duo P8400 Windows XP 32bit Guest
Fedora 13 guest
cat /proc/cpuinfo attached attachment:vbox_cpus.txt Download

comment:51 follow-up: ↓ 53 Changed 3 years ago by IPW

Sorry, I meant to say Intel Core2 Duo P8400 Windows XP 32bit host

comment:52 follow-up: ↓ 56 Changed 3 years ago by hwti

Booting with nolapic_timer kernel option solved the problems for me.

VirtualBox 4.04 Intel Core i7 920
Host : Windows 7 x64
Guest : Ubuntu 10.10 x64

comment:53 in reply to: ↑ 51 Changed 3 years ago by IPW

Tried VirtualBox 4.04, still a problem. However, I had the System Activity dialog open at the time of the lockup and noticed that several of processes displayed the CPU% as 'disk sleep'. Perhaps this reveals something about the lockup mechanism.

comment:54 in reply to: ↑ description Changed 3 years ago by lnoland

I had this problem with Virtualbox 4.02 r69518, Windows 7 64-bit host and Ubuntu 10.10 guest. with 2 to 4 processors, nested paging on or off, I would get the freeze with identical symptoms as described. It has been running rock-solid since I changed to 1 cpu.

My virtual machine is running a mythtv backend, and one of the things I noticed was that the most common (but not the only) time it would freeze was within a few minutes of beginning a recording while other recordings were in process (which may or may not have begun about the same time). So, this would be a time of high disk activity (the recordings store to NFS drives so most of the disk activity is really network activity, but I understand that during recording a "seek table" is built in the local database which would mean regular database updates for each show recording), high network activity (in addition to the NFS activity, my capture devices are HDHomeRun units which are addressed by their own IP), and possibly, a time where it was transitioning from a mostly idle state.

comment:55 Changed 3 years ago by ezs

Turning off ACPI seemed to work for me as well. I did it using VBoxManage modifyvm <vmname> --acpi off. After I did that, for some reason I had a lot of difficulty using my mouse in the guest OS (Ubuntu 10.10 64 bit). I then upgraded to the latest version of VirtualBox and that problem went away.

However, now I have a small problem whenever I invoke a shutdown from the guest OS - it freezes just before actually shutting down. I guess this has something to do with ACPI being disabled. Anyway, I can log off normally, and then shutdowning from the login screen it seems to be safer.

However, this just shows that there is still a lingering bug here with VirtalBox and ACPI. The best solution would be a bug fix instead of the workaround of turning off ACPI. Is there any status regarding solving this problem with another release of VirtualBox?

comment:56 in reply to: ↑ 52 ; follow-up: ↓ 58 Changed 3 years ago by dmjm

Replying to hwti:

Booting with nolapic_timer kernel option solved the problems for me.

VirtualBox 4.04 Intel Core i7 920
Host : Windows 7 x64
Guest : Ubuntu 10.10 x64

Worked for me too with all 8 virtual cpus allocated. Thanks!

VirtualBox 4.0.4
Xeon W3530
Host: Windows XP
Guest: Ubuntu 10.10 x32

To save others time, for ubuntu 9.10 or later which use grub2 the change is:

sudo gedit /etc/default/grub

set item like this:

GRUB_CMDLINE_LINUX_DEFAULT="nolapic_timer quiet splash"

save and exit gedit, then

sudo update-grub

Restart, that's it

comment:57 Changed 3 years ago by frank

Interesting. Could you post the output of 'dmesg' from the guest? Please add 'apic=debug' to the guest kernel command line. Then boot the VM once with 'nolapic_timer' added, once without. I would be interested in the two resulting logs.

Changed 3 years ago by hwti

dmesg output with "apic=debug" kernel command line

Changed 3 years ago by hwti

dmesg output with "apic=debug nolapic_timer" kernel command line

comment:58 in reply to: ↑ 56 ; follow-up: ↓ 59 Changed 3 years ago by dmjm

Replying to dmjm: Damn, forget that advice, still get freezes. Dropped down to 1 physical CPU (2 virtual processors) and no more freezes. Very annonying bug this one as I've got long running builds that run heaps faster using concurrency...

comment:59 in reply to: ↑ 58 ; follow-up: ↓ 60 Changed 3 years ago by dmjm

Replying to dmjm: Ok tried again but turned off acpi using VBoxManage and worked GREAT with 8 virtual processors without a freeze under the load that provoked a freeze before. Still good after 24 hours. So in detail, don't make those changes to /etc/default/grub in the vm, rather on the host machine run this command:

VBoxManage modifyvm <VM_NAME> --acpi off

comment:60 in reply to: ↑ 59 Changed 3 years ago by hwti

Replying to dmjm: I can't boot with ACPI disabled, it stops when starting VM additions. But I never got any freeze with nolapic_timer boot option.

comment:61 Changed 3 years ago by topse

In my setup disabling ACPI the one or the other way does not help. First it looks like its getting better, then I start my compiler (project with >1Mio lines of code with make -j8), and sooner or later I get into freeze...

Host: Core i7 Q720, Win7-64 with 8GB Guest: Ubuntu10-10 all updates, 2GB, 4 or 8 cores - is the same, 3D activated, ACPI off, kernelparameter "nolapic_timer" set.

Is there really no developer who is able to reproduce the problem?

comment:62 Changed 3 years ago by dschaefer

And shouldn't this be marked critical? This bug has forced me off of VirtualBox to a competitor product that I'd rather not be using. I'm a big fan of vbox, but this bug leaves it useless for me. It's a pretty sad situation.

comment:63 Changed 3 years ago by McMagnus

To the folks not seeing any improvement even after using nolapic_timer boot option, I think there are two different issues here, and you should probably search for a solution in some other thread, or start a new one. The solution here might be for a different issue than you're having.

For me, I enabled the nolapic_timer options 3-4 weeks ago, if not more, and I've never seen the problem since. And yes, I've compiled using lots of processes, usually with -j4 cause I use a 2x2 i7 620 CPU, but I can use -j8 as well. When I do, both the guest and the host becomes pretty sluggish during the compilation (which takes ~4 minutes), but after that, it's back to normal again. This is nothing I'd blame VBox for but is quite natural.

Since you mentioned compiling with lots of processes, I don't think it's the same issue because for me, hard load was never a trigger for the problem. The trigger was hibernation/save machine state, and when getting back, the problem could pop up in very low load, doing almost nothing at all. It just suddenly started to deteriorate.

Now, I've used the same guest session for almost 2 weeks, saving the machine state every night. That would have been impossible not using the solution presented here.

comment:64 Changed 3 years ago by dschaefer

But what are the side affects of nolapic_timer? I've seen various reports of mice not working and such.

comment:65 Changed 3 years ago by frank

nolapic_timer should be safe to use. If this really helps (can more users confirm this?) a reason could be that the one-shot mode of the local APIC does somehow misbehave.

comment:66 follow-up: ↓ 71 Changed 3 years ago by frank

hwti, did you explicitly enable HPET for your VM?

comment:67 Changed 3 years ago by frank

McMagnus, could you attach a dmesg from your guest kernel when you boot with nolapic_timer?

comment:68 Changed 3 years ago by dschaefer

I've given nolapic_timer a try and it does seem to be working. 6 virtual CPUs. It's good to be back :).

Note that I even got the hang just booting off the Fedora 14 64-bit Live ISO. Setting nolapic_timer at the grub screen got me through it.

comment:69 Changed 3 years ago by frank

Same applies to you, please attach the output of "dmesg" from your guest kernel with nolapic_timer passed.

comment:70 Changed 3 years ago by frank

Erm, make that "apic=debug nolapic_timer" please.

Changed 3 years ago by dschaefer

This time with the apic=debug setting really turned on.

Changed 3 years ago by McMagnus

As requested by frank

comment:71 in reply to: ↑ 66 Changed 3 years ago by hwti

Replying to frank:

hwti, did you explicitly enable HPET for your VM?

No, it seems that HPET is always enabled for ICH9, even if it's disabled in the config file.

I will try to check with PIIX3 with and without HPET, as soon as the VM becomes unstable again. Today it's stable, even without nolapic_timer. It's really strange since yesterday I had many freezes on boot. Perhaps something linked with the host, but I've no idea.

comment:72 Changed 3 years ago by hwti

Here are some results without nolapic_timer, with 8 virtual CPUs.
It could perhaps be different issues, but I never had these problems with only 1 CPU.


HPET enabled

1) VM frozen for several seconds, with high host CPU usage
Errors on ata2 (PATA controller with only the virtual CD-ROM drive connected, no image mounted)

[  867.840131] ata2: lost interrupt (Status 0x41)
...
[  879.210145] ata2: EH complete

See ata_errors.hwti.txt

2) VM frozen for several seconds, with high host CPU usage
Errors on ata3 (SATA port 0, AHCI)

[   47.961999] ata3.00: exception Emask 0x0 SAct 0x3 SErr 0x0 action 0x6 frozen
...
[   52.142240] ata3: EH complete

See ata_errors.hwti.txt


HPET disabled

3) Freeze when compiling with 16 processes, host CPU stays at 100%
Nothing in the logs after reboot, and it had to fix a few ext4 errors (EXT4-fs (sda1): ext4_orphan_cleanup: deleting unreferenced inode xxxx)

4) Freeze on shutdown, host CPU stays at 75%
There is a segfault, but I don't think it could cause the freeze.

[  102.152977] show_signal_msg: 27 callbacks suppressed
[  102.152980] polkit-gnome-au[1525]: segfault at 7375424c ip 00007f65d9fcb1c8 sp 00007fffea4bb7d0 error 4 in libglib-2.0.so.0.2600.1[7f65d9fa2000+e0000]
Kernel logging (proc) stopped.

5) segfaults
When compiling, I sometimes get a segfault. If I launch it again, I will get several other segfaults easily. But after a reboot everything is fine.

Changed 3 years ago by hwti

ata errors seen with HPET enabled

comment:73 Changed 3 years ago by dschaefer

Speaking of segfaults. I am getting the same with a large parallel build with nolapic_timer enabled. (Don't know what HPET is so I'll say it's at the default value). After chugging along fine for a while, gcc gets an internal error and then the other jobs start failing in similar ways and sometimes in a binutils tool.

Got to get some work done so switch away again :(

comment:74 Changed 3 years ago by lnoland

After several others reported success using the nolapic_timer kernel option, I decided to try it. I added the option and increased my CPUs on my VM to 4. While it worked differently than when I had used 4 CPUs without the option, I'm back to leaving the option off and one CPU. With the opton set, I didn't have the problem of the OS freezing -- instead I had applications freezing, and if I tried to reboot the VM, it would fail to reboot, usually citing that it could not stop the guest additions. I would have to reset the VM in order to reboot. Since I am running MythTV in the VM, between reboots I would be lucky if I got one whole recording -- usually there would be two or three with a few minutes recorded and then something in MythTV would lock up and that would be the end of it until the next reboot.

I think I will stick with one CPU until you guys get this sorted.

  • Les

comment:75 in reply to: ↑ 1 Changed 3 years ago by tmarkus

Host: win7-64, 32gb ram total Guest: Ubuntu 10.10, 16gb ram VB: 4.0.6

I am also having the issues reported by others. I've tried all the acpi-related solutions mentioned previously, but am still affected by this bug. The number of occurrences seem to be proportional with the number of CPUs I assign:

1 CPU = stable 2 CPU = freezes every 2-3 days 4 CPU = freezes 1-2 a day

comment:76 Changed 3 years ago by topse

... 8 CPU: freeze when trying to install Ubuntu10.10

comment:77 Changed 3 years ago by codeslingercompsalot

possibly related to bug #8511

comment:78 Changed 3 years ago by frank

Please retry with VBox 4.0.10. It contains timer fixes which should affect especially Linux SMP guests.

comment:79 Changed 3 years ago by IPW

Looking promising with 4.0.10 running now with 2 vcpus for 1 day and 6 hours

comment:80 Changed 3 years ago by topse

Hi, I also had a good run on 8 CPU's over night with some video encoding tasks... I am sure that 4.0.8 would have freezed here...

comment:81 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Let's close this one, feel free to reopen if you experience similar issues with VBox 4.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use