VirtualBox

Ticket #8429 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Windows XP Guest suddenly resets after starting Altium Designer => Fixed in 4.0.6

Reported by: DK707 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

This bug may be the same as #8191. I am reporting it as new as it occurring in VirtualBox 4.0.4 rather than 4.0.2.

When I start Altium Designer, the Windows XP Guest resets itself and reboots spontaneously. This is a new problem that started when I upgraded to VirtualBox 4.0.4. I have not tested previous Version 4 releases. Altium Designer has been working properly in the 3.2.X versions.

I have done the following tests: Please note that each test was done independently.

1) Disable 2D acceleration.
Result -> Guest still resets/reboots spontaneously.

2) Disable the Preview Window
Result -> Guest still resets/reboots spontaneously.

3) Change the Windows XP display properties from 32bit to 24bit
Result -> Guest works OK -- NO REBOOTS

4) Change the windows XP display properties/advanced/Hardware Acceleration to NONE
Result -> Guest works OK -- NO REBOOTS

When the guest reboots after one of these events, I get a dialog box from Windows XP indicating "The system has recovered from a serious error" and a minidump is created. I have attached a zip file of the minidump along with the usual VirtualBox log file.

Attachments

VBox.log Download (75.2 KB) - added by DK707 3 years ago.
winerr.zip Download (24.5 KB) - added by DK707 3 years ago.
MiniDump after Guest Reboots
VBox.2.log Download (58.0 KB) - added by fmiles 3 years ago.
requested log file
VBox_consolidated.log Download (126.2 KB) - added by webfors 3 years ago.
VB log for the past day in which 3 resets happened.

Change History

Changed 3 years ago by DK707

Changed 3 years ago by DK707

MiniDump after Guest Reboots

comment:1 Changed 3 years ago by sunlover

Thanks for the minidump. It shows that the crash does not involve VBox drivers. The crashing process is explorer.exe, the crashing module is nt.

Could you please check if the crash is still reproducible if you use 3.2.12 guest additions in the VM:

 http://download.virtualbox.org/virtualbox/3.2.12/VBoxGuestAdditions_3.2.12.iso

comment:2 Changed 3 years ago by bjuric

If this is of any help...

Windows 7 (32bit) also resets with Altium. In XP setting compatibility to win98 works (didn't try with Win7).

comment:3 Changed 3 years ago by DK707

I reverted to the 3.2.12 version of the guest additions and the reset/rebooting problem has gone away. This is with all of video settings set to their normal value. i.e. 32bit color depth, 2D acceleration on.

The problem is definitely being triggered by the 4.0.4 Version of the guest additions.

comment:4 Changed 3 years ago by sunlover

Thank you for testing. The problem has been reproduced here.

comment:5 Changed 3 years ago by itdaniher

This is an issue relevant to me as well. Duplicated on 4.0.4/XP with guest additions installed.

comment:6 follow-up: ↓ 7 Changed 3 years ago by sunlover

comment:7 in reply to: ↑ 6 Changed 3 years ago by DK707

Replying to sunlover:

Please test if the new additions fix this:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r70281.iso

Version "4.0.5r70281" of the Guest additions works well. I would like to thank you for fixing this issue so quickly.

comment:8 Changed 3 years ago by frank

  • Summary changed from Windows XP Guest suddenly resets after starting Altium Designer to Windows XP Guest suddenly resets after starting Altium Designer => Fixed in 4.0.6

Thanks for the feedback!

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:10 Changed 3 years ago by fmiles

  • Status changed from closed to reopened
  • Resolution fixed deleted

Altium Designed causes my Windows XP guest to suddenly reset: VirtualBox 4.0.8/r71778, with current Guest Additions and 2D/3D acceleration turned on or off.

comment:11 follow-up: ↓ 12 Changed 3 years ago by sunlover

fmiles, you should attach VBox.log of the session where Altium Designer caused the Windows XP VM reset.

Changed 3 years ago by fmiles

requested log file

comment:12 in reply to: ↑ 11 Changed 3 years ago by fmiles

Replying to sunlover:

fmiles, you should attach VBox.log of the session where Altium Designer caused the Windows XP VM reset.

Attaching...

comment:13 Changed 3 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

fmiles, you still have guest additions 4.0.4 in the guest. And the problem has been fixed in 4.0.6. So please update the guest additions.

comment:14 Changed 3 years ago by fmiles

Thanks for the pointer.

However this is very strange. What I had installed was:

virtualbox-4.0_4.0.8-71778~Debian~squeeze_amd64.deb

Virtualbox confirms this when I click on File/Extensions - it indicates 4.0.8, not 4.0.4. When I scan my system for packages, the older extension packages are listed as "deinstalled".

I have uninstalled Altium (long story). Is there some other way that I can test whether I have remnants of 4.0.4 in my system?

comment:15 Changed 3 years ago by frank

sunlover is referring to the Guest Additions, not the VirtualBox package. You have to update the Guest Additions by installing them again when you booted your VM. The Guest Additions is a bundle of services and kernel drivers for the guest kernel which allows the guest kernel to better communicate with the VMM.

comment:16 Changed 3 years ago by sunlover

You have to install 4.0.8 guest additions in your "win_xp" guest. Usually it is enough to start the VM using the VirtualBox frontend and then select "Devices/Install Guest Additions..." menu item.

comment:17 Changed 3 years ago by fmiles

Ooopppss, sorry, cut/pasted the wrong filename. It was:

Oracle_VM_VirtualBox_Extension_Pack-4.0.8-71778.vbox-extpack

The rest of my note was correct.

comment:18 Changed 3 years ago by frank

We are NOT talking about the Extension Pack but about the Guest Additions! The Extension Pack is installed on the host, the Guest Additions are installed into the guest!

comment:19 Changed 3 years ago by fmiles

Ahhh... ok, my bad, didn't understand that these were different things. I will correct that. Thanks for the clarification.

comment:20 Changed 3 years ago by webfors

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopening this issue. Experiencing random resets with Ubuntu 11.04 and VirtualBox 4.0.12. I've been running VB for a while now on several hosts, including natty for the past couple of months with no problems. Now the xp guest will reset randomly. Last reset was overnight. I went to bed, woke up and the VM was reset with the same message/error as indicated in this ticket.

I've attached my vbox.log for reference. So far I've disabled hardware acceleration, including all 2d/3d accelerations. Found some references in the vbox log regarding the preview window so I have also set the polling to 0 to disable.

I've confirmed guest additions are current, as I'm good about that after every VB update.

Changed 3 years ago by webfors

VB log for the past day in which 3 resets happened.

comment:21 Changed 3 years ago by sunlover

webfors, if you can start Altium Designer at all, then this is a different issue. You said that you have disabled "hardware acceleration, including all 2d/3d", you are talking about the VM settings, right?

Did you change anything in the XP guest? What applications were running in the guest when the reset happened?

comment:22 Changed 3 years ago by webfors

My apologies, never used Altium Designer. Yes, in the VB settings for the VM, along with disabling all hardware acceleration inside the guest.

I had several programs running. Outlook, IE (with a dozen windows open), VMware vsphere to manage a remote enterprise cluster environment, Avamar client to manage remote backups for this same environment, Pidgin, MS Excel.

If I need to open a new ticket please let me know. The good news is I haven't had a reset in 24 since disabling the VM preview polling.

Let me know if you see anything obvious in the logs. If not I'll wait this out and open a new ticket if it happens again.

Thanks!

comment:23 Changed 3 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

Of course it is better to create new tickets for new issues. The problem described in this ticket has been fixed. Please create a new ticket for the new issue.

Unfortunately there is nothing obvious in the log. Could you please verify if disabling the preview really affects the VM? Do not change any other VM settings and try to run the VM for a couple of days with disabled preview and then with enabled. Thanks!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use