VirtualBox

Ticket #8122 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Display corruption on x11 guests, no 3D -> fixed as of 25.01.11, see #8180 for 3D issues

Reported by: sej7278 Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.2 Keywords: Ubuntu, display, black, corrupt
Cc: Guest type: X11
Host type: other

Description

Frequently windows in my Ubuntu 9.10 64-Bit guest (with GA's installed) are not redrawn properly - they are just replaced with solid black squares. If I minimize+maximise the VirtualBox window it redraws it properly, but shortly afterwards it happens again.

Its not the whole display, but individual windows and panels.

Fedora 14 64-Bit host with extpack installed. Nvidia graphics drivers, no Compiz or anything, 2D/3D acceleration is disabled.

The same VM worked fine on the same host with 4.0.0

Attachments

VBox.log Download (75.6 KB) - added by sej7278 3 years ago.
Perhaps "Display::handleDisplayResize(): Warning: resize postponed." is relevant.
Screenshot-Ubuntu 10.4 [Running] - Oracle VM VirtualBox.jpg Download (80.1 KB) - added by rumen 3 years ago.
3d disabled on the guest - Looks Normal
Screenshot-Ubuntu 10.4 [Running] - Oracle VM VirtualBox.2.jpg Download (80.1 KB) - added by rumen 3 years ago.
3d disabled on the guest - Looks Normal
Screenshot-Ubuntu 10.4 [Running] - Oracle VM VirtualBox- 3D-enabled.jpg Download (136.8 KB) - added by rumen 3 years ago.
3d enabled in the guest - wired colors and the window contents remain when the window is moved

Change History

Changed 3 years ago by sej7278

Perhaps "Display::handleDisplayResize(): Warning: resize postponed." is relevant.

comment:2 Changed 3 years ago by rumen

I have the same problem with Ubuntu 10.10(x64) host and 32bit Ubuntu 10.04 LTS guest. It looks like that by disabling the visual effects on host System->Preferences->Appeareance the problem started to appear less often, but still it is very annoying.

comment:3 Changed 3 years ago by sej7278

i'm not using compiz effects, reverting back to 4.0.0 fixes it so it is a 4.0.2 regression

comment:4 Changed 3 years ago by michael

Did you try 1) disabling 3D for the guest if relevant and 2) seeing if using 4.0.0 or 4.0.2 Additions makes a difference? There is at least one change to the Additions which might be relevant here. The change was made rather late before the release (my fault) and turned out to need additional changes to the main code to work properly.

comment:5 Changed 3 years ago by sej7278

2d/3d are not enabled in the guest.

i've not tried using 400 additions on 402 as i've had to revert to using 400 for now.

comment:6 Changed 3 years ago by michael

comment:7 Changed 3 years ago by sej7278

don't have an fc14_x86_64 rpm of that do you (just makes package management easier)?

comment:8 Changed 3 years ago by sej7278

nevermind, i installed the .run for now, just removed the 400 rpm.

it does seem to have solved the problem - even with the 400 additions installed (or 403) so i guess its the main code not the ga's that's the problem.

the fonts in the gui look horrible though (small, squashed, not antialiased) perhaps as its not packaged for fedora's qt4.

Changed 3 years ago by rumen

3d disabled on the guest - Looks Normal

Changed 3 years ago by rumen

3d disabled on the guest - Looks Normal

Changed 3 years ago by rumen

3d enabled in the guest - wired colors and the window contents remain when the window is moved

comment:9 Changed 3 years ago by rumen

The problem with no 3D seems to be fixed. Thanks! But I went a little bit further;) I enabled the 3d acceleration for the guest and the problem is there again. See the Screenshots. I am not sure it has something to do with this very problem but it seems related.

comment:10 Changed 3 years ago by michael

sej7278: glad that has solved the problem. In fact as I said, it is most likely not a problem in the main code or the Additions, but rather that the two got out of sync, and the 4.0.2 Additions ended up depending on main code that wasn't complete.

rumen: that sounds like the fix is not yet complete, but as I am not very familiar with our 3D bits I will have to pass it on to someone who is.

comment:11 Changed 3 years ago by michael

Would you further be able to test if this Additions build in combination with 4.0.2 solves the problem?

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r69551.iso

And by the way, the reason for the strange fonts with the .run build is that that is a portable build which is supposed to work anywhere, and bundles its own copy of Qt which doesn't read the settings of the installed version properly.

comment:12 Changed 3 years ago by rumen

Hm... Something strange happened...

# sh ./Virtual.... uninstall

and then # dpkg -i virtualbox-4.0_4.0.2-69518~Ubuntu~maverick_amd64.deb

and there is nothing related to in /etc/init.d/

and vbox gui complains about missing DKMS... and advises to run /etc/init.d/vboxdrv

but it is not there any more... any idea?

comment:13 Changed 3 years ago by sej7278

yes the 4.0.2 rpm with the 69551 additions seems to work too - not tried 3d though as i don't use it.

comment:14 Changed 3 years ago by michael

rumen: you might try "purging" the Debian package and reinstalling. The dpkg database probably remembers that you used to have VirtualBox installed, so that dpkg doesn't install any configuration files (init scripts count as such).

sej7278: thanks for confirming that.

comment:15 Changed 3 years ago by rumen

Thank you michael, purging worked.

Also 4.0.2 with 69551 additions works (only with 3d disabled).

comment:16 Changed 3 years ago by synackfin

I have this problem on 4.0.2 with Windows Vista host and Ubuntu guest - trying with 69551 additions causes it to crash when the screensaver comes up (instead of having a stuck black screen).

comment:17 Changed 3 years ago by synackfin

Hmm, upon retrying, it seems like 69551 additions w/ 3D disabled solves the problem. Not sure what was different last time.

comment:18 Changed 3 years ago by michael

  • Host type changed from Linux to other
  • Summary changed from Display corruption on Linux guest to Display corruption on Linux guest -> fixed as of 25.01.11

The updated r69551 build is now publicly available as  http://download.virtualbox.org/virtualbox/4.0.2/VBoxGuestAdditions_4.0.2-update-69551.iso. Just to be clear, this build fixes problems with X11-using guests when virtual screens are disabled, which often happens at the same time as the guest goes into screen saving mode, although it is actually a separate event and can also happen at other times. This build does not address specific issues which occur when 3D is enabled. I will mark this ticket as fixed though, and refer to #8180 for the 3D-related issues.

comment:19 Changed 3 years ago by michael

  • Guest type changed from Linux to X11
  • Summary changed from Display corruption on Linux guest -> fixed as of 25.01.11 to Display corruption on Linux guest -> fixed as of 25.01.11, see #8180 for 3D issues

comment:20 Changed 3 years ago by michael

  • Summary changed from Display corruption on Linux guest -> fixed as of 25.01.11, see #8180 for 3D issues to Display corruption on x11 guests, no 3D -> fixed as of 25.01.11, see #8180 for 3D issues

comment:21 follow-up: ↓ 22 Changed 3 years ago by mooninite

Not sure if this is the same issue, but on my Fedora 14 x86_64 host I get display corruption in a Fedora 14 x86_64 guest when I move a window. 3D is disabled. I have tried the 4.0.3 guest additions listed on the Download page but they did not help. The 4.0.0, 4.0.2, and 4.0.3 GA all result in the same problem.

A Fedora 14 x86 guest does not get display corruption when I move a window, so it seems to be a 64-bit guest issue.

comment:22 in reply to: ↑ 21 ; follow-up: ↓ 23 Changed 3 years ago by michael

Replying to mooninite: It doesn't sound like the same thing. Could you please open a new ticket and attach a screenshot and the guest's /var/log/Xorg.0.log?

comment:23 in reply to: ↑ 22 Changed 3 years ago by mooninite

Replying to michael:

It doesn't sound like the same thing. Could you please open a new ticket and attach a screenshot and the guest's /var/log/Xorg.0.log?

Done. Ticket 8198 created.

comment:24 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use