VirtualBox

Ticket #8180 (closed defect: fixed)

Opened 3 years ago

Last modified 6 months ago

With 3D acceleration enabled, screen blacked out or garbled

Reported by: mousecat Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by misha) (diff)

With 3D acceleration enabled, screen blacked out or garbled. If disable it, it works just fine. screen resolution used: 1280X800

Change History

comment:1 Changed 3 years ago by michael

Did you use other versions of VirtualBox prior to this? And if so, is this a new issue?

comment:2 Changed 3 years ago by mousecat

I have used and kept up with all the update from vbox main site. This problem is new to me. Right now I have to turn off the option that let the screen go to sleep in the power management section.

comment:3 Changed 3 years ago by leonid

Could you provide more details please such as: host log, exact guest os type, when does the screen corruption happen at os boot or when you run compiz or some other 3d application in guest?

comment:4 Changed 3 years ago by therion

Similar problem. Using VBox 4.0.6, Ubuntu 11.04 Desktop 64-bit version on a Macbook Pro host, guest additions installed, with the default Unity (3D-capable) interface...

Simplest way to reproduce it for me is to disable the screen saver, and set power management to sleep the display after 1 minute (these are within the Ubuntu guest, not the OS X host). The screen is garbled immediately upon "sleeping". Certainly not the only way, but this one is predictable.

Host log receives this when the display sleeps:

00:25:49.180 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:25:49.181 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:25:49.181 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=1440 h=774 bpp=0 cbLine=0x1680, flags=0x3 00:25:49.181 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes 00:25:49.181 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=1440 h=774 bpp=0 cbLine=0x1680, flags=0x3 00:25:49.181 Display::handleDisplayResize(): Warning: resize postponed. 00:25:49.191 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=1440 h=774 bpp=0 cbLine=0x0, flags=0x3

comment:5 Changed 3 years ago by frank

Are you working on a secondary host screen by any chance?

comment:6 Changed 3 years ago by therion

I'm not.

comment:7 follow-up: ↓ 9 Changed 3 years ago by therion

The problem is still there with 4.0.8, FYI.

comment:8 Changed 3 years ago by reece

I'm also getting garbled screen when attempting to use RealFlight G4.5 and Phoenix flight simulators.

The setup: HP dm4-1173cl (Core i5, integrated graphics) host Ubuntu 11.04, 64 bit guest Windows7, 32bit virtualbox 4.0.6 and .8. Guest Additions installed 1 monitor, tried 64MB and 128MB video memory, 2D and 3D acceleration enabled 1 physical monitor (laptop LCD) IO APIC NOT enabled PAE NOT enabled VT-x/AMD-v enabled

With RealFlight, I get what appears to be a garbled dialog box on a black background. With PhoenixRC, I get a white background (waited ~60s)

I'm using fullscreen.

I'll be happy to provide logs if that'll help.

comment:9 in reply to: ↑ 7 Changed 15 months ago by misha

  • Description modified (diff)

Replying to therion, mousecat & reece:

The problem is still there with 4.0.8, FYI.

Could you try if the issue is still there with the latest VBox 4.2.6 and 4.2.6 additions?
And if yes, please attach a VM log here.

comment:10 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Please try VBox 4.3 and VBox 4.3 Guest Additions, and re-open if the issue persists, attaching a VM log file.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use