VirtualBox

Ticket #8094 (closed defect: fixed)

Opened 5 years ago

Last modified 2 weeks ago

VBox 4.0 Can't use same port for TCP & UDP forwarding -->fixed in SVN

Reported by: appyface Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by vushakov) (diff)

I posted my issue in the forum, Sasquatch confirmed and suggested I open a bug ticket here. Please see this thread:

 http://forums.virtualbox.org/viewtopic.php?f=1&t=38093&start=0

I can't get 4.0 to use same port for both TCP and UDP port forwarding?

In 3.x versions this has been working well using VBoxManage (early versions used "setextradata", later versions using "modifyvm" as shown here):

VBoxManage.exe modifyvm "my_vm" --natpf1 "tcp_pf",tcp,,32512,,32512
VBoxManage.exe modifyvm "my_vm" --natpf1 "udp_pf",udp,,32512,,32512

Now with 4.0 I can only set both rules if ports are not the same. Sasquatch confirmed in the GUI that the second rule is discarded. VBoxManage gives error message on the second rule, stating it already exists.

Kind regards,

--appyface

Change History

comment:1 Changed 5 years ago by Hachiman

  • Summary changed from VBox 4.0 Can't use same port for TCP & UDP forwarding to VBox 4.0 Can't use same port for TCP & UDP forwarding --fixed in SVN

thanks for reporting, issue is fixed in svn.

comment:2 Changed 5 years ago by Hachiman

  • Summary changed from VBox 4.0 Can't use same port for TCP & UDP forwarding --fixed in SVN to VBox 4.0 Can't use same port for TCP & UDP forwarding -->fixed in SVN

comment:3 Changed 5 years ago by Hachiman

Thanks for reporting, issue is fixed in SVN.

comment:4 Changed 5 years ago by appyface

Awesome, thank you so much :-)

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 follow-up: ↓ 8 Changed 3 weeks ago by chad

This bug seems to affect vbox 5.0 possible regression

comment:7 Changed 2 weeks ago by vushakov

  • Description modified (diff)

comment:8 in reply to: ↑ 6 Changed 2 weeks ago by vushakov

Replying to chad:

This bug seems to affect vbox 5.0 possible regression

Any details? Works for me.

comment:9 follow-up: ↓ 10 Changed 2 weeks ago by sinzim

Same problem in 5.0, try adding two rules in the GUI which use the same port but different protocols. It fails in my case.

comment:10 in reply to: ↑ 9 Changed 2 weeks ago by vushakov

Replying to sinzim:

Same problem in 5.0, try adding two rules in the GUI which use the same port but different protocols. It fails in my case.

Thanks for being specific in your description. The problem indeed exists, but it's GUI problem. When the original bug was fixed, the GUI checks were not relaxed, apparently. You can use VBoxManage as the workaround.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use