VirtualBox

Ticket #8093 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Frequent crashes

Reported by: medeksza Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have setup some Windows XP SP3 virtual machines to help offload some tasks from my Windows 2003 server. Right now I run these virtual machine in headless mode on a Windows XP SP3 host. I don't need a gui so I start the VM using this command line: VBoxHeadless.exe -startvm "Hal Cloud Instance" --vrdp=off

However, I get frequent crashes at least every other day. They all crash with the same message: Faulting application vboxheadless.exe, version 0.0.0.0, faulting module ole32.dll, version 5.1.2600.5512, fault address 0x0002cdbd.

Attached is also the log for this VM, cutting off the bottom since the log is about 7 MB of the follow message appearing every second:

00:03:14.926 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={09eed313-cd56-4d06-bd56-fac0f716b5dd} aComponent={Display} aText={Could not take a screenshot (VERR_TRY_AGAIN)}, preserve=false

Could this be a bug of the --vrdp=off option?

Attachments

Hal Cloud Instance-2011-01-16-09-29-26.log Download (54.6 KB) - added by medeksza 3 years ago.
log
vbox.log Download (61.6 KB) - added by vadimrapp 3 years ago.

Change History

Changed 3 years ago by medeksza

log

comment:1 Changed 3 years ago by frank

Sounds more like a duplicate of #7966. Could you try  this test build?

comment:2 Changed 3 years ago by medeksza

I am running the new test build and it hasn't crashed yet after about 2 days of running so that's good. However, the log file still gets saturated with the "Could not take a screenshot" error every second if I use "--vrdp=off". I just don't use that option anymore but I suggest if you continue to offer this option to change this behavior.

comment:3 Changed 3 years ago by frank

Thanks for the feedback!

comment:4 Changed 3 years ago by vadimrapp

I have the same problem, crash with the same message

AppName: vboxheadless.exe AppVer: 0.0.0.0 ModName: ole32.dll ModVer: 5.1.2600.5512 Offset: 0002cdbd

and this is VirtualBox 4.0.4. The crash occured when the machine powered on.

comment:5 Changed 3 years ago by vadimrapp

correction: when the machine has powered off.

Changed 3 years ago by vadimrapp

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed with VBox 4.0.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use