VirtualBox

Ticket #8063 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VRDP external auth library path lookup fails (regression) => Fixed in SVN

Reported by: mooninite Owned by:
Priority: major Component: RDP
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I have a VM server running multiple guests of different OSes. The machine was running VirtualBox 3.2.12 for the past month with no issues. I used VRDP with authentication set to external and used my host user to login successfully.

After upgrading to 4.0.0 I can no longer use external auth. I must set it to "none" to be able to connect to the RDP session.

The Extension Pack is installed. The Machine Log shows that VirtualBox cannot find the VRDPAuth.so library. I attempted to place a symlink to it in /usr/lib/virtualbox but then it is linked to VBoxRT.so. Creating a symlink for VBoxRX.so in /usr/lib64 still fails somewhere else when I try to connect with RDP.

Host: Fedora 13 x86_64 fully up-to-date

Log excerpt (only users and computer names have been changed): 00:09:29.130 VRDP: New connection: 00:09:29.139 VRDP: Flags 0x0000001b 00:09:29.139 VRDP: Channel: [rdpdr] [1004]. Not supported. 00:09:29.139 VRDP: Channel: [rdpsnd] [1005]. Accepted. 00:09:29.139 VRDP: Channel: [drdynvc] [1006]. Accepted. 00:09:29.139 VRDP: Channel: [cliprdr] [1007]. Accepted. 00:09:29.201 VRDP: Client seems to be MSFT. 00:09:29.201 VRDP: Logon: COMPUTER (172.17.100.100) build 7600. User: [username] Domain: [DOMAINNAME] Screen: 0 00:09:29.202 AUTH: User: [username]. Domain: [DOMAINNAME]. Authentication type: [External] 00:09:29.203 AUTH: ConsoleVRDPServer::Authenticate: loading external authentication library 'VRDPAuth' 00:09:29.203 RTLdrLoadAppPriv: "/usr/lib/virtualbox/VRDPAuth.so" not found 00:09:29.203 AUTH: Failed to load external authentication library. Error code: VERR_FILE_NOT_FOUND 00:09:29.204 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={515e8e8d-f932-4d8e-9f32-79a52aead882} aComponent={Console} aText={Could not load the external authentication library 'VRDPAuth' (VERR_FILE_NOT_FOUND)}, preserve=false 00:09:29.204 AUTH: Access denied. 00:09:29.204 VRDP: Connection closed: 00:09:29.204 VRDP: Logoff: COMPUTER (172.17.100.100) build 7600. User: [username] Domain: [DOMAINNAME] Reason 0x0001.

Change History

comment:1 Changed 3 years ago by jey350

I have a similar bug under Windows. VRDPAuth is trying to be loaded instead of VBoxAuth by vboxwebsrv. It causes an issue with phpvirtualbox-4-2.

My workaround has been to duplicate VBoxAuth an rename it to VRDPAuth.

comment:2 Changed 3 years ago by mooninite

Still broken in 4.0.2. Same problem.

comment:3 Changed 3 years ago by ljones3

Still broken in 4.0.4. Same problem. Workaround still works. Thanks!

comment:4 Changed 3 years ago by frank

  • Summary changed from VRDP external auth library path lookup fails (regression) to VRDP external auth library path lookup fails (regression) => Fixed in SVN

Thanks for the report. That problem will be fixed in the next maintenance release.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 3 years ago by mooninite

I can confirm this is fixed. Thanks Frank, etc.!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use