VirtualBox

Ticket #8040 (closed defect: fixed)

Opened 3 years ago

Last modified 13 months ago

VirtualBox crashes when writing to a VHD disk

Reported by: Leolo Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Host OS: Windows 7 x64 Guest OS: Windows 2008 R2 x64 standard

The error occurs whenever I try to install Windows 2008 r2 Standard guest virtual machine onto a dynamic .VHD file. As soon as there is access to the disk, VirtualBox crashes.

The .VHD file was created using the Microsoft "Disk Management" administrative tool that comes with Windows. It's a 80 GB dynamicly growing file, currently about 9 gigs in size.

Details of the error: A problem caused the program to stop working correctly. Please close the program.

Windows Event log Application Error (Event ID 1000): Faulting application name: VirtualBox.exe, version: 4.0.0.0, time stamp: 0x4d12068f Faulting module name: VBoxDDU.dll, version: 0.0.0.0, time stamp: 0x4d120676 Exception code: 0xc0000005 Fault offset: 0x0000000000006560 Faulting process id: 0x31c Faulting application start time: 0x01cbaf99fdbe6478 Faulting application path: C:\PROGRA~1\Oracle\VIRTUA~1\VirtualBox.exe Faulting module path: C:\PROGRA~1\Oracle\VIRTUA~1\VBoxDDU.dll Report Id: 550fe08f-1b8d-11e0-9488-6cf049b76ab5

Attachments

VBox.log Download (41.1 KB) - added by Leolo 3 years ago.
windows event id 1000.txt Download (488 bytes) - added by Leolo 3 years ago.
windows event id 1000 (VBox 4.1.10.0).txt Download (1.7 KB) - added by landrey 2 years ago.

Change History

Changed 3 years ago by Leolo

Changed 3 years ago by Leolo

comment:1 Changed 3 years ago by aeichner

I'm not able to reproduce the crash. Could be fixed in the next maintenance release (see #7947) though you are not using any snapshots. Would be great if you could try again with the next maintenance release and report back. The bug can be avoided if you enable "Use host I/O cache" in the storage controller settings.

comment:2 Changed 3 years ago by Leolo

Yes, enabling "Use host I/O cache" does the trick! It works now!

Thanks!!

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still reproducible with VBox 4.0.2.

comment:4 Changed 2 years ago by landrey

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi,

I've found the same issue in VBox 4.1.10.0 The bug was very reproducible in VM with CentOS 6.2 64bit. The VM had dynamic virtual disk in VHD format with size = 76G. Also that VDisk was configured to work in write through mode.

Looks like switching controller to "Use host I/O cache" mode fixes it.

Andrey

Changed 2 years ago by landrey

comment:5 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

There were more VHD fixes in the meantime. Please reopen if still relevant with VBox 4.2.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use