VirtualBox

Ticket #7905 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Host-only network interface and DHCP doesn't work

Reported by: aevum Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

My host-only network interface doesn't get an IP address from the VBox DHCP server and times out after a while. My other NAT network interface does get an IP.

See also  http://forum.virtualbox.org/viewtopic.php?f=6&t=37402 and  http://forum.virtualbox.org/viewtopic.php?f=6&t=37414

Change History

comment:1 Changed 3 years ago by jrideout

I have the same issue on a windows 7 host, with Linux guest.

comment:2 Changed 3 years ago by Warhammer

I have the same issue. But I'm using Linux as host (OpenSUSE 11.3) and Windows XP SP3 as guest. I'm using VBox compiled from SVN - v.4.0.0 r35437.

Build-in DHCP server not working when I'm using Host-Only networking.

comment:3 Changed 3 years ago by misha

Could you clarify your issue a bit, namely when (at which stage) does your host adapter fails to get an IP? Is it on VM start or on host system start or whatever?
I'm asking because VBox DHCP server gets started only when VM using the corresponding host-only adapter is started. This is why it is expected that the host-only adapter will fail to get a dynamic IP config any time before that. And the right way is to have the host-only configured statically.

comment:4 Changed 3 years ago by boogha

I have this same issue, Win XP SP3 Host and a Linux Guest (OEL 5.5). When I go and check the Network Preferences in VM VirtualBox Manager my Host-Only Interface removes itself and re-installs on windows.

comment:5 Changed 3 years ago by peitschie

I'm still seeing this problem with 4.0.2.

The problem is that the VM starts without issue, and the network appears to be trying to connect, but no DHCP address is ever assigned. The Windows guest eventually gives up and assigns a private IP, complaining about potentially limited connectivity

In my case I'm running a Windows XP Guest inside a Windows XP host (both 32-bit)

comment:7 Changed 3 years ago by tha492s

I have the same problem with WinXP as host with 4.0.0. The patch works, but it will hopefully be corrected soon in the product.

comment:8 Changed 3 years ago by misha

We've reproduced the issue here and have a fix for it already. We should be able to provide you with a test build later today or tomorrow.

comment:9 Changed 3 years ago by misha

To all having DHCP server problems with host-only: here is a link to the test build with the fix:  http://www.virtualbox.org/download/testcase/VirtualBox-2011-01-21-19-21-01-win-4.0-rel-4.0.3-r69593-MultiArch.exe

Please give it a try.

comment:10 Changed 3 years ago by tha492s

I installed the test version above, and everything seemed to work with my host-only machines. Still testing, but my first impression is that the error is fixed. Thanks a lot!

comment:11 Changed 3 years ago by orev

I also tried the patched version and I am now able to use DHCP on the host-only adapter again. Thanks for the quick response to this.

I do notice that the installation wipes out the custom configuration for the Host-Only adapter (like IP address, etc...), but that might be by design, or at least a different bug.

comment:12 Changed 3 years ago by dikujack

I have the same problem with VB 4.0.2, a win7 (64 bit) host and Oracle Linux guest. I would like to try the testbuild above, but the link dos not work anymore. Can anyone help me with a new link?

Thanks!

comment:13 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use