VirtualBox

Ticket #7872 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

heavy load caused by: "VBoxManage guestcontrol execute --wait-for exit ..."

Reported by: Paolo Virtual Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

when waiting for a blocking program in the guest called by

"VBoxManage guestcontrol execute --wait-for exit ..."

there is a significant increase in CPU load on the host. This is caused by both processes VBoxSVC as well as VirtualBox, although the program in the guest does not cause any load within the guest. This behavior was observed, on Windows 7 and Linux hosts, with VirtualBox Versions 3.2.10, 3.2.12 as well as Beta 4.0.

Attachments

Load_in_Linux_gast.png Download (11.8 KB) - added by Paolo Virtual 3 years ago.

Change History

comment:1 Changed 3 years ago by Paolo Virtual

The bug is still persistent in Versions 4.0 and 4.02 as well as SVN-revision r35773.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #8235.

Changed 3 years ago by Paolo Virtual

comment:3 Changed 3 years ago by Paolo Virtual

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Unfortunately the load is still there, caused by VBoxService within the guest (see attachment).

comment:4 follow-up: ↓ 5 Changed 3 years ago by frank

Which additions version is that?

comment:5 in reply to: ↑ 4 Changed 3 years ago by Paolo Virtual

Replying to frank:

Which additions version is that?

We tried with the guest additions of Versions 4.0, 4.02 and meanwhile also SVN-revision r35820. To make it clear, the 'wait-for-exit' issues from #8235 are fixed, but the heavy load is still there.

comment:6 Changed 3 years ago by frank

r35831 should improve the behavior. This changeset will be included in the next maintenance release. The cause of the CPU load is busy waiting of VBoxManage for the termination of the guest process. Changing this would require an API change, therefore a change is not possible in short term.

comment:7 Changed 3 years ago by frank

4.0.4 contains a partial fix.

comment:8 Changed 3 years ago by cyxob

Execution guest programms without "waiting-for-exit" heavy loads CPU too. CPU is about 100% until the guest process off. The same process running in the virual machine manually does not load CPU more than 10%.

This bug is reproduced by CLI utility VBoxManage and by API load IGuest.executeProcess().

This bug does not still fixed by 4.0.4 virtualbox version.

comment:9 Changed 3 years ago by andy_9_9_9_9

In my case, version 3.2.10 still works. However. I just upgraded my system to squeeze. And somehow sequeeze does not work with 3.2.10 anymore (due to some NMI_WATCHDOG not found anymore). So now I am really stuck.

comment:10 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should be fixed in VBox 4.0.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use