VirtualBox

Ticket #7756 (reopened defect)

Opened 4 years ago

Last modified 4 weeks ago

Occasional Hang when saving machine state - data loss

Reported by: mcnaz Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

Hi there.

Occasionally Virtualbox fails to save the machine and hangs on 100% on the "... Saving the execution state of the virtual machine"

I am forced to kill the VirtualBox.exe process. This unfortunately corrupts the attached virtual disk and often leads to any work done during that session to be lost.

Host Windows XP SP2

Attachments

EDMS Dev-2010-11-23-12-10-46.log Download (89.9 KB) - added by mcnaz 4 years ago.
VBox.log.1 Download (99.0 KB) - added by impc 4 years ago.
Hang on shutdown after 5xx hours of running
ws111114-tailof-vbox.log Download (111.6 KB) - added by ws 3 years ago.
ws111114-procexp-threads.png Download (55.6 KB) - added by ws 3 years ago.
ws111114-stack-of-virtualbox.exe.txt Download (3.1 KB) - added by ws 3 years ago.
ws111114-stacks-of-some-other-threads.txt Download (2.6 KB) - added by ws 3 years ago.
Ubuntu Dev-2012-06-21-18-55-52.log Download (404.0 KB) - added by KLH 3 years ago.
log from hanging VM
Win7-Pro-XPSP3Guest.log Download (177.8 KB) - added by danf84 3 years ago.
shortened VBox.log.1 Download (68.0 KB) - added by JarrettBillingsley2 3 years ago.
shortened VBox.log.3 Download (95.7 KB) - added by JarrettBillingsley2 3 years ago.
shortened VBox.log.1.txt Download (40.9 KB) - added by christo 2 years ago.
aidanhs-VBox.log Download (69.7 KB) - added by aidanhs 2 years ago.
VBox42212.log Download (133.2 KB) - added by Petr Vones 2 years ago.
VirtualBox 4.2.12 close crash log
VBox - Copy.log Download (112.0 KB) - added by Marco2 2 years ago.
log file
selectorwindow.log Download (1.0 KB) - added by johnwesting12 23 months ago.
VBoxSVC.log Download (1.8 KB) - added by johnwesting12 23 months ago.
amica.log Download (7.3 KB) - added by AmicaNoctis 23 months ago.
VBox.log.suspend.issue.log Download (96.8 KB) - added by wacher 21 months ago.
E_ACCESSDENIED
Agile OEL 64 Agile932 OPLA CNM v3.00-2013-08-13-21-06-16.log Download (34.0 KB) - added by Marco2 20 months ago.
Log File
error.jpg Download (476.9 KB) - added by ncsome 20 months ago.
Process monitor trace
Logfile.CSV Download (33.2 KB) - added by ncsome 20 months ago.
processmonlogfile
reg.reg Download (1.2 KB) - added by ncsome 20 months ago.
registry entry
VBoxSVC.2.log Download (2.5 KB) - added by Chondroma 20 months ago.
Debian-2013-09-06-22-03-08.txt Download (67.2 KB) - added by Chondroma 20 months ago.
VBox.log.2.1 Download (121.8 KB) - added by wacher 18 months ago.
Log for the modified #57 comment
VBox - Copy (2).log Download (118.7 KB) - added by wacher 15 months ago.
VM log for crashed GUI
VBox - Copy (2).eventlog.txt Download (462 bytes) - added by wacher 15 months ago.
VM log for crashed GUI - eventlog entry
VBox.log_PRab_V4.3.6 Download (60.0 KB) - added by PRab 15 months ago.
VBox.log Download (64.7 KB) - added by Ancow 14 months ago.
VBox.log (Ancow)

Change History

Changed 4 years ago by mcnaz

comment:1 Changed 4 years ago by frank

Still relevant with VBox 4.0.4?

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:3 Changed 4 years ago by midix

This happened a week ago to me on Windows 7 Host with XP guest (both 32 bit) and just happened on Windows 7 Host with Vista guest. I am looking now at the "Saving the execution state" 100% message for an hour already. It has not fully hung, actually, I can move the message around and the guest window beneath the message is being redrawn normally (with the usual grayscale overlay which is visible on saving). It seems I'll have to kill VirtualBox.exe process again.

My log file looks really similar to the attached one: it has a bunch of messages at the end:

ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={The virtual machine is being powered down} aWarning=false, preserve=false

VirtualBox version 4.0.8. I will upgrade to 4.0.10. now and see if it occurs again.

comment:4 Changed 4 years ago by impc

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still relevant with VBox 4.1.2 Does not depend on running guest (happened with windows/linux)

Changed 4 years ago by impc

Hang on shutdown after 5xx hours of running

Changed 3 years ago by ws

Changed 3 years ago by ws

Changed 3 years ago by ws

Changed 3 years ago by ws

comment:5 Changed 3 years ago by ws

It has not fully hung, actually, I can move the message around and the guest window beneath the message is being redrawn normally with the usual grayscale overlay

I observed the same characteristics here:

virtualbox 4.1.4 r74291 Windows 7 x64 also using the following software: kaspersky antivirus, vmware-player 3

added some attachments with prefix "ws111114". (Stack traces were taken at different points in time.)

After saving these attachments I did the following (no attachments for the second instance!):

While application was not responding, i started a second instance and navigated to the 4th item ("Massenspeicher" in the German GUI). The content (with IDE-Controller and SATA-Controller) was not drawn and the second application stopped responding too. I stopped further investigation at this point.

comment:6 Changed 3 years ago by ws

BTW: I checked the logs of Kaspersky Anti-Virus 2011: No (false positive) threat was reported.

comment:7 Changed 3 years ago by ws

Also reappeared with

VirtualBox version 4.1.8 r75467 (and Oracle VM VirtualBox Extension Pack of the same version)

host: Windows 7 x64 without any anti-virus software installed

guest: ubuntu 11.10 32bit with current guest additions installed

Would a mini-dump created by sysinternals process explorer help in finding the bug?

comment:8 Changed 3 years ago by orand

This just happened to me with VirtualBox version 4.1.10 r76836. All the behaviors described above match what I'm seeing.

Host: Windows 7 x64

Guest: Windows Server 2003 32-bit

I then tried to save the state of another guest I had running and encountered the same issue.

Last edited 3 years ago by orand (previous) (diff)

comment:9 Changed 3 years ago by xerces8

4.1.12 Win7 host, Win XP guest

Hangs on close. The log has this line repeating about once each second:

00:57:57.102 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

comment:10 Changed 3 years ago by Marcus

This happens sometimes with me on VirtualBox 4.1.6

Host: Windows 7 x64

guests: Windows Server 2008R2, Windows Vista x32, Windows XP x32

comment:11 Changed 3 years ago by dracula

Same here. Host Windows 7 Pro 64b, Guest: Windows XP 32 Guest addons are installed. Happened to several machine on same host. Starting 4 guests at same time and try to close one after the other.

ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

Last edited 3 years ago by dracula (previous) (diff)

comment:12 Changed 3 years ago by frank

  • Description modified (diff)

Please attach a VBox.log file of such a VM session.

Changed 3 years ago by KLH

log from hanging VM

comment:13 Changed 3 years ago by KLH

I've also seen this problem. It seems to be most prevalent when the host machine is busy (high mem usage), but I have no real evidence for this.

This behavior has trashed several VMs of mine though.

Log attached.

comment:14 Changed 3 years ago by brooze

I have run into this case many times, and my conclusion is it has something related to peripheral device interrupt.

It happened when pc has serial-com device connect and plugout while save state machine.

I have no energe and time to reproduce it, maybe some guy can do it.

Last edited 3 years ago by frank (previous) (diff)

comment:15 Changed 3 years ago by progmars

I occasionally get the same problem on Windows 7 64 bit host with VirtualBox 4.1.12. There were no visible issues, why this might happen - enough free physical RAM, enough free disk space, no hardware plugged/unplugged during saving. Still cannot reproduce.

comment:16 Changed 3 years ago by danf84

Happened to me a few times with 4.1.20 and the stable version before that. Log "Win7-Pro-XPSP3Guest" attached. It got to 100% during "Saving State". Lots of access denied of some sort flooding the log while it's hanging.

Changed 3 years ago by danf84

comment:17 Changed 3 years ago by AnotherLife

Same here. I got this when it happened. Using version 4.1.20

01:31:51.151 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

comment:18 Changed 3 years ago by JarrettBillingsley2

Had this happen to me twice in the last week. I've attached the two relevant logs. I'm using 4.1.20, host OS is Win7 Ultimate x64, guest is 32-bit Linux.

Changed 3 years ago by JarrettBillingsley2

Changed 3 years ago by JarrettBillingsley2

comment:19 Changed 2 years ago by christo

Happens quite often. Using 4.2.0 r80737. Win7 Professional x64.

49:50:27.178217 SSM: Successfully saved the VM state to '[REMOVED]\Snapshots\2012-10-21T10-49-45-952405400Z.sav'
49:50:27.178304 Changing the VM state from 'SAVING' to 'SUSPENDED'.
49:50:27.285398 Console::powerDown(): A request to power off the VM has been issued (mMachineState=Saving, InUninit=0)
49:50:27.285562 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
49:50:28.300470 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
...

Changed 2 years ago by christo

comment:20 Changed 2 years ago by TTTIk3

I'm starting to get worried that I'm going to lose my data if I continue to use VirtualBox. This occurs every other day now on 4.2.2 and has been occurring regularly for over a year. Running as administrator does not seem to be the answer and I'm not sure what else to try. I used to think it had to do with unplugging USB devices during saving, but that does not seem to be the case. It occurs even if I don't touch my machine during saving.

comment:21 Changed 2 years ago by AnotherLife

It happens to me and I have USB controller disabled.

Maybe it has to do with I/O APIC ? For some reason I had it enabled even though I don't know what it does :-/

comment:22 Changed 2 years ago by wpeckham

This happens to me with the log holding a ton of these messages ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

If I leave it all night, the log file gets HUGE, and waiting does no good. Win7 host 32-bit with Win7 guest 32bit, mostly default settings with more memory allocated. VB versions 4.2.2 and 4.2.4.

I was going to add "no other symptoms", but I recently noticed that this happens more often when the guest has been running slow after several hours of work. If I bring it up and do a shutdown while things are still running pretty fast, it is less likely. Still a nearly daily event. It will take several days of trials to verify this, so today it is only an observation.

comment:23 Changed 2 years ago by mrjl

Happening for me as well. What I noticed is that I had some heavy disk operations going on on a host PC when I was saving VirutalBox session and it got stuck at 100%. I' using it on dell laptop with a normal (non ssd) hard drive under win7 x64. Error message in the log is the same as mentioned above. Virtual Box v 4.2.4.

comment:24 Changed 2 years ago by mrjl

And again. Virtual Box v 4.2.6. Should I start looking for alternatives?

comment:25 Changed 2 years ago by frank

Looks like only Windows users are affected. Is there any non-Windows user who observes the same bug? mrjl, do you have any USB devices attached to your guest?

comment:26 Changed 2 years ago by mrji

The only USB device is mouse, which is attached to host. Just got the same issue again. What I have noticed, though, is that if I have heavy disk usage in host and guest, saving will most certainly hang.

Last edited 2 years ago by mrji (previous) (diff)

comment:27 Changed 2 years ago by marcs

I have a similar issue with OS X Mountain Lion host, Ubuntu 12.04 guest.

This occurred with 2.4 and again after upgrading to 2.6.

This seems to be connected to the guest additions. If I uninstall the guest additions, the problem goes away.

Here's the tail of the log:

00:00:25.834372 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes
00:04:16.045500 Changing the VM state from 'RUNNING' to 'SUSPENDING'.
00:04:16.417176 AIOMgr: Endpoint for file '/Users/marcstober/VirtualBox VMs/Ubuntu/Ubuntu.vdi' (flags 000c0781) created successfully
00:04:16.483511 PDMR3Suspend: 149 730 646 ns run time
00:04:16.483566 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'.
00:04:19.119451 Changing the VM state from 'SUSPENDED' to 'SAVING'.
00:04:19.184924 VUSB: detached 'HidMouse' from port 1
00:05:25.185815 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={Already paused}, preserve=false
Last edited 2 years ago by marcs (previous) (diff)

comment:28 Changed 2 years ago by marcs

I have the same issue when I attempt to take a snapshot with the guest additions installed, so it seems to be an issue with saving state.

Update: I was able to resolve the problem by disabling 3D acceleration.

Not sure if it's the same issue as the Windows bug above or just the same symptom.

Last edited 2 years ago by marcs (previous) (diff)

comment:29 Changed 2 years ago by Philip

I got the problem on version 4.2.6 running on Windows 7 R2. The OS in the session was Windows 2008 R2.

During the session I had deleted a mouse driver, removed the mouse, added the mouse back in and used a new driver.

comment:30 Changed 2 years ago by rogerdpack

just got this, full log:  https://gist.github.com/rdp/4724563

The relevant part appears to be, at the end, the following line is repeated over and over, forever:

00:59:50.485217 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

with 4.2.4, windows x64 host, linux guest, but I've run into it on other machines, as well...

comment:31 Changed 2 years ago by aidanhs

Still present on 4.2.6 r82870. Windows 7 x64 SP1 host, Linux (Lubuntu) guest. I had no USB devices plugged in at all when the suspension started and when it hung (but have plugged and unplugged things while the VM was active). Guest additions are installed.

Precisely the same error as above. The VBox main interface can be started and is responsive for poking with other VM's settings. Some log context:

01:47:17.997288 ***
01:47:17.997289 ************** End of Guest state at power off ***************
01:47:17.997332 PDMR3PowerOff: 8 324 ns run time
01:47:17.997340 Changing the VM state from 'POWERING_OFF' to 'OFF'.
01:47:18.392239 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
[...]

I have closed the main interface and suspended the two remaining virtualbox processes (VBoxSVC.exe and its child VirtualBox.exe) so the log doesn't grow massively. Would any dumps or experiments be useful?

Last edited 2 years ago by aidanhs (previous) (diff)

comment:32 Changed 2 years ago by frank

Could you attach the complete VBox.log file?

Changed 2 years ago by aidanhs

comment:33 Changed 2 years ago by aidanhs

Log attached (aidanhs-VBox.log), with the following modifications

  • Minor path tweak at 00:00:01.096647 to remove some info.
  • Many thousands of duplicate error messages at the end of the file removed.

comment:34 Changed 2 years ago by aidanhs

Just to note I can probably keep these VMs suspended for about the next 24 hours, but I'll need to actually use them at some point. Is there any point leaving them as they are now (i.e. is there any more info that anyone might want?) or should I just terminate them (I'll grab an application dump before I do so)?

Edit: I now have a 1.18GB and 70MB dump file for VirtualBox.exe and VBoxSvc.exe respectively.

Last edited 2 years ago by aidanhs (previous) (diff)

comment:35 Changed 2 years ago by yakatz

Same issue:

Host: Windows 7 x64, Virtual Box 4.2.6 r 82870. Guest: Windows Server 2012 Essentials.

Error only started after I installed Addons.

VBox.log growing extremely fast (20,000 lines in 6 hours).

Can I supply any information that will assist in tracking down the problem? I have the VBox.log mostly anonymized (used find and replace, so I hope it is good).

Last edited 2 years ago by yakatz (previous) (diff)

comment:36 Changed 2 years ago by yakatz

I should have posted that I had the same problem with a Ubuntu VM around the same time and I have the log for that one too.

comment:37 Changed 2 years ago by progmars

Still present on 4.2.10r84104

I noticed that I often get these lines at the end of log files after saving state normally:

08:53:58.299869 Changing the VM state from 'DESTROYING' to 'TERMINATED'. 08:53:59.231839 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

and the last line repeats couple of times.

But in cases when saving hangs at 100%, the last line is repeated hundreds of times (until I kill Virtualbox process manually).

My specs:

Host: Windows 7 SP1 64bit. RAM: 8GB. When saving hangs, I still have about 1.5GB free RAM.

Guest: Windows 7 SP1 32bit. RAM: 3.5GB. Guest additions installed.

Last edited 2 years ago by progmars (previous) (diff)

comment:38 Changed 2 years ago by klaus

That "last line" is actually generated because the VM manager GUI tries to get a screenshot of the VM periodically for its preview. So it has very little to do with the actual cause of the hang, it's just a symptom showing how long the VM is hanging before killing it.

comment:39 Changed 2 years ago by progmars

Thanks, klaus, for clearing this up for me, I didn't know that.

Today it happened again. The log file says:

08:10:13.510847 Changing the VM state from 'RUNNING' to 'SUSPENDING'.
08:10:13.551646 AIOMgr: Endpoint for file 'V:\Win7Dev\System.vdi' (flags 000c0781) created successfully
08:10:13.656872 AIOMgr: Endpoint for file 'V:\Win7Dev\Data.vdi' (flags 000c0781) created successfully
08:10:13.754973 PDMR3Suspend: 240 637 872 ns run time
08:10:13.755003 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'.
08:10:17.030098 Changing the VM state from 'SUSPENDED' to 'SAVING'.
08:10:34.793818 SSM: Footer at 0x651fc80c (1696581644), 33 directory entries.
08:10:34.999009 SSM: Successfully saved the VM state to 'V:\Win7Dev\Snapshots\2013-04-15T15-44-58-473591600Z.sav'
08:10:34.999034 Changing the VM state from 'SAVING' to 'SUSPENDED'.
08:10:36.242396 Console::powerDown(): A request to power off the VM has been issued (mMachineState=Saving, InUninit=0)
08:10:36.243031 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
... again last line repeated hundreds of times ...

When the saving hangs at 100%, the VM is still using all of its allocated memory. There are ~2GB RAM free on the host. No other heavy activities were in progress while saving, I just closed the VM and started watching a Youtube video on Google Chrome while the VM was saving in background.

comment:40 Changed 2 years ago by Petr Vones

Still with 4.2.12. Host: Windows 7 x64, Guest: Windows Server 2008 R2.

After that, the virtual machine can not be started again until host reboot.

Changed 2 years ago by Petr Vones

VirtualBox 4.2.12 close crash log

Changed 2 years ago by Marco2

log file

comment:41 Changed 2 years ago by Marco2

Same issue for me Vbox 4.2.10 r84104. Host Win 7 x64. Guest Linux 2.6.

comment:42 follow-up: ↓ 43 Changed 2 years ago by frank

Marco2, the user marcs wrote that with disabled 3D in the VM settings this does not happen. Can you confirm that?

comment:43 in reply to: ↑ 42 Changed 2 years ago by Petr Vones

Replying to frank:

Marco2, the user marcs wrote that with disabled 3D in the VM settings this does not happen. Can you confirm that?

No, it happend to me with both 3D and 2D acceleration disabled. I don't have USB support installed.

Last edited 23 months ago by Petr Vones (previous) (diff)

Changed 23 months ago by johnwesting12

Changed 23 months ago by johnwesting12

comment:44 Changed 23 months ago by johnwesting12

Same problem for me. VBox v4.2.12 r84980, Win 7 x64 host, Ubuntu 12.04 guest, no 3D acceleration. 2 logs are attached, don't know if these are relevant logs they're from C:\Users\myusername\.VirtualBox\. I have guest additions installed. I was using a Broadcom Bluetooth USB dongle in the VM with a custom USB kernel driver. I closed the app that was using the USB dongle and released the device in the VM before I closed the VM (suspended and saved the machine state). It stuck at 100%. I had to close the VM in the task manager. When I resumed the VM I found that the machine's state was not saved.

comment:45 follow-up: ↓ 47 Changed 23 months ago by Petr Vones

More on this, maybe it is related to NAT networking. Can anyone else confirm that ?

comment:46 Changed 23 months ago by AmicaNoctis

I had the same problem for the first time today after 3 weeks of using VirtualBox 4.2.12 rev84980.

OS: Windows 7 Ultimate x64 (both host and guest) Guest add-ons installed

I used the Devices menu to capture a USB stick by the guest, saved something and released it again, which went perfectly well (I didn't do this before). Somewhat later I tried to save the guest's state and had the same 100% hang.

Log file VBoxSVC.log.9 attached as amica.log

Changed 23 months ago by AmicaNoctis

comment:47 in reply to: ↑ 45 ; follow-up: ↓ 48 Changed 22 months ago by Lofi007

Replying to Petr Vones:

More on this, maybe it is related to NAT networking. Can anyone else confirm that ?

Looks suspicious. Here's the log when it hangs:

...
00:02:28.689562 /TM/VirtualSync/CurrentOffset           0 ns
00:02:28.689571 ********************* End of statistics **********************
00:02:29.404872 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
00:02:30.406494 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
...

and here when it doesn't:

...
00:01:13.266680 /TM/VirtualSync/CurrentOffset      245998 ns
00:01:13.266683 ********************* End of statistics **********************
00:01:13.270153 NAT: zone(nm:mbuf_cluster, used:0)
00:01:13.270530 NAT: zone(nm:mbuf_packet, used:0)
00:01:13.270536 NAT: zone(nm:mbuf, used:1)
00:01:13.270540 NAT: zone(nm:mbuf_jumbo_pagesize, used:0)
00:01:13.270893 NAT: zone(nm:mbuf_jumbo_9k, used:0)
00:01:13.271065 NAT: zone(nm:mbuf_jumbo_16k, used:0)
00:01:13.271160 NAT: zone(nm:mbuf_ext_refcnt, used:0)
00:01:13.277504 Changing the VM state from 'DESTROYING' to 'TERMINATED'.
00:01:13.393615 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
...
  1. e. I still got the E_ACCESSDENIED error which someone pointed out isn't related to the hang.

But you can see that the next log entries when it hangs would have been NAT related.

comment:48 in reply to: ↑ 47 Changed 22 months ago by Lofi007

fyi, the bug is still in VirtualBox-4.2.16-86992-Win

I upgraded from 4.2.14-86644-Win to 4.2.16-86992-Win, started the VM (NAT from the old version remained enabled), installed the Guest Additions. The Guest Additions required reboot, so I shut down the VM. Or more precisely, I tried. During the shut down the machine was hanging with the usual symptoms. Only a reboot helped to solve the problem.

After that I uninstalled VirtualBox, installed 4.2.16-86992-Win, did the same procedure, except that I disabled the network before starting the VM. This worked so far.

edit: nope. Disabling the network adapter doesn't solve the problem. It still occurs. Does anyone know logging settings which I could use in order to find the cause for this problem?

Last edited 21 months ago by Lofi007 (previous) (diff)

Changed 21 months ago by wacher

E_ACCESSDENIED

comment:49 Changed 21 months ago by wacher

Same here. Log has been attached. (Host is Win7 64bit, guest is Win7 32 bits)

Last edited 21 months ago by wacher (previous) (diff)

Changed 20 months ago by Marco2

Log File

comment:50 Changed 20 months ago by Marco2

Same here. log file attached. Host Win7 64, Guest Linux 64

Changed 20 months ago by ncsome

Process monitor trace

comment:51 Changed 20 months ago by ncsome

The same thing happens to me. Win7 64 host, linux 64 guest.

I have attached a screenshot (https://www.virtualbox.org/attachment/ticket/7756/error.jpg) and a csv showing the log of process monitor where you can see that it's trying to create a file mapping and it gets a "file locked with only readers"... This operations happens over and over writing the log file everytime... I also looked at the registry entries that the process is reading, exported and uploaded them here ...

it's really frustrating that this happens everytime I try to save the virtual machine state ...

Last edited 20 months ago by ncsome (previous) (diff)

Changed 20 months ago by ncsome

processmonlogfile

Changed 20 months ago by ncsome

registry entry

comment:52 follow-up: ↓ 53 Changed 20 months ago by ncsome

running "ps ax | grep -i vb" on the guest machine and killing the process returned by that query before saving the VM state seems to prevent the issue from happening...

comment:53 in reply to: ↑ 52 Changed 20 months ago by Petr Vones

Replying to ncsome:

running "ps ax | grep -i vb" on the guest machine and killing the process returned by that query before saving the VM state seems to prevent the issue from happening...

There are two processes in Windows guests, VBoxTray.exe running under logged user and VBoxService.exe running under SYSTEM account. I guess the first is innocent but the second one provides communication between the guest and host. Killing the second one process is probably not a good idea but if it helps it indicates the issue.

Isn't there anything interesting in guest event log ?

Last edited 20 months ago by Petr Vones (previous) (diff)

comment:54 Changed 20 months ago by Chondroma

This is still happening intermittently to me with VirtualBox 4.2.16 r86992 w/Extension Pack 4.2.16, using a Windows 7 x64 SP1 host and a Debian wheezy x64 guest. I didn't notice this happening before I updated to this current version of VirtualBox.

I can't reproduce it reliably, but I can comment that it tends to occur after the guest has been running after a few days. I can't recall an instance when I've started the guest and tried to save its state after a short duration (<~6 hours) and had this bug.

I've attached the guest log and the VBoxSVC log.

Changed 20 months ago by Chondroma

Changed 20 months ago by Chondroma

comment:55 Changed 19 months ago by teddyzhao

I just encountered this problem as everybody did. I am running Ubuntu 12.04 LTS guest on a Windows 7 Professional x64 SP1 host with VirtualBox 4.2.4 r81684.

@Chondroma: This happened to me when I only ran it for less than an hour.

Fortunately, I was able to recover my previous session and this is the most important thing I'd like to share with you all. Here is how I did it.

  1. When it hangs at 100%, check the log file to see if the VM state has been saved successfully (see below). If so, you can terminate all VirtualBox related processes from the Window Task Manager.
    00:42:10.625421 SSM: Successfully saved the VM state to 'C:\VirtualBox VMs\UB Linux\Snapshots\2013-09-11T13-18-17-401051000Z.sav'
    00:42:10.625476 Changing the VM state from 'SAVING' to 'SUSPENDED'.
    
  1. Reopen the VirtualBox and your VM state will be "Powered Off" instead of "Saved" because of the failure. Just turn it on and save it again. If it doesn't hang this time, you will have another file (e.g. 2013-09-11T14-09-40-972717900Z.sav) in the "\Snapshots" folder and the VM state should be "Saved".
  1. Copy both .sav files to another location as a backup. Delete the new file in the "\Snapshots" folder and rename the old file (2013-09-11T13-18-17-401051000Z.sav) to the new one (2013-09-11T14-09-40-972717900Z.sav).
  1. Start the VM, and it will load the new file (actually your old saved session when it crashed) and everything should recover.

Hope someone will benefit from it.

comment:56 Changed 18 months ago by Petr Vones

Can anyone confirm the issue with 4.3 version ?

comment:57 follow-up: ↓ 60 Changed 18 months ago by wacher

Is seems to be wrong in different way. Not hang anymore but simple crash.

Last edited 18 months ago by wacher (previous) (diff)

comment:58 Changed 18 months ago by klaus

The recipe in comment 55 looks way more complicated than it needs to be - if you just want to associate a saved state with a VM (better be sure that it's the right file and for the right state, otherwise this can lead to data loss) with VBoxManage adoptstate "vmname" /path/to/file.sav

Changed 18 months ago by wacher

Log for the modified #57 comment

comment:59 Changed 18 months ago by wacher

14:49:10.733630 Changing the VM state from 'SUSPENDED' to 'POWERING_OFF'.
...
14:49:10.736047 Changing the VM state from 'POWERING_OFF' to 'OFF'.    
14:49:10.740217 Changing the VM state from 'OFF' to 'DESTROYING'.     
...
14:49:10.804199 Changing the VM state from 'DESTROYING' to 'TERMINATED'.

comment:60 in reply to: ↑ 57 Changed 18 months ago by Petr Vones

Replying to wacher:

Is seems to be wrong in different way. Not hang anymore but simple crash.

How exactly did it crash ? The log does not contain any errors. It looks like the state had been saved correctly: https://www.virtualbox.org/attachment/ticket/7756/VBox.log.2.1#L1416

comment:61 follow-up: ↓ 63 Changed 18 months ago by wacher

Yes, the state had been saved but after that VirtualBox.exe process crashed. The final VM state is Aborted. There are more log lines, please read more :) If you see the comments above mine, you can see that the saving of state is successful. Before 4.3 the Vbox process just hang and you have to kill it, from now you don't have to kill it, it collapse. This symptom is not really reproducable, cca 1-2 of 10 saving state is failed.

Last edited 18 months ago by wacher (previous) (diff)

comment:62 Changed 18 months ago by wacher

One more thing. I used to use 32 bits host with 32 bits guest and I never experienced this. Some months ago I have started to use 64 bit host, after that everything changed.

comment:63 in reply to: ↑ 61 Changed 18 months ago by Petr Vones

Replying to wacher:

The final VM state is Aborted. There are more log lines, please read more :)

I can't find it in the log provided. It might help to post the VirtualBox.exe process crash information from Event Log.

comment:64 follow-up: ↓ 65 Changed 18 months ago by wacher

Here is it:

Log Name:      Application
Source:        Application Error
Date:          2013.10.22. 0:18:44
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Tamas-PC
Description:
Faulting application name: VirtualBox.exe, version: 4.3.0.0, time stamp: 0x525d1b9c
Faulting module name: QtCoreVBox4.dll, version: 4.8.4.0, time stamp: 0x51cd576a
Exception code: 0xc0000005
Fault offset: 0x000000000011cae6
Faulting process id: 0xc18
Faulting application start time: 0x01cece2f4910ec2c
Faulting application path: C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
Faulting module path: C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
Report Id: bf2edb4f-3a9e-11e3-aa49-28924a269714

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-10-21T22:18:44.000000000Z" />
    <EventRecordID>1846</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Tamas-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>VirtualBox.exe</Data>
    <Data>4.3.0.0</Data>
    <Data>525d1b9c</Data>
    <Data>QtCoreVBox4.dll</Data>
    <Data>4.8.4.0</Data>
    <Data>51cd576a</Data>
    <Data>c0000005</Data>
    <Data>000000000011cae6</Data>
    <Data>c18</Data>
    <Data>01cece2f4910ec2c</Data>
    <Data>C:\Program Files\Oracle\VirtualBox\VirtualBox.exe</Data>
    <Data>C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll</Data>
    <Data>bf2edb4f-3a9e-11e3-aa49-28924a269714</Data>
  </EventData>
</Event>

comment:65 in reply to: ↑ 64 ; follow-up: ↓ 66 Changed 18 months ago by Petr Vones

Replying to wacher:

Good, it is Access Violation exception somewhere in Qt4 UI library.

comment:66 in reply to: ↑ 65 Changed 18 months ago by wacher

Replying to Petr Vones:

Replying to wacher:

Good, it is Access Violation exception somewhere in Qt4 UI library.

Maybe you are right, but from my point of view it doesn't matter which part of VirtualBox has been failed.

comment:67 follow-up: ↓ 69 Changed 18 months ago by rwoolf

I am on VirtualBox 4.3 and this happens to me on a regular basis. It happens at least 50% of the time when I try to save a session. Sometimes I get to 100% and it just sits there until I kill the process, and sometimes it just crashes towards the 100%. Win 7 pro as host, Elementary OS Luna as guest. I would be glad to provide any debug info if someone can tell me exactly what data I should collect.

comment:68 Changed 18 months ago by Petr Vones

Interesting comment https://www.virtualbox.org/ticket/3207#comment:12 under similar older ticket regarding clipboard.

comment:69 in reply to: ↑ 67 ; follow-up: ↓ 70 Changed 18 months ago by Petr Vones

Replying to rwoolf:

I am on VirtualBox 4.3 and this happens to me on a regular basis

Could you specify exact version, is it 4.3.0 or 4.3.2 ? There is similar issue that has been just fixed in 4.3.2 and closed https://www.virtualbox.org/ticket/3207#comment:15

Last edited 18 months ago by Petr Vones (previous) (diff)

comment:70 in reply to: ↑ 69 ; follow-up: ↓ 71 Changed 17 months ago by rwoolf

Replying to Petr Vones:

Replying to rwoolf:

I am on VirtualBox 4.3 and this happens to me on a regular basis

Could you specify exact version, is it 4.3.0 or 4.3.2 ? There is similar issue that has been just fixed in 4.3.2 and closed https://www.virtualbox.org/ticket/3207#comment:15

I was on 4.3.0, but I upgraded to 4.3.2 in hopes that it solved the problem but no change in behavior. I am hanging over 50% of the time. Unfortunately this is unusable as I can't save state so I am moving over to VMWare as it seems to have no problems. I would be glad to help anyone troubleshoot this problem if they could tell me anything I could provide. This instability is on my Dell laptop. My Dell desktop machine does not exhibit this problem. Both have same Host and Guest OS.

comment:71 in reply to: ↑ 70 Changed 17 months ago by Petr Vones

Replying to rwoolf:

I was on 4.3.0, but I upgraded to 4.3.2 in hopes that it solved the problem but no change in behavior. I am hanging over 50% of the time.

I share your frustration but I still like VirtualBox more than VMWare, I have a lot of old VirtualPC VHD files that VirtualBox can directly use without conversion required by VMWare.

I think that more verbose https://www.virtualbox.org/wiki/VBoxLogging logging is required to diagnose it.

comment:72 Changed 16 months ago by frank

Guys, could you re-check with VBox 4.3.6 and attach a VBox.log file from such sessions where suspending hangs? Thank you!

comment:73 follow-up: ↓ 74 Changed 16 months ago by wacher

GUI crashed, VM is aborted. Is this matter? (See comment#59) Are the virtualbox crashing and the suspending hangs related, maybe?

comment:74 in reply to: ↑ 73 Changed 15 months ago by Petr Vones

Replying to wacher:

GUI crashed, VM is aborted.

Could you post the log file ?

Changed 15 months ago by wacher

VM log for crashed GUI

Changed 15 months ago by wacher

VM log for crashed GUI - eventlog entry

comment:75 Changed 15 months ago by wacher

Here is the log, you can see changes of state: running > suspending > suspended > saving > suspended > powering_off > off > destroying > terminated
Everything goes right but suddenly something happens and the successfully saved state is destroyed, VM is terminated.

comment:76 Changed 15 months ago by Petr Vones

Indeed, and the Access Violation exception somewhere in Qt4 library again.

comment:77 Changed 15 months ago by PRab

I can confirm that this is still happening in 4.3.6. Windows 7 (64 bit) host, Windows 2012 guest. I will attach the log.

Changed 15 months ago by PRab

comment:78 Changed 15 months ago by Wayne Sallee

Occasionally on an older version the saved state would become corrupted and I would have to discard the saved state. So I upgraded to 4.3.6 hoping it would fix it, but instead it always fails when saving state on one of my guests every time. I have 18 guests.

An interesting thing about the guest that fails, is that if I pause it, it will pause, but not grey out. Maybe that will add a clue as to what is happening. Likewise it will not grey out when saving machine state.

Wayne Sallee Wayne@…

comment:79 Changed 15 months ago by Wayne Sallee

Ok here is a reproducible situation that should interest you. :-)

Linux Host Microsoft Windows Guest

Install guest additions. Reboot guest. On boot up you may get error something like "could not read from the boot medium, system halted". If so, reboot. Windows starts up. Pause guest. It will pause, but not grey out. Unpause, and save state. It will fail. Restart. Uninstall guest additions. Reboot. Pause guest. It will pause and grey out. Unpause and save state. It will save just fine.

So the Guest additions is causing the problem.

Wayne Sallee Wayne@…

comment:80 Changed 15 months ago by Wayne Sallee

I tried it on a Linux Guest, and it only failed on the first restart after installing guest additions. Then worked fine.

I'll have to try a test xp install. And see what happens.

But I know that in the past with an older version of vbox I had linux and windows guests end up with corrupt failed states. So how much of that bug has carried through, I don't know.

Wayne Sallee Wayne@…

comment:81 Changed 15 months ago by Wayne Sallee

Windows XP fresh install test installs vbox additions fine and doesn't even fail on first boot like the others.

But Windows 8 and Windows 8.1 fail on first boot, and on save state. For me they are just test systems, so they don't matter to me.

And linux fails only on first boot.

First boot means boot right after installing vbox additions as required by the vbox additions installation.

Wayne Sallee Wayne@…

comment:82 Changed 14 months ago by Ancow

I have a bit of a special use case, and apparently the same symptoms as described here:
Virtualbox version 4.3.8
Host: Win 7 64bit
Guest: Debian Linux 64bit, installed on a physical partition of this machine and usually run standalone, i.e. without Virtualbox.

The hang occurs fairly regularly.

Changed 14 months ago by Ancow

VBox.log (Ancow)

comment:83 Changed 12 months ago by tcs

Same problem still exists with varying frequency on my laptop and desktop systems, but regularly. Host: Win 7, up-to-date Guest: Oracle linux 6.5, with latest VBoxAdditions Virtualbox: 4.3.10 r93012 Above mentioned symptoms are all correct, hang at 100% when saving machine state when closing or when creating snapshot. Let me know if I can send you any data of diagnostic value.

comment:84 Changed 11 months ago by frank

Hi all, is there any Linux user which experiences this problem? Looking through all these comments it looks like this is a Windows-specific problem (I'm talking about the host, not the guest). This information would be helpful for narrowing down the problem.

comment:85 Changed 11 months ago by Ancow

I'm primarily a Linux user and only rarely boot over to Windows. I experience this bug fairly regularly while in Windows, but have never seen it in Linux. (My guests are both Windows and Linux on my Linux host. My Windows host only has the one Linux guest.)

comment:86 Changed 11 months ago by Wayne Sallee

I use Linux.

The "saved state" problem does happen with Linux host. It happens more often after an upgrade. Does not happen very often.

Wayne Sallee Wayne@…

comment:87 Changed 11 months ago by Petr Vones

Do you use NAT or Bridged adapter ? Does it make any difference to the issue ?

comment:88 Changed 11 months ago by Ancow

Windows: I've tried both NAT and Bridged - no difference.

Linux: I use NAT exclusively.

comment:89 follow-up: ↓ 92 Changed 10 months ago by c--

I've been using VirtualBox (currently 4.3.10) on a Linux (Fedora) host for a long time now (at least 2 yrs) and never had such a problem. A few months ago, I started using VirtualBox (also currently 4.3.10) on a Windows (7) host and it has already happened 3 times (!) in the last couple of weeks. (This might of course be incidental, maybe the Linux build has the same bug and it simply hasn't happened to me yet.) Always the same behavior: I close the VM, "save state", it's saving along happily until it reaches 100%. At that point, the window is kind of frozen (doesn't do anything, stays at 100% forever, not possible to close the window or anything) although the GUI is still responsive.

Here's how the log file ends (there are no dates, I hope I got the right log), note the error in the last line:

09:07:20.739605 Changing the VM state from 'RUNNING' to 'SUSPENDING'.
09:07:20.870438 AIOMgr: Endpoint for file 'D:\VirtualBox-VMs\Fedora-1\Snapshots/{ef8b4d1a-db58-4439-b32d-936445d6b8c4}.vdi' (flags 000c0781) created successfully
09:07:20.970604 PDMR3Suspend: 230 979 165 ns run time
09:07:20.970615 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'.
09:07:24.944428 Changing the VM state from 'SUSPENDED' to 'SAVING'.
09:07:24.944891 VUSB: detached 'HidMouse' from port 1
09:07:51.308465 SSM: Footer at 0x8879e981 (2289691009), 34 directory entries.
09:07:51.308499 VUSB: attached 'HidMouse' to port 1
09:07:52.254256 SSM: Successfully saved the VM state to 'D:\VirtualBox-VMs\Fedora-1\Snapshots\2014-06-10T15-08-21-162471200Z.sav'
09:07:52.254270 Changing the VM state from 'SAVING' to 'SUSPENDED'.
09:07:52.387287 Console::powerDown(): A request to power off the VM has been issued (mMachineState=Saving, InUninit=0)
09:09:54.714663 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={8ab7c520-2442-4b66-8d74-4ff1e195d2b6} aComponent={Console} aText={Already paused}, preserve=false

This is very frustrating. The whole point of saving the state is to keep unsaved work and instead it's crashing the VM causing even more (data) loss.

comment:90 follow-up: ↓ 91 Changed 10 months ago by frank

No doubt this is frustrating and the bug has to be fixed. The problem is that we cannot reproduce this behavior so far. This problem might be related to the Windows host, I remember seeing a couple of similar reports, IIRC all for Windows hosts.

comment:91 in reply to: ↑ 90 ; follow-up: ↓ 98 Changed 10 months ago by c--

Replying to frank:

The problem is that we cannot reproduce this behavior so far.

Unfortunately I have not found a way to trigger this behavior reliably yet. It just seems to happen occasionally. I haven't recognized a pattern yet.

This problem might be related to the Windows host, I remember seeing a couple of similar reports, IIRC all for Windows hosts.

This is my impression as well since it has never happened to me on my Linux box.

If there's something I could run to find the culprit (or maybe there's a debug/verbose switch somewhere), let me know. At this point, the log is the only interesting thing to check that I can think of. It's difficult to find the right entries though, because there don't seem to be any dates/timestamps (except for the start date in the first 2 lines).

Next time it happens, I'll update this bug (with some log entries, hopefully).

comment:92 in reply to: ↑ 89 Changed 10 months ago by Petr Vones

Replying to c--:

This is very frustrating. The whole point of saving the state is to keep unsaved work and instead it's crashing the VM causing even more (data) loss.

The saved state is not lost. See #comment:55 A recovery option in VirtualBox GUI would help to workaround this issue.

I also think that more verbose log is needed to diagnose the issue. Anything particular described here https://www.virtualbox.org/wiki/VBoxLogging ?

Last edited 10 months ago by Petr Vones (previous) (diff)

comment:93 Changed 5 months ago by stattert

Never had this issue, untill recently, happened 3 times now. Very painful to loose so much work. Windows 7 Professional, Virtual Box 4.2.6 with a Centos 6 machine

92:58:09.837084 SSM: Successfully saved the VM state to 'D:\VirtualBox VMs\Centos 6.3 (64 bit)\Snapshots\2014-11-18T09-25-38-006817000Z.sav' 92:58:09.837106 Changing the VM state from 'SAVING' to 'SUSPENDED'. 92:58:11.871481 Console::powerDown(): A request to power off the VM has been issued (mMachineState=Saving, InUninit=0) 92:58:12.076461 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false 92:58:19.192750 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false 92:58:19.194719 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false

same error repeated continually

Last edited 5 months ago by stattert (previous) (diff)

comment:94 Changed 5 months ago by frank

Actually what we would need is an application dump, full application dump preferred, I'm not sure if a minidump would also help. How to create such a dump:

  • Download the Microsoft sysinternals process explorer
  • Start it as Administrator
  • In the tree view, make sure to find the actual VirtualBox.exe process. You should be able to identify it by the process memory size
  • Right click on the process and do 'Create Dump' / 'Create Full Dump'

It would be nice if you could make such an application dump available for us, together with the corresponding VBox.log file. You can contact me directly via frank _dot_ mehnert _at_ oracle _dot_ com on where to send the dump file.

comment:95 Changed 5 months ago by 0cd

I created full dump and mini dump. Full dump : 1.3b, mini dump : 13m. I will send mini dump to frank's e-mail. If dev's need full dump, reply e-mail to me or add a comment here. My virtulBox's version is 4.3.6 r91406.

Last edited 5 months ago by 0cd (previous) (diff)

comment:96 Changed 5 months ago by frank

0cd, did you already contact me and I missed the email?

comment:97 Changed 4 months ago by rogerdpack

I think I just experienced this (linux guest 4.3.20) possibly caused by old guest extensions though, I'll reinstall and keep my eye on it.

comment:98 in reply to: ↑ 91 Changed 4 weeks ago by c--

Replying to c--:

Next time it happens, I'll update this bug (with some log entries, hopefully).

I've dumped this Windows box and installed Linux. I guess this mostly affects Windows hosts, it hasn't happened to me since.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use