VirtualBox

Ticket #3207 (closed defect: fixed)

Opened 5 years ago

Last modified 6 months ago

Saving execution state hangs at 97% -> retry with 2.1.4

Reported by: karl.forner Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.2 Keywords: execution state clipboard
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Hi, Saving the execution state on XP host with ubuntu 8.04 guest often hangs at 97%, where it stays forever. It may be linked to another bug I'm experiencing with virtuabox locking the windows clipboard, thus preventing other windows software to use it

Attachments

VBox.log Download (44.1 KB) - added by karl.forner 5 years ago.
log
VBox.2.log Download (67.3 KB) - added by dgrant 5 years ago.
Ubuntu-64-2-2010-11-16-11-17-29.log Download (54.3 KB) - added by phramusca 3 years ago.
related to my first post on this topic
Save failing.log Download (55.6 KB) - added by anat 3 years ago.

Change History

Changed 5 years ago by karl.forner

log

comment:1 Changed 5 years ago by michael

Could you please open a separate ticket for the clipboard issue?

comment:2 Changed 5 years ago by karl.forner

done

comment:3 Changed 5 years ago by jvdongen

I got the exact same problem, but with Ubuntu 8.10 64 bit as host and Windows XP as guest

comment:4 Changed 5 years ago by sandervl73

  • Summary changed from Saving execution state hangs at 97% to Saving execution state hangs at 97% -> retry with 2.1.4

comment:5 Changed 5 years ago by dgrant

I have the same problem. Running 2.1.4-42893_Ubuntu_intrepid.

Changed 5 years ago by dgrant

comment:6 Changed 5 years ago by frank

dgrant, any chance to reproduce this problem with 2.2.4? If so, could you generate a  core dump and send it to me at frank _dot_ mehnert _at_ sun _dot_ com? This sounds like a deadlock and a core dump from a Linux box would help us debug the problem.

comment:7 Changed 5 years ago by dgrant

Ok, I've started VirtualBox with the appropriate settings and as soon as I can reproduce the hang, I'll get the core dump.

comment:8 Changed 5 years ago by rabbit

I have same problem most times I try to suspend the machine: Saving execution state hangs with no CPU usage for virtualbox. So no loop. Looks like this maybe linked to the shared Clipboard issue. After some time the cut&pate does not work anymore on the HOST system. I can only resolve this by reboot of the host system. And it looks like if this occurs I also do have the hang at 97% in SAVING THE EXECUTION STATE.

HOST: WinXP Prof, SP3 Guest: SUSE Linux 10.2 VirtualBox: 2.2.4 r47978

comment:9 Changed 5 years ago by rabbit

By the way: after I kill the virtual guest system on my host the cut&paste works fine again on the host system

comment:10 Changed 5 years ago by dgrant

I still haven't been able to reproduce the problem, but as soon as it does happen, I hope to have a core dump.

comment:11 Changed 4 years ago by Technologov

Please test with 3.2.0, and tell us if the problem still exists

-Technologov

comment:12 Changed 3 years ago by phramusca

Hi, I had the issue in the past, but never noticed it was (or not) at 97% However, today, I had the issue and wanted to know more about it. That's how I found this bug report. I have a Windows XP host running VirtualBox 3.2.10 and Ubuntu 10.10 64bits client. The issue today, is reversed: I had the clipboard failing on Windows and after unsuccessful retries to fix it, I decided to reboot Windows. So, I saved Virtual Box state and it stopped at 97% !! I rebooted anyway and got a Windows error message saying that "VBoxSharedClipboardClass" was not responding.

The Windows XP clipoard hangs frequently, and it looks like VirtualBox hangs too at saving the execution state at 97% if windows clipboard is in an invalid state. I don't know if cliboard content is saved at this moment, but the solution would be either not to store the clipboard content in the machine state (as not very useful - clipboard is only temporary data) or find a way to test the clipboard behavior and save the content according to its state (running or hanged).

Hope this will help solving this issue.

Changed 3 years ago by phramusca

related to my first post on this topic

comment:13 Changed 3 years ago by anat

I'm facing exactly the same issue on 4.0.10. It only happens with my CentOS client. As the host system I have XP. And yes, every time the saving hangs, I can't use copy-past even on the host system and once I have killed the hanged savin process the copy-paste starts to work again.

Changed 3 years ago by anat

comment:14 Changed 6 months ago by rogerdpack

Does this still happen?

comment:15 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Good question. I assume that we would have seen reports if this would be the case. I will close this ticket, please reopen if this still happens with VBox 4.3.2. In that case, please attach a VBox.log file of such a VM session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use