VirtualBox

Ticket #7709 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VBox hangs trying to save state from the command line

Reported by: brihuega Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.2.10 Keywords: savestate hang
Cc: Guest type: other
Host type: Linux

Description

When I save the state of a guest machine from the GUI, it works OK, but trying it from the command line hangs all machines and I must kill all the remaining VBox processes to continue using VBox.

The command:

$ VBoxManage controlvm Windows savestate
Oracle VM VirtualBox Command Line Management Interface Version 3.2.10
(C) 2005-2010 Oracle Corporation
All rights reserved.

0%...

I have to CTRL-C, close all the guest machines windows and kill all processes:

$ ps -ef|grep VB
brihuega  3189     1  0 09:28 tty1     00:00:00 /opt/VirtualBox/VBoxXPCOMIPCD
brihuega  3198     1  0 09:28 ?        00:00:00 /opt/VirtualBox/VBoxSVC --pipe 10 --auto-shutdown
$ kill 3189 3198

Then I can run VBox again. The state of the guest machines is lost.

These are the system data:

Linux d*****i 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 17:14:28 CEST 2010 x86_64 Pentium(R) Dual-Core CPU E5400 @ 2.70GHz GenuineIntel GNU/Linux

The system distro is ArchLinux.

VBox version: VirtualBox-3.2.10-66896-Linux_amd64

Guest machine system doesn't matter. I've tryed with Windows XP, Windows 7, Ubuntu, 32 and 64 bits, etc. with the same problem.

Log file attached.

Attachments

VBox.log Download (55.7 KB) - added by brihuega 3 years ago.
Log

Change History

Changed 3 years ago by brihuega

Log

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4124. Current workaround is to disable 2D.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use