VirtualBox

Ticket #4124 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

VBoxManage controlvm $uuid savestate hangs due to 2D enabled => Fixed in SVN

Reported by: brian Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

When I try to save my VM's state, the VBoxManage command simply hangs:

$ VBoxManage controlvm 4a908f7b-53d3-420f-9c6a-066d62c118f8 savestate
VirtualBox Command Line Management Interface Version 2.2.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.



And that's it. There I sit, presumably forever, waiting for it to take effect. It never does.

This is pretty reproducable. It simply happens after the guest's console has been battered with output from the (guest of course) Linux kernel.

Attachments

VBox.log.1 Download (51.8 KB) - added by romkyns 3 years ago.
Log showing "startvm" followed by "controlvm savestate"

Change History

comment:1 Changed 3 years ago by romkyns

Upgraded to v3.2.10 from 3.1.something.

savestate used to work fine in 3.1, but in 3.2.10 it locks up every single time, absolutely 100% reproduceable.

This should really be marked as critical, as it's a core feature that causes dataloss (current state is lost), and prevents most automation from working (e.g. snapshotting, which can't be done without a savestate).

This thread here looks relevant:  http://www.mail-archive.com/vbox-dev@virtualbox.org/msg03027.html

comment:2 Changed 3 years ago by frank

This is not reproducible here. Please attach a VBox.log file of such a hanging session. This problem might depend on the VM settings.

Changed 3 years ago by romkyns

Log showing "startvm" followed by "controlvm savestate"

comment:3 Changed 3 years ago by romkyns

Log attached. The output of VBoxManage was:

"C:/Program Files/Oracle/VirtualBox/VBoxManage.exe" controlvm altair savestate Oracle VM VirtualBox Command Line Management Interface Version 3.2.10 (C) 2005-2010 Oracle Corporation All rights reserved.

0%...

comment:4 Changed 3 years ago by romkyns

It appears that clearing the "Enable 2D video acceleration" setting fixes the hang. I suppose it's my fault entirely for enabling unnecessary options on production machines...

I should point out that only saving the state via VBoxManage causes the hang. Going via the "Close VM" dialog saves the state correctly without any hangs.

comment:5 Changed 3 years ago by frank

Reproduced, thanks for the report. This is a bug which should be fixed of course.

comment:6 Changed 3 years ago by frank

  • Version changed from VirtualBox 2.2.2 to VirtualBox 3.2.10
  • Component changed from VM control to 3D support
  • Summary changed from VBoxManage controlvm $uuid savestate hangs to VBoxManage controlvm $uuid savestate hangs due to 2D enabled

comment:7 Changed 3 years ago by misha

  • Summary changed from VBoxManage controlvm $uuid savestate hangs due to 2D enabled to VBoxManage controlvm $uuid savestate hangs due to 2D enabled => Fixed in SVN

We've fixed the issue. The fix will be available in the next VBox release. Thanks for the report.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix contained in VBox 3.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use