VirtualBox

Ticket #768 (closed defect: fixed)

Opened 11 years ago

Last modified 8 years ago

Mouse driver conflict -> Fixed in 2.2.2

Reported by: naju Owned by:
Component: guest additions Version: VirtualBox 1.5.0
Keywords: Cc:
Guest type: Windows Host type: other

Description (last modified by michael) (diff)

I have tested this with the official 1.5.0 build (VirtualBox_1.5.0_Linux_amd64.run) and a build from today ( http://virtualbox.org/download/testcase/VirtualBox-2007-10-11-12-32-37-lin64-rel.run), with their respective guest additions.

My setup:

  • Dual-boot Gentoo linux amd64/Windows XP 32-bit system
  • All partitions are primary
  • Windows XP has 2 hardware profiles, one for virtualbox, one for the native hardware, which are used for their respective tasks.
  • Guest additions is installed on winxp/virtualbox hardware profile.
  • I am using the raw host hard disk support to boot the winxp partition directly from the VM.

This setup works perfectly until I install the Logitech mouse driver software, "SetPoint", when running Windows XP natively (and after a reboot). After that, whenever I run winxp in virtualbox, the mouse shows the following behavior:

  • With mouse integration (from guest additions) enabled, if the pointer is moved, both mouse buttons are clicked rapidly and uncontrollably.
  • With mouse integration disabled, after the mouse pointer is captured, it appears to be "stuck" on the left side of the screen and both mouse buttons are clicked as before.

I have failed to correct this problem by uninstalling SetPoint or guest additions. The only way is to bring the mouse pointer back to a normal state in the VM is to re-install Windows.

I have found few reports of this, except maybe the "mouse pointer stuck in left corners of the screen" kind of deal, except this:

 http://forums.virtualbox.org/viewtopic.php?t=1536&sid=896e438eaf1a461048b4885059471d45

relevant hardware/software:

  • cpu: amd64 3000+
  • Logitech MX518 mouse
  • Logitech SetPoint 4.00 mouse driver
  • Windows XP Professional SP2 5.1.2600

Attachments

hector-2009-06-25-10-45-16.log Download (67.9 KB) - added by alidaf 10 years ago.
most recent log
hector-2009-06-25-10-45-16.2.log Download (67.9 KB) - added by alidaf 10 years ago.
most recent log
hector-2009-06-23-13-13-57.log Download (140.9 KB) - added by alidaf 10 years ago.
earlier log with lots of mouse errors

Change History

comment:2 Changed 11 years ago by michael

  • Description modified (diff)

comment:3 Changed 11 years ago by michael

  • Description modified (diff)

comment:4 Changed 11 years ago by intelliboy

I am still having the same problem with virtualbox 1.6. I installed virtualbox on kubuntu 7.10 gutsy with winxp as guest and i have the logitech setpoint software installed. as soon as i boot in winxp, the mouse goes crazy clicking everywhere.

comment:5 Changed 11 years ago by frank

  • Component changed from other to guest additions

comment:6 Changed 11 years ago by frank

  • Guest type changed from other to Windows

comment:7 Changed 10 years ago by ameno

i can confirm this problem with a ubuntu 8.10 host and a win2k guest (used to be my old laptop installation). virtualbox-ose 2.0.4. havent found a workaround yet.

comment:8 Changed 10 years ago by ameno

hm... got it working.. dunno exactly what was the essential step. "uninstalling" the mouse driver, removing all kinds of logitech crap...

comment:9 Changed 10 years ago by 3vi1

I have what sounds to be the same issue with an image I made from an XP system that previously used a Logitech mouse and keyboard.

At first, neither integrated nor capture mode worked: The mouse was stuck on the right side of the screen and seemed to be right-clicking anytime I tried to move it.

I uninstalled the Logitech mouse from the device manager, but the problem didn't go away. I then went into the device manager and overrode the mouse/keybards to the MS standards and removed references to the logitech mouse/keyboard drivers in the registry.

After that, Captured mode works, but Integrated causes the mouse to move down the screen and to the right at a 45-degree angle - like another report I've seen on here.

Re-installing the guest additions did not fix the issue.

(host is Kubuntu 8.10, btw).

comment:10 Changed 10 years ago by 3vi1

Okay, this is weird: I spent over four hours going through the registry of the guest, looking for and removing anything that I thought could be a factor (SMS mouse entries, USB mouse entries, KHALMNPR.exe in Run etc.), I copied all the device drivers over from an image that didn't have the problem, re-installed the guest addtions, and completely powered off/on the guest machine, but still had the exact same symptoms at the end of the day,

So, I gave up an powered off the host.

Today, I turn on the host, start the guest, and integration works perfectly.

What I don't understand is how the host side of integration could have been in a "bad" state, yet integration still worked fine with other images. I really can't think of anything else I did to the guest between it not working yesterday and then working today.

comment:11 Changed 10 years ago by bitblitter

Ubuntu 8.10, Virtual box 2.04 OSE, Guest system WinXP SP3. I had the same problem. Then I disabled mouse integration, navigated through keyboard to uninstall Logitech SetPoint, rebooted, and everything worked again.

comment:12 Changed 10 years ago by sunlover

A similar problem has been fixed recently. Please try the mouse driver attached to ticket  http://www.virtualbox.org/ticket/1324 (if you use a 32 bit Windows guest). Thanks.

comment:13 Changed 10 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Mouse driver conflict to Mouse driver conflict -> Fixed in 2.2.2

This should be fixed in VirtualBox 2.2.2. Do not forget to update the guest addition to 2.2.2 as well. Reopen this ticket if the problem persists.

comment:14 Changed 10 years ago by alidaf

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm relatively new to VB and I'm having this exact same issue with version 2.2.4. I'm running Ubuntu 9.04 host and XP guest.

comment:15 Changed 10 years ago by alidaf

Tried 3.0 beta and no change.

comment:16 Changed 10 years ago by sunlover

alidaf, you should attach VBox.log for the VM.

Changed 10 years ago by alidaf

most recent log

Changed 10 years ago by alidaf

most recent log

comment:17 Changed 10 years ago by alidaf

ok thanks. Have done - I think!

Changed 10 years ago by alidaf

earlier log with lots of mouse errors

comment:18 Changed 10 years ago by alidaf

Ok, the way I got rid of the logitech mouse driver completely was to uninstall the mouse from the device manager and then when it reinstalled drivers following reboot - rollback the mouse driver. This then rolled back to the microsoft ps/2 driver. I'd seen comments regarding installing the microsoft driver but no explanations on how to do it. This worked for me. Mouse integration doesn't seem to work but its a step in the right direction. What I think killed it in the first place was mistaking the purpose of the usb filters and checking the usb keyboard/mouse for the guest. What this does, if I understand it correctly is to pass through the usb device to the guest but remove it from the host. I only check security dongles now and leave the mouse one alone.

comment:19 Changed 9 years ago by lat

I too have the continuous right mouse clicking problem with VirtualBox 3.0.10 on OS X 10.6.1 host, Windows XP SP3 guest. The XP was a brand new installation, though I am not sure what exactly it installed (company managed installation). It auto-selected Logitech PS/2 compatible mouse drivers. It looks like I managed to get the mouse to somewhat sane working order by: 1) Install guest additions; 2) Reboot; 3) Login (operate in keyboard mode since mouse is unusable); 4) Edit C:\WINNT\INF\msmouse.inf, under "version" replace "Driverver=07/01/2004,5.1.2600.0"; 5) Edit C:\WINNT\INF\oem8.inf and \$OEM$\$1\OEMDrvs\Unsupported\lm2kplus.inf, under "version" replace "Driverver=11/07/2001,9.79 (aka, make logitech drivers older than ms driver, they now both become unsigned drivers), 6) Control Panel / Administrative tools / Computer Management / Device Manager: Remove Mouse driver; 7) Reboot; 8) Login again, 9) Found New Hardware prompts for driver selection, and now suggests Microsoft PS/2 mouse driver, choose that one; 10) Reboot. And finally, mouse seems to work fine.

comment:20 Changed 9 years ago by Technologov

lat: Your problem is different than original problem. Your problem is fixed in 3.1.0

naju and alidaf: Please retry with 3.1.0. Try with USB disabled, as it grabbed your mouse. Then you can retry with USB enabled too...

-Technologov

comment:21 Changed 8 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use