VirtualBox

Ticket #7573 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

Flash player crashes in Ubuntu 10.10 guest when going full screen in VM (Not seamless mode)

Reported by: VBoxBugReporter Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.10 Keywords: flahs, crash, fullscreen
Cc: Guest type: Linux
Host type: Linux

Description

Host OS: Ubuntu 10.10
Guest OS: Ubuntu 10.10
VirtualBox: 3.2.10

Originally I used VirtualBox 3.2.8 but then I upgraded to 3.2.10. This bug exists in both versions so I'm reporting it under 3.2.10.

Background issue:

Installing the 3.2.8 guest additions failed with an X11 driver issue. As a result I could not change the guest OS resolution. Search on the internet suggested that I should install the virtualbox-ose-guest-x11 package to solve this issue. So I did and it did solve the problem. Now I could reset the guest resolution. But then I bumped into the main issue (see next).

Main issue:

The Flash player (used with Firefox) works in windowed mode in the guest VM but when I try to maximise it into full-screen mode inside the VM the flash player crashes. This is fully reproducible. It does it all the time.

If I turn 3D acceleration off, then it does not crash. When 3D acceleration is turned back on, then it crashes again.

Upgrading to 3.2.10 from 3.2.8 did not solve this issue.

Also if I uninstall the virtualbox-ose-guest-x11 package then it does not crash but there is no hw acceleration, either hence it becomes unusably slow.

Flash player works fine in the host OS both in windowed and fullscreen mode. So this issue only affects the VirtualBox VM.

Conclusion:

There is something wrong with the 3D acceleration in VirtualBox 3.2.10.

And since the Flash player keeps crashing hence it's a pretty major issue.

Attachments

VirtualBox.log Download (78.9 KB) - added by VBoxBugReporter 4 years ago.

Change History

Changed 4 years ago by VBoxBugReporter

comment:1 Changed 3 years ago by frank

Still relevant with VBox 4.1.4?

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use