VirtualBox

Ticket #7572 (closed defect: obsolete)

Opened 4 years ago

Last modified 2 months ago

Linux guest, 3.2.10 GA: Problems with 3D acceleration and desktop effects

Reported by: scottku Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: other

Description (last modified by misha) (diff)

NOTE: This ticket was created as a result of a discussion here:  http://forums.virtualbox.org/viewtopic.php?f=3&t=35218

There have been several reports 3D acceleration on Linux guests failing. I'm not sure if this is due to one or more different bugs.

A couple of people reported that they had working 3D acceleration until they installed 3.2.10 GA (on Linux Mint 9, Ubuntu 10.04). I have seen this problem with trying to turn on 3D acceleration with virtualbox 3.2.10 on Ubuntu 10.10. Here is the post on the forum describing my particular problem:

If I use the 3.2.10 GA, glxinfo reports that it is using mesa for rendering, desktop effects are disabled, and OpenGL programs based on GLUT run, but run without hardware acceleration.

If I use the Ubuntu virtualbox-ose-guest-x11 package from Ubuntu (which I know isn't recommended for the PUEL version) glxinfo reports that it is using Chromium for rendering, and desktop effects are enabled. However, in this situation, OpenGL apps which use GLUT (that I've tried) segfault with a message about XGetVisualInfo returned 0 visuals.

I have attached several logs which were created when I had the 3.2.10 GA installed on my Ubuntu 10.10 guest.

Attachments

glxinfo.txt Download (20.4 KB) - added by scottku 4 years ago.
guest-log.log Download (52.8 KB) - added by scottku 4 years ago.
Xorg.0 (1).log Download (30.2 KB) - added by scottku 4 years ago.
Makefile Download (2.5 KB) - added by virusek 4 years ago.
Fixed src/vboxguest-3.2.10/Makefile

Change History

Changed 4 years ago by scottku

Changed 4 years ago by scottku

Changed 4 years ago by scottku

comment:1 Changed 4 years ago by scottku

An update: Myself and others on the forum post referenced above are have found that desktop effects do work on a fresh Ubuntu 10.10 installation. So, this bug might actually be invalid. Sorry for the spam.

comment:2 Changed 4 years ago by virusek

I had same issue. Is caused by src/vboxguest-3.2.10/Makefile inside guest additions package - it does not compile vboxvideo DRM kernel module. Workaround is to unpack installer, then compile and install driver manually, permanent fix is to make changes to Makefile to correctly compile and install vboxvideo module then make new packages.

Changed 4 years ago by virusek

Fixed src/vboxguest-3.2.10/Makefile

comment:3 Changed 4 years ago by net147

I can confirm this bug also occurs for me.

comment:4 Changed 4 years ago by frank

So this issue seems to be only relevant if DKMS is not installed in the guest because DKMS should compile the vboxvideo module.

comment:5 Changed 4 years ago by virusek

On Ubuntu DKMS is default installed, so this is not DKMS problem. DKMS seems to use Makefile from sources to build module, so if there are no targets to build vboxvideo in Makefile, module is not build. Also note that in older tools modules are build different than in 3.2.10 version.

comment:6 Changed 3 years ago by frank

If your attached Makefile really fixes the issue for you then this is definitely a DKMS problem. The first part of that Makefile is used for DKMS, the second part of that file if DKMS is not installed or not active for some reason.

comment:7 Changed 3 years ago by frank

With DKMS problem I mean, a problem that DKMS is not installed or not active.

comment:8 Changed 3 years ago by virusek

On my guest DKMS was active, and does NOT build kernel module, because it does normal make using src/vboxguest-3.2.10/Makefile so it cannot compile module if this Makefile will not build it.

comment:9 Changed 3 years ago by frank

Then there is something really wrong. In the DKMS case the first part of the Makefile should be used and this works here as expected. I've tested this with an Ubuntu Lucid guest. Which Ubuntu version are you using as guest? Could you attach the file /var/lib/dkms/vboxguest/kernel-*/log/make.log?

comment:10 Changed 3 years ago by virusek

Ubuntu 10.10 (Maverick). I do a clean install of it, and you're right, DKMS is not installed as default. I was sure that is installed and running as in older Ubuntu version ... For proper support this new distro, this modules should be compiled on addition install, because now DKMS is optional in Ubuntu.

comment:11 Changed 3 years ago by Perryg

AFAIK DKMS has always been an option and never a default in any version of Linux I have ever installed, and I have installed a lot of them. That's why it states in the virtualBox users manual that you should install it.

comment:12 Changed 3 years ago by scottku

Why doesn't the install script perform some sort of check to see if DKMS is installed and print out a warning message if DKMS is not found? It seems that multiple people forget (or don't know) that it should be installed for the guest additions to work properly.

comment:13 Changed 3 years ago by frank

The installation script tests if DKMS is installed. If yes, it uses DKMS, if not, it installs without using DKMS. The installation mechanism without DKMS has a bug. Not all Linux distributions ship DKMS.

comment:14 Changed 3 years ago by eteq

I can confirm that DKMS needs to be installed, but even after it is installed and everything else seems to be fine, any programs based on GLUT (and some other OpenGL-based programs) segfault.

comment:15 Changed 3 years ago by michael

etaq: might you be seeing bug #7061?

comment:16 Changed 3 years ago by eteq

It's not in the same place in the code, at least - what I'm seeing is a segfault in the freeglut toolkit itself - although I suppose it could be caused by 7061 by some roundabout means. I compiled freeglut 2.6 w/ debug symbols, and the segfault happens as below. When I look at the inputs to the function it's calling (XCreateColormap), the fgDisplay.Screen pointer is null - perhaps that's somehow the same problem as #7061?

Program received signal SIGSEGV, Segmentation fault. 0x00007ffff7bbac67 in fgOpenWindow (window=0x60ea00,

title=0x400cd0 "Triangle", positionUse=<value optimized out>, x=<value optimized out>, y=<value optimized out>, sizeUse=1 '\001', w=400, h=500, gameMode=0 '\000', isSubWindow=0 '\000') at freeglut_window.c:821

821 winAttr.colormap = XCreateColormap(

comment:17 Changed 3 years ago by avi_m1968

hello

i have Installed a fresh mint 10 and ubuntu 10.04 all was ok. after installing 3.2.10 GA:

  1. in mint 10 NO 3D acceleration and desktop effects can be setup at all.
  2. in the ubuntu 10.04 after installing the GA the following happend. A: i was able to select Extra Desktop effects, but the screen refresh of the

guest stoped working and if i had a window from the host overlap the guest i had to move some window on the guest screen to refresh the guest desktop. i.e. see it again.

B: if i selected NORMAL effects then the windows on the guest desktop were

able to move to the RIGHT ONLY no matter what the mouse did. also the refresh of the guest desktop was effected just like the above.

C: going back to NONE in the desktop effects , got everythin gback yo NORMAL

all was moving and the refresh of the guest desktop was OK again. i.e. overlapping host windows didn't effect the guest desktop.

any chance this would be fixed or is any work around since i must have 3D in my virtual guests.

thank you Avi

comment:18 Changed 3 years ago by frank

The fix for properly compiling the Linux kernel modules in VBox 3.2.12.

comment:19 Changed 3 years ago by avi_m1968

Hello

I have installed VBox 3.2.12 and the NEW 3.2.12 GA as you saied above. in both UBUNTU 10.04 and Mint 10 i had installed. BUT the problems I wrote about above are still there

  1. Mint 10 - i can't enable 3D effects in the desktop. i still get a message saying "3D effects can't be enabled" (after searching for drivers)
  2. Ubuntu 10.04 - Guest screen refresh still does not work. i.e. if i have Host windows overlap the VB Guest desktop, then when switching back to the guest I have to move the guest windows around the guest desktop to "clear" the overlapped host window picture so i can see the guest desktop.

i must say that in Normal 3D effects windows now move with the mouse, and not only

to the right as before in ver. 3.2.10.

again in normal mode with NO effects there are NO problems with overlapping host/guest windows.

what do i need to do now ? thank you Avi p.s. as i said those were two fresh installs of the OS.

comment:20 Changed 3 years ago by eteq

In a fresh install of Ubuntu 10.10 (win 7 64 host), I am *not* seeing the problem avi_m1968 reports. However, I do see the Mint 10 problem - and glxinfo reports that the Mesa rasterizer is in use, indicating the 3D drivers are not installed correctly. I see no obvious error message in dmesg, though.

(Oh, and I had to install dkms for both with synaptic - it wasn't a default package)

comment:21 Changed 3 years ago by avi_m1968

Hi

I have checked and dkms was and is installed on my ubuntu 10.04. I installed dkms on the mint 10 and I was able to select 3D effects BUT I got the refresh problem like in the ubuntu too. if there was any host windows over the guest virtualbox desktop it was there with no refresh when I moved to the guest desktop moving the windows in the guest , cleared the overlaying of the host windows.

I must say that with no 3d effects all is working well. both ubuntu 10.04 and mint 10 also i have windows xp guest and no 3d effects problems on that guest. this is the 3rd time I'm reinstalling the ubuntu 10.04 & mint 10.

I'm going to try it on a different computer later this week.

thank you Avi

comment:22 Changed 3 years ago by gregdavisfromnj

People suffering from this bug might also want to have a look at  #4582, which is a related problem specific to KDE4 and its window manager. Comments include a workaround to achieve useless eye-candy. One needs to still install DKMS for Chromium OpenGL to work instead of the Mesa software implementation.

comment:23 Changed 3 years ago by eteq

Actually, I think #4582 is distinct - that's referring specifically to KDE4's compositor, and the issues here seem to be in gnome/compiz. The workaround in #4582 seems to be saying basically "use compiz instead of the KDE compositor," so any still-existing problems with compiz should also strike for KDE...

Also, composited WMs are not just "useless eye-cany". I am more efficient on composited desktops due to such utilities as the "scale" plugin and some of the optimized switchers, as well as reasonable use of transparancy for quick overlaying of various plots on top of each other. So these problems are usability bugs, not purely cosmetic.

comment:24 Changed 3 years ago by avi_m1968

Hi

sorry for the late answer, I wasn't in the office, I have read thru #4582 but I can't find it connected in anyway to the problem we have. as eteq said "issues here seem to be in gnome/compiz."

I also use most of the features for work (as eteq) so

its is a matter of solving the problem quick to get my work going full speed. I'm going to do some more in depth checking during the holidays and look for the cause of the problem.

Avi

comment:25 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions?

comment:26 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use