VirtualBox

Ticket #7571 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VB 3.2.10 guest additions has broken desktop settings => Fixed in SVN

Reported by: loukingjr Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

installed Ubuntu 10.10 in VB 3.2.10. installed the guest additions. desktop effects no longer work correctly. for one thing if you try and drag a window, it keeps moving to the right.. installed 3.2.10 guest additions into a previous install of ubuntu 10.04 and Linux Mint 9. Both gave me a can't enable desktop effects until I re-installed 3.2.8 guest additions.

Change History

comment:1 Changed 4 years ago by michael

Does disabling 3D in the host settings make a difference here?

comment:2 Changed 4 years ago by loukingjr

I would assume so since desktop effects has never worked with #D disabled.

comment:3 Changed 4 years ago by loukingjr

oops 3D*

comment:4 Changed 4 years ago by michael

Dragging windows is supposed to work with 3D disabled though.

comment:5 Changed 4 years ago by michael

By the way, does bug #7572 look like the same issue?

comment:6 Changed 4 years ago by virusek

This should be same as #7572. For workaround check that issue.

comment:7 Changed 3 years ago by frank

I doubt that. I can reproduce this problem with a Windows host and a Lucid guest with 3D effects enabled. The vboxvideo module is properly compiled and loaded.

comment:8 Changed 3 years ago by virusek

On Lucid is ok, because it has installed as default DKMS. Maverick does not have DKMS installed as default so DKMS will not build vboxvideo module. On Maverik DKMS must be installed before guest additions. So in my opinion, options for future guest addition releases are:

  1. Check for DKMS in install scripts
  2. Build vboxvideo module on install time, not using DKMS if DKMS not found. (or build it always?)

comment:9 Changed 3 years ago by frank

Again, this ticket has probably nothing to do with #7572. vboxvideo is compiled fine here but I still can reproduce that the guest window only moves to the right despite the direction of the mouse. The issue that vboxvideo is not compiled if DKMS is not installed was fixed some days ago in the SVN and the next maintenance release will contain the fix.

comment:10 Changed 3 years ago by virusek

Maybe this issue is caused by window decorator crash ? loukingjr did not provide any logs so its hard to deduce ...

Also:

OpenGL Warning: Unsupported GLX Call: glXGetConfig with attrib 0x8010, ignoring.

was fixed in SVN ?

comment:11 Changed 3 years ago by frank

No, the mouse issue is a VBox host problem. We are investigating.

comment:12 Changed 3 years ago by frank

Found the cause. The fix will be in the next maintenance release. And it is not sufficient to update the additions.

comment:13 Changed 3 years ago by frank

  • Cc loukingjr@… removed
  • Summary changed from VB 3.2.10 guest additions has broken desktop settings to VB 3.2.10 guest additions has broken desktop settings => Fixed in SVN

comment:14 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use