VirtualBox

Ticket #7565 (new defect)

Opened 4 years ago

Last modified 4 years ago

ntfs error 55 in host event log when reverting to snapshot

Reported by: alephzain Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords: ntfs event id 55 error snapshot
Cc: Guest type: Windows
Host type: Windows

Description

Win 7 ultimate x64 host Win Xp x86 guest

it happens like 2 out of three times. tried both with microsoft ahci controller driver and intel one on host, same behavior.

as a consequence of the error, the system partition (which in my case is the one where the virtual disk file resides) is marked dirty and chkdsk tested at next boot. no errors have been found so far.

Attachments

error.log Download (1.0 KB) - added by alephzain 4 years ago.

Change History

Changed 4 years ago by alephzain

comment:1 follow-up: ↓ 2 Changed 4 years ago by sandervl73

Please attach the VBox.log of that session...

comment:2 in reply to: ↑ 1 Changed 4 years ago by alephzain

Replying to sandervl73:

Please attach the VBox.log of that session...

I'm afraid there's no log because there's no session. When those errors appear in the host's event log, the virtual machine is stopped. By the way, another error occurred, but this time it was triggered by simply starting VB's user interface.

A little background about those errors: I've been plagued by them since august, so they were probably introduces by release 3.2.8. Since for a while they seemed completely random to me, but my physical drive had passed many though tests including several complete tests in Seatools and Spinrite, besides several chkdsk /r, I decided to activate message notification every time the dreaded error 55 appeared in the log. Since then, I've never seen that message unless VirtualBox's user interface was running and something significative had just happened, like opening the user interface or reverting to snapshots.

The reason why error 55 is so annoying to me, is I have StorageCraft's ShadowProtect installed, and when my system partition is checked at next boot following one of those events, the backup software loses its ability to track sector changes in real time, in order to do blazing fast incremental backups. After those events, it has to track down changes differentially, and that makes a 30 secs backup last like one hour and a half.

So, please, fix this.

comment:3 Changed 4 years ago by sandervl73

Well, I'm not convinced the problem is with VirtualBox. Do you have the host interface/host only and/or USB VBox drivers installed? If so, uninstall them to see if that makes any difference.

The fact that the error (also) occurs when you restore a snapshot seems to point to your backup software.

comment:4 Changed 4 years ago by alephzain

I've tried, but even without those drivers the error still appears.

Some things I might not been clear about:

1) As far as I know, the backup software loses its abilities to track changes after a partition is marked dirty no matter of the cause. The fact that happens is normal after an error 55, and it doesn't necessarily point in the direction of the backup software being the culprit.

2) The software's snapshot driver runs 24/7 but only VB triggers the error.

If the backup software is involved, I guess it's a bad interaction between them and VB. I have opened a thread on their forum, and I'll point them here. I hope you'll want to cooperate with them to understand what's going on.

I'm not pointing fingers, I'd just want the problem solved, that's all.

comment:5 Changed 4 years ago by alephzain

For reference, this is the thread I opened on ShadowProtect's support forum:

 http://forum.storagecraft.com/Community/forums/p/3503/16728.aspx

comment:6 Changed 4 years ago by sandervl73

What kind of graphics hardware do you have? You might want to try to rename VBoxTestOGL.exe in your VirtualBox directory. That's the only thing I can think of that can cause trouble when starting the VBox GUI. If that helps, then your graphics driver is the cause.

comment:7 Changed 4 years ago by alephzain

Thanks for your input.

I've got a GeForce 9800GTX with ForceWare 258.96 installed.

I tried what you suggested, and I haven't been able to reproduce the error when opening the GUI since. I tried like 30 times. I have to say I have only seen that once, so I have no idea about how easy it was / would have been to trigger that error by just starting the GUI.

The error when reverting to snapshot remains though. That's almost a 100% chance of happening.

The ideal thing was if you guys installed ShadowProtect and / or StorageCraft guys installed VirtualBox to see if you can reproduce the situation and see what happens under the hood.

comment:8 Changed 4 years ago by sandervl73

If the error occurs when reverting a snapshot in the GUI (no VM running), then I can't but conclude it's a problem with the StorageCraft software. In that case we do nothing but (a lot of) file io.

comment:9 Changed 4 years ago by alephzain

Yes, that's exactly what happens. I'll report your comment to them and see if they can find anything. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use