VirtualBox

Ticket #7564 (new defect)

Opened 4 years ago

Last modified 4 years ago

Repeater keys stuck forever, perhaps requiring host reset

Reported by: Raf_Schietekat Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

On host Ubuntu "Lucid Lynx" 10.04.1 LTS, VirtualBox 3.2.8 r64453, and the same Ubuntu version for a client (considering going full-time virtual Linux on a new system), pressing the physical sound control key until it repeats during full-screen video playback on the client never ends (sound volume control window keeps flickering). With the client displayed full-screen, and the video also full-screen, the mouse pointer was still visible and reactive, but nothing else I tried worked: home-f, positioning the pointer over the controls at the bottom (should shift up, but didn't), waiting overnight (problem persisted for several hours), ... Maybe I could have tried CTRL-ALT-F1 or something to get a text terminal (no access to external login at the time), or CTRL-ALT-BACK, I don't know if that would have worked, but instead I ended up having to reset the physical machine (not pretty). I don't really want to test this for reproducibility or to find the exact circumstances.

A milder form is when scrolling up or down on a web browser page or so: releasing the arrow key doesn't stop the scrolling, but at least this generally seems to end after the end of the page is reached, and then things return to normal.

Change History

comment:1 Changed 4 years ago by michael

Might this be a duplicate of the venerable bug #1229, which seems to affect quite a few people, but which none of us has ever succeeded in reproducing?

comment:2 Changed 4 years ago by Raf_Schietekat

Also Linux host apparently, different guest, but yes, this looks the same (I have not read all the comments) for the "milder form" in the second paragraph of my report here, which I have had happen to me over several host O.S. versions but never reported before. This case is also different because it involves the hardware sound control keys (Dell Latitude D820) and it is more severe, requiring a host reset. (Although... perhaps that might happen also for up/down scrolling that has no bounds in a particular application, because the scrolling always seems to stop there.)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use