VirtualBox

Ticket #1229 (new defect)

Opened 6 years ago

Last modified 4 years ago

Never-ending scrolling

Reported by: Gandalf Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords: mouse scroll
Cc: Guest type: other
Host type: other

Description

When I scroll horizontally through Excel worksheets by pressing the arrow-button of the scrollbar and do not release the mouse button immediately the system behaves like I would still hold the mouse button down. Scrolling stops not before Excel has scrolled through the whole table. I have found an analog behaviour as I tried to select text in the Excel VBA editor over the bottom of the window. Host: Ubuntu 7.10 Guest: Windows XP Pro VBox-Version: 1.5.6 (Ubuntu package 1.5.6-28266_Ubuntu_gutsy)

Attachments

i.do-2008-02-28-06-49-00.log Download (32.6 KB) - added by Gandalf 6 years ago.
WinXP_001.en-2008-03-12-19-01-46.log Download (29.6 KB) - added by kalin 6 years ago.
Log after the mouse got stuck in MS Excel (was able to unstick it this time after a minute of waiting)
winbox-2008-04-15-21-29-17.log Download (27.3 KB) - added by the_penguin 6 years ago.
VirtualBox Log after the dreaded "infinite scroll" bug (WinXP guest, Excel 2003).
vbox.log Download (28.9 KB) - added by scgroup 6 years ago.
Log: Dell 9400 Ubuntu host, XP guest, Excel 2003 runaway scroll
VBox.log Download (32.5 KB) - added by jfelten 6 years ago.
VB log showing pause/unpause to recover from endless scrolling bug
Windows XP-2009-01-22-00-28-13.log Download (39.8 KB) - added by bass 5 years ago.
log seems to go by GMT, scrolling occured at 12:27am (GMT-5) about 49-50min into the log, right near the end
vb-log-and-xset-q.zip Download (9.7 KB) - added by mlaker 4 years ago.
VirtualBox log plus `xset q' on guest and host
mlaker-3.2.7-r63131-virtualbox-log Download (14.1 KB) - added by mlaker 4 years ago.
Logfile from 3.2.7 beta
VBox.stickykeys.2.log Download (154.8 KB) - added by dannib 4 years ago.
Roughly betwen 00:04:34 and 00:04:35 I'm pressing in uparrow. Between 04:35 - 04:39 VM is on its own.

Change History

comment:1 Changed 6 years ago by Gandalf

Addition: The mouse acts generally sticky, that is whenever I perform an action with the left mouse button pressed, the action continues for a little moment after the button is released. That's sometimes pretty confusing!

comment:2 Changed 6 years ago by Gandalf

I think I have found a solution: After disabling the mouse driver option "Quick Initialization" (hope the translation is right - I'm using a German localization) in hardware manager the mouse behaves normal but it seemes to need some time to get ready after boot.

comment:3 Changed 6 years ago by nahwoo

I can confirm this behaviour. I run a CAD application where the workspace will autoscroll when the mouse pointer reaches the screen edge. Once the mouse triggers the scrolling it cannot be stopped until the workspace has scrolled to the X or Y limit in the direction the scroll was triggered. I tried turning off Quick Initialization in the driver advanced settings and it made the mouse unusable. I have a MS USB Intellimouse Explorer, OpenSuse 10.2 Host, and Windows XP Pro guest.

comment:4 Changed 6 years ago by Gandalf

Unfortunately, I was a bit rash with my report. After I have written it I had to notice that the mouse is unusable after every start of my virtual machine. The only workaround I found is to disable the mouse pointer integration and click into the vm window. Thereafter the mouse pointer integration can be enabled again. Pretty fiddly, isn't it?

comment:5 follow-up: ↓ 7 Changed 6 years ago by frank

Please post you VBox.log file after you experienced such a 'mouse button hang'.

comment:6 Changed 6 years ago by Gandalf

Today I was able to reproduce the problem in fullscreen mode with a maximized empty Excel worksheet. I jumped to cell A63000, hoping that scrolling would stop at the last row. It did but unfortunately, the virtual machine stayed unusable and I had to restart my X server.

Changed 6 years ago by Gandalf

comment:7 in reply to: ↑ 5 Changed 6 years ago by nahwoo

Replying to frank:

Please post you VBox.log file after you experienced such a 'mouse button hang'.

Please advise where this log is found and I will submit.

comment:8 Changed 6 years ago by frank

Main window, machine menu, 'Show Log...'.

comment:9 Changed 6 years ago by nahwoo

I have just upgraded from OpenSuse10.2 to OpenSuse10.3. Having done this, and reinstalled Virtualbox, the scroll problem reported in my CAD application in the guest WinXP Pro has gone. It now works as it should.

comment:10 Changed 6 years ago by kalin

I have analog problem that has bitten me many times since 1.5.2_OSE, 1.5.4_OSE, 1.5.6_OSE, now the same on 1.5.6 (all Gentoo host + WinXP guest). I don't see it that often, but generally trying to select in MS Excel triggers it. Will try to reproduce it and attach the log.

Changed 6 years ago by kalin

Log after the mouse got stuck in MS Excel (was able to unstick it this time after a minute of waiting)

Changed 6 years ago by the_penguin

VirtualBox Log after the dreaded "infinite scroll" bug (WinXP guest, Excel 2003).

comment:11 Changed 6 years ago by the_penguin

Forgot to mention in my first post:

1) The host is the same as the OP's (Ubuntu Gutsy 7.10), with WinXP SP2 as guest 2) I experience the same bug with both my machines (C2Q w/VT-x desktop and Core Duo laptop) 3) It happens every time I scroll, I need to go really slow with the mouse or it *will* happen (and scrolling through Excel's 65536 lines is no fun, it can take even 10 minutes!)

If you need any more info just ask, I'd like to help as much as possible: this bug is driving me nuts :-/

comment:12 Changed 6 years ago by pyramoose

Same problem here. Host: Ubuntu 8.04, Virtualbox 1.6 (non-OSE). I had the same problem earlier with Ubuntu 7.10, and earlier virtualbox versions. Guest is Windows XP SP3. It is scrolling in any program, not just Excel. Scrolls util it reaches the bottom or top of the document. It is only with the scroll buttons on the bar, if I drag the slider it is fine. Running on an dell inspiron 700m laptop with a touchpad. There's nothing in the log file except startup info and then some screen resolution changes. (The last scrolling problem would have been between those screen resolution changes).

comment:13 Changed 6 years ago by deaven

One more confirmation. On my Vsystem, the problem is always reproducible, and disabling the VM mouse integration fixes it. The "Quick Initialization" setting in device manager does not make any difference.

Reproducible scenario requiring less locked system than the excel bug:

  1. VirtualBox 1.6.0, Windows XP guest OS, Open SUSE 10.3 host
  2. Open an HTML doc in firefox which contains a table longer than the vertical height of the page.
  3. Left click and drag to select rows from the table starting at the top. Continue to drag off the end of the firefox window, activating an accelerated scroll-select.
  4. The page will scroll to the bottom no matter what you do with the mouse. No other apps can be selected, no other keyboard or mouse input is processed until firefox hits the end of the page.

comment:14 Changed 6 years ago by Gandalf

Same problem with Ubuntu 8.04 and VirtualBox 1.6.0!

comment:15 Changed 6 years ago by nahwoo

I am now running Xubuntu Hardy (8.04) and Virtualbox 1.6.2. My guest is Windows XP Pro. I can confirm that this out of control scrolling I earlier reported under OpenSuse still persists with my present installation. My application is Protel 99SE PCB CAD package. Under Vmware this problem is not present.

comment:16 Changed 6 years ago by alonbl

Any attempt to scroll down after end of document in MSWord 2003 cause this.

Gentoo, virtualbox-1.6.2

comment:17 Changed 6 years ago by scgroup

IMO, this is a very serious bug; it's disappointing to see that in six months, it has not been fixed and there is no reasonable workaround.

The problem is not limited to a few applications, nor to a specific OS. For example, OpenOffice.org 2.4.1 Calc in a Ubuntu 8.04 guest exhibits the same trouble as reported for Excel in a Windows guest.

When the problem occurs, VirtualBox does not respond to user input; one must forcibly terminate the guest, or wait for the application to reach the end of the document (which could take hours is some cases). If the guest is running full screen, there is no response to the host key; a remote login is the only way to kill the errant guest. If the host is not remotely accessible, or if you don't have access to another computer, your only recourse is to forcibly power down the host system, losing any unsaved work in the host and all guests.

There are hundreds of programs that activate continuous or repeated scrolling by dragging beyond the edge of a document. It's probably safe to say that most applications dealing with documents that are potentially much larger than the screen use this paradigm. I believe that the majority of those using VirtualBox on a workstation will be bitten by this bug.

My configuration: Dell Inspiron 9400 Ubuntu 8.04 host VirtualBox 1.6.4 Ubuntu 8.0.4 guest Win XP SP3 guest

comment:18 follow-up: ↓ 22 Changed 6 years ago by frank

Unfortunately we are still not able to reproduce this problem. I would appreciate if you could attach a VBox.log file of your VM session with 1.6.4 to this defect. I don't expect to see any problem there but one never knows.

Obviously the chance to fix bugs we can reproduce is bigger than the chance to fix bugs we cannot reproduce. And keep in mind that this is not the only bugtracker we have, there are customers demands as well...

comment:19 Changed 6 years ago by sandervl73

It's very simple. We've never seen this bug and can't reproduce it using the instruction posted here. If 'everybody' were indeed affected by this bug, then a lot more people would complain.

It's more likely that something on your host is interfering with VirtualBox. Some desktop manager, 3d tools or whatever. It would be useful if you could provide more information than just Ubuntu 8.04.

comment:20 Changed 6 years ago by webhelp

I am also having the issue running xp pro on ubuntu 8.04

However this is an issue that i had encountered on a few occasions when I was running a plain old windows computer. It was one of the reason why I changed to Ubuntu.

I feel this issue isn't a virtualbox issue but a MS issue

Changed 6 years ago by scgroup

Log: Dell 9400 Ubuntu host, XP guest, Excel 2003 runaway scroll

comment:21 Changed 6 years ago by scgroup

On the Dell 9400 (Mobile Intel 945GM Express Chipset, 1920x1200 LCD panel) under Ubuntu, when continuous scrolling, VirtualBox seems to "get behind" rendering the display, preventing it from processing keyboard or mouse input in the guest window.

If I connect to the guest using RDP, the trouble does not occur, even if the Terminal Server Client is run on the host. If I make the guest window small enough, I can show it side-by-side with Terminal Server Client connected to the same guest. Of course, you see two copies of the guest screen and can control the guest from either. Now, if I click in the vbox window, select a cell in Excel, and drag off the botton of the window, the uncontrollable scrolling will start. But strangely, as soon I move the mouse into the TSC window, the scrolling stops! So it appears that it's only the vbox guest window that can't receive input.

It's more likely that something on your host is interfering with VirtualBox. Some desktop manager, 3d tools or whatever. It would be useful if you could provide more information than just Ubuntu 8.04.

But I am running "just Ubuntu 8.04". The host started as an empty partition; I installed an ISO downloaded from Ubuntu.com, and made all automatic updates. Although I installed various applications, none of them (except for VirtualBox), modify the kernel, X, Gnome, or startup files. So, when these other apps are not running (and for this testing, they aren't), system behavior is completely standard. (I have since installed VMware workstation, which does modify system behavior, but the VirtualBox trouble was present before VMware, and remains the same after.)

I noticed that seamless mode is not stable on my system; garbage and remnants of old windows are often displayed, and the display sometimes hangs. I did not attempt to investigate this further, because I don't need seamless for my application, and both window and fullscreen modes work fine (except for the scrolling bug). However, this may be a clue to the scrolling problem.

It's possible to see the trouble remotely, by connecting to the host desktop by VNC and displaying the guest in a host window. If you have no other way to duplicate the problem, I could provide such access for Sun.

comment:22 in reply to: ↑ 18 Changed 6 years ago by lmarina

I have found this bug hosting in red hat 2.6.9-78.0.1.EL.cernsmp athlon i386 GNU/Linux and hosting in debian last release, both using virtualbox for legal microsoft windows, one xp and the other 2000 pro. In both cases this happens with exel, would you please try and reproduce the bug, because it is very frustrating and my boss as many I know are planing on giving up on VirtualBox at this account, even if it means using a bought software.

comment:23 Changed 6 years ago by jfelten

Exact same problem here and reproducible. Ubuntu 8.04 host running virtualbox 1.5.6 running guest Windows XP (latest patches).

Linux d810 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

I mostly notice it in a large text file I have loaded in Windows notepad. Sometimes when I click on the down arrow to scroll down a line it just takes off scrolling and doesn't stop. The entire guest OS becomes unresponsive and CPU load pegs at 100%. Extremely annoying when I have a lot of files open with unsaved work etc. I did find one trick that seems to recover to avoid having to crash virtualbox. Although the virtualbox main window becomes very sluggishly responsive, I can right click on the vm and pause it if I'm patient. Once paused I can then unpause the vm and the scrolling has stopped and I can then save my files etc. without having to crash virtualbox.

I'll attach the log file but I see nothing logged between when I pause and unpause, but maybe something earlier in the log may help. Note the two pause/unpause cycles at the end of the log are when it happened twice in a row.

I need to experiment a bit. It may happen when I left click on the down arrow and slightly move the mouse pointer at the same instant.

I've down arrowed millions of times in notepad in native windows XP and have NEVER seen this problem. This is definitely a virtualbox problem and not a problem endemic to windows itself (as much as I would like to blame windows). I've also never seen this problem in Linux.

Finally, thanks for virtualbox. Fix this and fix the broken Ethernet bridging with SuSE 11 and I'll be extremely happy with it.

Changed 6 years ago by jfelten

VB log showing pause/unpause to recover from endless scrolling bug

comment:24 Changed 6 years ago by frank

scgroup, you added the wrong log file. Please update to 1.6.6 where the logging bug is fixed. The correct logging file can be found in ~/.VirtualBox/Machines/VM_NAME/Logs.

comment:25 Changed 6 years ago by jfelten

P.S. Just happened again, this time when I clicked on the up arrow scroll widget. The pause/unpause trick worked again to recover control but I had to wait about 60 seconds after selecting pause before virtualbox would respond to unpause. Nothing new in the log file except the pause/unpause event.

It is hard to navigate through a large text document without clicking on those scroll widgets, plus old habits die hard. Dell Latitude D810 laptop with touchpad (no scroll wheel, not that I care for them anyway).

comment:26 Changed 6 years ago by jfelten

Another clue perhaps. This time it happened with a custom application, but it didn't lock up the vm like it normally does with notepad. I still had control, and when it got as far as it could scroll, it stopped. Since I could reproduce it without locking up the vm, I found that it happens whenever I left click on the scroll widget and hold down the "mouse" button for about one second or more. Less than a second and it worked normally. A second or more and it continued scrolling on its own. Also, I noticed that while it was scrolling, the scroll widget was "depressed". About 3 second after it reaches the end of how far it can scroll, the scroll widget un-depresses by itself. All of this is without the mouse cursor anywhere near it. Hope this helps crack this bug. If anyone on the vb development team wants to contact me to try some tests, please feel free to do so.

comment:27 follow-up: ↓ 28 Changed 6 years ago by padde

I encountered (probably) this bug today while working with MS Excel 2003 running on Windows XP SP3 in VirtualBox 1.6.4_33808_fedora8-1.i586 (PUEL, on Fedora 8, 32 bit).

I then logged on to my computer at home and fired up VirtualBox 1.6.6 (OSE, on Gentoo, 64 bit). MS Excel 2008 on Windows XP SP3 behaves in the exact same way there.

What I did:

  • Start up MS Excel
  • Select a random cell
  • Pull the mouse down to the edge of the screen in order to trigger automatic scrolling to be able to select more cells down below

Excel then scrolls down like mad, selecting all cells in that column until it reaches the lower-most cell (in line 65536). This takes only a few seconds, but afterwards VirtualBox is still completely unusable for a couple of seconds. During the scrolling, if I minimise VirtualBox and then restore the window again, only Excel's work area (where the cells are) is being redrawn, everything else is black (Windows' task bar, the menu area, etc.).

Hope this helps fixing this bug.

comment:28 in reply to: ↑ 27 Changed 6 years ago by padde

Replying to padde:

Hope this helps fixing this bug.

Additional data: I just uninstalled Guest Additions and tried again, and the same happens - with one small difference: The mouse cursor cannot be moved while the scrolling madness is happening. Maybe this helps narrowing down where the problem might be.

comment:29 Changed 6 years ago by padde

I just updated to VirtualBox-2.0.2_36488_fedora8-1.i386 (PUEL, on Fedora 8, 32 bit), installed the new Guest Additions and the problem still persists.

comment:30 Changed 6 years ago by hifih

I have this on both (all) of my home desktop PC's

Ubuntu 8.04 Running Virtual Box 1.5.6_0SE with Guest Additions and Windows XP Home with SP 3

(symptom : when clicking on scroll up arrow at left of Quicken account page the scroll procedes until it reaches the first entry in the account page - in this case records from 2004 - no other input is possible until first entry is reached - about 30 seconds)

Ubuntu 8.04 Running Virtual Box 2.0.2 with Guest Additions and Windows XP Home with SP3

  • installed this edition of virtual box to enable USB printing from this PC.

(symptom : when clicking on scroll up arrow in PAF5 list view behaviour is identical to that on other PC)

PC's are not identical but both have latest Ubuntu 8.04 with all updates.

comment:31 Changed 6 years ago by hifih

Correction

In previous post should be scroll arrow on right (not left) of both Quicken and PAF pages.

comment:32 Changed 6 years ago by kifkroker

In my case the solution was (reproducable) to reduce the color-depth to 16bit (inside the guest).

comment:33 Changed 6 years ago by deaven

I just tried changing color depth to 16 bits. It fixed the issue for excel, but not for MS word. I also tried progressively turning off video acceleration "Control Panel -> Display -> Settings -> Advanced -> Troubleshooting", and at "no acceleration" the problem gores away, but all other settings from minimal acceleration to full acceleration still show the bug.

VirtualBox 1.6.0 with patched guest additions Host: OpenSuSE 10.3, Gnome

NVidia graphics card & driver window manager = metacity-2.20.0-4.2

Guest: Windows XP

Scenario: open any multi-page Word document in MS word within guest. Select text, drag down and continue down past Word window border, activating speed scroll/select. Release mouse button. Scrolling continues to end of document regardless of when mouse is released.

comment:34 Changed 6 years ago by hifih

Reducing colour depth to 16 bits has worked for me on one of my PC's - will report again when I have checked the other one.

comment:35 Changed 6 years ago by hifih

Reducing colour depth to 16 bits has now worked on both my PC's - no changes necessary to video acceleration in my case.

Thanks to all for assistance.

comment:36 follow-up: ↓ 37 Changed 5 years ago by kilou

None of the workarounds described here (16bits color and/or no disabled hardware acceleration) solve the problem for me. I'm runing Ubuntu 8.10 as host and xp guest in VirtualBox 2.0.4. However I wonder if the problem is not related to screen resolution and especially the use of "auto resize guest display" option. I didn't tested that extensively but it seems that disabling this option solves the problem. Can anyone confirm this behaviour?

Thanks

comment:37 in reply to: ↑ 36 Changed 5 years ago by kilou

Actually, as soon as I use another resolution than the native one (800x600) I get the scrolling problem. Even if I do not use "auto resize guest display" and try to modify the resolution of the virtual machine from Ubuntu terminal with:

VBoxManage setextradata global GUI/MaxGuestResolution 1024,768 (for example)

...i'll get the scrolling problem. For me it seems to be linked to the use of a "non native" resolution in virtualbox (my laptop uses a 1280x800 resolution but it seems that VB default is 800x600. What I mean if all resolutions different from 800x600 will reproduce the scrolling problem). So for now I stick with 800x600 because I need Excel quite a lot.

comment:38 follow-up: ↓ 39 Changed 5 years ago by michael

Have any of you tried disabling hyperthreading in the (host) bios to see if it makes a difference?

comment:39 in reply to: ↑ 38 Changed 5 years ago by kilou

Replying to michael:

Have any of you tried disabling hyperthreading in the (host) bios to see if it makes a difference?

I have no such option available in my BIOS (laptop with Pentium-M Centrino). In my case, the problem is clearly linked to the resolution of the virtual machine: as soon as I use something else than 800x600, the scrolling problem occurs in Excel.

comment:40 Changed 5 years ago by bass

I've noticed something like this when playing Starcraft: Broodwar on a Windows XP SP3 guest using both the OSE and full version of VirtualBox 2.1.0. The host system runs 32-bit Ubuntu Intrepid, on an AMD FX-53 processor with 2GB memory. This problem persists whether mouse integration is enabled or disabled, windowed or fullscreen. I normally play with it disabled, in full screen with my X resolution set to match the game.

In the game, moving the mouse to the edge of the screen causes the screen to scroll. I sometimes get stuck with it scrolling up or down (I've not seen this in side scrolling yet), and when reaching the scrollable range, it will continue to scroll itself back in that direction if I try to scroll away from it.

I've also had this problem several times in Excel with older versions, but haven't been using Excel as much lately so I don't know if that's fixed or not.

After much frustration, I randomly discovered that pressing NUM LOCK will release the scrolling. That's right, NUM LOCK, not SCROLL LOCK. Also, it doesn't matter whether NUM LOCK was already turned on or off, toggling it either way stopped the undesired scrolling. However, this has happened multiple times in the same game before, so pressing NUM LOCK seems to to fix the current scrolling lock, and does not prevent further occurrences. I have yet to have an opportunity to try this fix with Excel or other programs. Regardless, having this happen in the middle of a game is bad and I would very much like to find a more permanent solution.

Note that I have not yet found a sure method to reproduce the problem... it just seems to strike at random.

comment:41 Changed 5 years ago by jfelten

Thanks. I'll give Num Lock a try the next time I boot up VB. I've pretty much stopped using it and gone back to vmware due to this bug.

comment:42 Changed 5 years ago by frank

bass, please could you attach a VBox.log file of a VM session where you observed that scrolling problem and pressed NUM LOCK to stop it?

comment:43 Changed 5 years ago by bass

I will do so the next time it happens, possibly tomorrow or at worst the next couple of days. I start and shut it down so many times in a day, I can't remember which VirtualBox session it happened in today, so I will just have to wait for the next. I'll try to note the time as well so that hopefully you'll know where to look in the log.

Are there any kind of debugging or other parameters you want me to pass VirtualBox while trying to log the error? Let me know and I will do so each time I run it. Currently I'm using the full Sun version of the product. Thanks for your interest.

comment:44 Changed 5 years ago by frank

I will probably send you a debug build once I saw the VBox.log file. So far no special parameters.

Changed 5 years ago by bass

log seems to go by GMT, scrolling occured at 12:27am (GMT-5) about 49-50min into the log, right near the end

comment:45 follow-up: ↓ 46 Changed 5 years ago by bass

I finally remembered to copy a log after reproducing the problem in a game. Fortunately, the problem occurred right at the end of the match, so I was able to quit playing and take a copy of the log very shortly after it actually happened, so if anything shows up it should be near the end of the file in the last few minutes or so.

comment:46 in reply to: ↑ 45 Changed 5 years ago by bass

Actually, I just looked at the log myself, and I don't see anything that would represent the problem. The first line I see around the time the problem occurred is:

"00:50:44.165 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b2a61000 w=720 h=480 bpp=32 cbLine=0xB40"

I play with VirtualBox full-screen, and StarCraft runs in 640x480 8bpp mode with my X resolution at 720x480. This helps correct the aspect ratio somewhat, because I have a wide screen display. I also had mouse integration off, so that kept the mouse from straying outside the game. That particular line of the log is just me ALT-tabbing out of StarCraft, just before switching VirtualBox back from full-screen to windowed mode in order to access the log file. That was about a minute after the problem occurred, so I think I need a way to create a more detailed log to catch the problem.

Also I forgot to mention, this time it got locked side scrolling, so apparently the problem can happen in any direction while running the game, not just vertically.

comment:47 Changed 5 years ago by bass

Any advice on how to produce a more useful log?

comment:48 Changed 5 years ago by tozzi

Any news? Or the problem still persists? On my pc (slackware 12.2 host, OSE 2.1.4, Win XP SP3 guest), no workaround works (mouse integration, hardware acceleration, 16 bit depth). May I help you giving any helpful data to find out the problem (and the solution)?

comment:49 Changed 5 years ago by prtsoftware

Is this the same or related to this bug "runaway message queue"? It might be that reducing the resolution and/or other fixes really are just minimizing either the number of items in the queue or speeding VirtualBox's ability to get through the queue.

 http://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg855139.html

I see this issue with Kubuntu 9.10 and both VB 2.2 and VB 3.04. For me it mostly manifests itself in uncontrolled scrollbar scrolling but I also see it with CAD-type programs (such as ExpressPCB) where a "mouse at edge of window" condition causes scrolling.

TJ

comment:50 Changed 4 years ago by mlaker

I'm seeing a similar problem with AMD64 Ubuntu 9.10 guest and host and VirtualBox 3.1.2 -- but I'm seeing it only with the keyboard, not with the mouse. If I go to a long Web page (such as this one) and hold down the down-arrow key for just over a second, the browser will laboriously scroll down to the end of the page, one line at a time. This happens in both Firefox and Konqueror. While the text scrolls, and sometimes for a few seconds afterwards, X ignores keyboard and mouse input, even in other windows, although it does seem to queue them up and execute them after the wild scrolling has finished. If I disable keyboard auto-repeat with xset -r', the problem goes away. I normally run with xset r rate 250 30'; dropping down to a very conservative `xset r rate 500 20' doesn't fix the problem.

Not all programs exhibit the problem: for example, if I copy the text of this page into OpenOffice.org Writer and scroll through it, scrolling will stop as soon as I release the arrow key.

Wild scrolling doesn't produce any output in the VirtualBox log, but I'm attaching a zipped logfile anyway, just in case it's useful. In the same archive, I'll include the output of `xset q' in both the guest and the host. See vb-log-and-xset-q.zip.

Changed 4 years ago by mlaker

VirtualBox log plus `xset q' on guest and host

comment:51 Changed 4 years ago by mlaker

Perhaps the reason why the VirtualBox folks can't reproduce the problem is that it's very sensitive to both the keyboard repeat rate and the application. I'm running 64-bit Kubuntu 9.10 on both host and guest. If, in the guest, I set the keyboard repeat rate to 15/sec, the problem never arises in Firefox. At about 17/sec, it happens intermittently. At 20/sec, it happens every time I leave my finger on a vertical arrow key for more than half a second or so. Oddly, only the vertical arrow keys display the problem: PgUp and PgDown don't.

OpenOffice.org Calc displays the problem; OpenOffice Writer doesn't. Kate and jEdit display it even at a repeat rate of 15/sec, and jEdit displays it even with PgUp, PgDown and (when it's used to paste multiple lines of text into the buffer) Ctrl+V. OO Calc, Kate and jEdit scroll line-by-line, whereas OO Writer does Emacs-like scrolling -- it waits until you get to the bottom of the window and then scrolls half a window at a time. So it seems that apps that can't display text fast enough to keep up with scrolling exhibit the problem, and get a pile of spurious keystrokes queued up, whereas apps that can keep up are well-behaved.

You already have a logfile from my comment of 2010-01-16. Please let me know if there's anything else I can do to help you debug the problem.

comment:52 Changed 4 years ago by michael

Could you test to see whether disabling auto-repeat on the host makes a difference?

comment:53 Changed 4 years ago by mlaker

Disabling auto-repeat on the host doesn't eliminate the problem, but seems to mitigate it: the unwanted scrolling ends after a few dozen lines, rather than continuing for hundreds or even thousands of lines as before. Thanks for this workaround.

comment:54 Changed 4 years ago by michael

It looks to me like this only occurs on Linux hosts. Has anyone seen this on other hosts? (If it occurs on Linux I would also expect it on Solaris and FreeBSD, due to the large amount of code shared between these platforms.)

comment:55 Changed 4 years ago by pippom77

I experience similar problems with the mouse, both under Windows7 64bit and Ubuntu hosts, both on Win XP and Ubuntu guests.

When I am requested to hold down left or right button while moving the mouse (typ. gaming), the screen starts rolling 'till I release the button. If I disable mouse integration, the pointer disappears under open (graphical) windows.

I post here because I think this behaviour is generated by the same cause. Indeed the problem is a kind of over sensibility of the mouse while using buttons (or wheel).

I have a Dell Studio 1558: maybe the problem appears on Dell computers much more often than on other computers (I'm about sure of this...).

comment:56 Changed 4 years ago by michael

pippom77: what guest application/game was that? (Preferably something freely available that I can try out...) And did disabling keyboard auto-repeat on the host make a difference? Note that so far I unfortunately haven't been able to reproduce this using any of the recipes on offer though.

comment:57 follow-up: ↓ 58 Changed 4 years ago by pippom77

Thank you Michael for speedy answering!

The problem occurs i.e. on Ubuntu guests by using the Cubic Desktop feature on Compiz: while holding down ctrl, alt and left mouse button, moving the mouse among desktops causes a twirling of the cube. This behavior continues 'till mouse button release. (This is not the only application showing this strange conflict, but I think it is one of the more easy to get - and it's free :) )

Now I'll try the keyboard auto-repeat disabling.

thanks! pippo

comment:58 in reply to: ↑ 57 Changed 4 years ago by dannib

Disabling the auto-repeat on host made the problem go away for me. Thanks Michael!

I can give my setup if it may help debugging. Host is ubuntu (10.04 x86-64bit) and Guest ubuntu (9.10 x86). Host and Guest have no Compiz visual effects activated. The applications where my up and down-arrow got stuck, scrolling through several thousand lines leaving me unoccupied for minutes sometimes, was emacs (emacs-snapshot-gtk). The problem started appearing after I upgraded virtualbox from 3.1 to 3.2 (3.2.4). In version 3.1 I never had this problem.

Replying to pippom77:

Thank you Michael for speedy answering!

The problem occurs i.e. on Ubuntu guests by using the Cubic Desktop feature on Compiz: while holding down ctrl, alt and left mouse button, moving the mouse among desktops causes a twirling of the cube. This behavior continues 'till mouse button release. (This is not the only application showing this strange conflict, but I think it is one of the more easy to get - and it's free :) )

Now I'll try the keyboard auto-repeat disabling.

thanks! pippo

comment:59 Changed 4 years ago by michael

  • Version changed from VirtualBox 1.5.6 to VirtualBox 3.2.6

I have a suspicion, which may or may not be right, about what could be causing this problem. I have prepared a test build of the current stable branch of VirtualBox (see here for information and disclaimers) which should print an additional warning in the logfile when this problem occurs - if my suspicion is correct. The URLs at which you can download the test build are:

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-06-28-11-37-40-lin32-3.2-3.2.7-r63131.run (32 bit Linux version)

and

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-06-28-11-43-04-lin64-3.2-3.2.7-r63131.run (64 bit Linux version)

Feedback is obviously appreciated.

comment:60 Changed 4 years ago by dannib

I've tried the 64 bit version and reproduced the problem several times. I turned on key-repeat on host. However the last printout in logs is: "00:01:59.016 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f2af35ab000 w=2560 h=1600 bpp=32 cbLine=0x2800". The log is not updated before, during or after sticky-scrolling.

I didn't manage to reproduce the error with key-repeat disabled on host. However I have experience the same problem even with host key-repeat disabled, but MUCH more seldom.

How long time VM becomes unresponsive and stuck with scrolling, doesn't seem to relate to where in any document I am. It may stop long before reaching eof, or long after. All my 4 CPU kernel hit around 50 % utilization during scrolling. It doesn't matter if VM is fullscreen or not.

comment:61 Changed 4 years ago by mlaker

I got the same results as dannib: I reproduced the problem easily enough using the 64-bit VirtualBox code, and all four cores went to about 50% utilisation, but the VirtualBox log doesn't show anything about the scrolling. I'll attach it anyway, just in case it helps. In my case, the host is a fully-patched 64-bit Kubuntu 9.10 and the guest is a fully-patched 32-bit Kubuntu 10.04.

How do I uninstall Virtual 3.2.7-r63131 so that I can go back to vanilla 3.2.6 cleanly? Giving the 3.2.7 installer a --help switch elicits about twenty lines of help, but I don't see a --remove option.

Many thanks for looking at this problem. It really is appreciated.

Changed 4 years ago by mlaker

Logfile from 3.2.7 beta

comment:62 Changed 4 years ago by mlaker

(My attachment is a zip file, although I see that zip(1) didn't give it a .zip extension, probably because of the dots in the filename. Apologies for the confusion.)

comment:63 Changed 4 years ago by michael

OK, that guess seems to have been wrong... could I suggest another test for you to try? This one will work with the current VirtualBox release (and it should do with the latest 3.1 releases too). Start a VM with which you can reproduce the problem from the command line with the following command:

$ VBOX_RELEASE_LOG=+dev_kbd.e.l.l2.l3.f VirtualBox --startvm <VM Name>

This will cause all keystrokes and non-Additions mouse movements - as the virtual machine sees them! - to be added to the logfile. Reproduce the problem and then check the logfile at once to see what the last line in it is. Then attach the logfile to this ticket with a marker in it to show the place where the problem occurred.

I hope this may shed a bit more light on the issue.

Changed 4 years ago by dannib

Roughly betwen 00:04:34 and 00:04:35 I'm pressing in uparrow. Between 04:35 - 04:39 VM is on its own.

comment:64 Changed 4 years ago by dannib

As you see in attachment there is alot of kbd_queue(...) events. I can verify that the scrolling got stuck between 04:35 - 04:39 but also earlier in log at one or two occasions.

Now I activated key-repeat on host for this. I've experienced the problem several times today with key-repeat disabled. So I'll enable this debug printout with key-repeat disabled on host and get back if something interesting might show up. (Disabling Key-repeat makes working in terminal on host awful :-)

comment:65 Changed 4 years ago by michael

From the log I can see that the VM saw 71 key down events (if I counted right) followed by one key up event for the up key. Did the scrolling stop on its own that time (between 04:35 - 04:39) or did you do something to make it stop?

comment:66 Changed 4 years ago by dannib

It did stop on its own on the middle of a document and I didn't press any other key until ~3 seconds afterwards.

comment:67 Changed 4 years ago by dannib

No sticky scrolling events scrolling up: 0xe0, 0x48, 0xe0, 0x48, ..., 0xe0, 0xc8 scrolling down: 0xe0, 0x50, 0xe0, 0x50, ..., 0xe0, 0xd0

When sticky scrolling occur the result is exactly the same.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use