VirtualBox

Ticket #7472 (new defect)

Opened 4 years ago

Last modified 18 months ago

VirtualBox freezes whole System on Ubuntu 10.10 when starting Guest

Reported by: hexa- Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.8 Keywords: maverick guest start freeze system
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Tried this on two computers:

  • Host: Ubuntu Maverick x86_64 (worked fine in Lucid)
  • Kernel: Linux ... 2.6.35-20-generic #29-Ubuntu SMP Fri Sep 3 14:55:28 UTC 2010 x86_64 GNU/Linux
  • Two Machines: Core2Quad Q9450 (Desktop), Core i7 620LM (Laptop)
  • Guest: Win7 x86_64

When starting the Guest the window opens, the progress bar stays at 0% and the whole computer freezes. There is no log entry whatsoever I could find.

This only happened after I added my user to the vboxusers group, it worked just fine without adding them.

Cannot really tell who is at fault here, but will assist in finding out who is at fault here if you tell me what to do.

Attachments

virtualbox-info.txt Download (2.4 KB) - added by rrp 3 years ago.
Vista.xml Download (6.1 KB) - added by rrp 3 years ago.
VM XML file
VBox.log.3 Download (634 bytes) - added by rrp 3 years ago.
Log File
vbox-messages.log Download (3.3 KB) - added by rrp 3 years ago.
VirtualBox related items in /var/log/messages
cpuinfo.txt Download (1.5 KB) - added by rrp 3 years ago.
CPU Info
VBox.log Download (64.8 KB) - added by rrp 3 years ago.
Log file of VM started without VT-x enabled

Change History

comment:1 Changed 4 years ago by frank

  • Description modified (diff)

Did I understand you correct: When the current user is not member of the group vboxusers you are still able to start virtual machines and the host does not freeze?

comment:2 Changed 3 years ago by jasmines

Same issue here. Host: Ubuntu 10.10, virtualbox 3.2.10. Guest: Windows XP

Changed 3 years ago by rrp

comment:3 Changed 3 years ago by rrp

Same issue here. As soon as I start the guest, the host machine freezes, and a power cycle is required.

Am running Ubuntu 10.10 x64 host. Haven't been able to install guest OS yet. My system details are contained in attached file virtualbox-info.txt

comment:4 Changed 3 years ago by frank

rrp, please try if  this test build fixes your problem.

comment:5 Changed 3 years ago by rrp

Thanks frank. Installed and tested with the same result. Started a guest machine and almost immediately the host machine froze completely.

comment:6 Changed 3 years ago by frank

Please could you attach the .xml file of this VM? Is there any VBox.log file created for that VM? If so, please attach it as well. Any related message in /var/log/messages after reboot of the host?

Changed 3 years ago by rrp

VM XML file

Changed 3 years ago by rrp

Log File

comment:7 Changed 3 years ago by rrp

VM xml file attached as requested. There were a number of log files for this VM, most had a size of 0 bytes, but I was surprised to find 2 with some content (both files were identical, so only one attached).

Couldn't see anything obvious in /var/log/messages. I've tried to capture all VBox related messages from the log file using cat /var/log/messages | grep -E -i v(irtual)?box > vbox-messages.log - see attached file.

Changed 3 years ago by rrp

VirtualBox related items in /var/log/messages

comment:8 Changed 3 years ago by frank

Unfortunately nothing interesting in the log files. What host CPU do you have? The question is if your VM runs in VT-x/AMD-V mode or in raw mode (when this extension is disabled). If your CPU is capable of VT-x/AMD-V then the question is still if this extension is really available or somehow locked by the BIOS. Furthermore: Is this a "normal" Maverick installation or do you run any special software in parallel to VirtualBox? Just for the record, I'm using the testbuild I posted above successfully on a 64-bit Maverick host, with and without VT-x.

comment:9 Changed 3 years ago by frank

One observation: Does your host freeze as well if you disable 3D for that VM?

Changed 3 years ago by rrp

CPU Info

comment:10 Changed 3 years ago by rrp

Host CPU is a non-overclocked Intel Core 2 Duo E8400 (see attached CPU info dump). I've checked that the VT-x is enabled in the BIOS.

OS is just vanilla Maverick 64 bit. Haven't installed much else on the machine apart from Git and Eclipse.

comment:11 Changed 3 years ago by rrp

I just tried disabling VT-x support for the VM, and it worked - no crashes. Is there an easy way to determine why VT-x support is failing?

comment:12 Changed 3 years ago by frank

Hmm, this is at least a beginning. Could you enable the VBox.log file for that VM with VT-x disabled?

Changed 3 years ago by rrp

Log file of VM started without VT-x enabled

comment:13 Changed 3 years ago by rrp

Log file attached as requested. Successfully started machine, and began client OS installation process. Installation was abandoned part-way through.

comment:14 Changed 3 years ago by frank

Thanks. Is the kvm module loaded by chance (lsmod | grep kvm)? If so, could you unload the module and check to start the VM with VT-x enabled again?

comment:15 Changed 3 years ago by rrp

Thanks frank. KVM module is definitely not loaded (lsmod | grep kvm outputs nothing). Full output of lsmod was attached earlier in file virtualbox-info.txt

comment:16 Changed 3 years ago by robisaks

I am having similar issue. Except I can boot into the guest OS and it seems to run fine until I try to use it. I'm not sure if this is the same issue or I should post a new bug report.

I get the same results from the test version posted. I also have nothing in out from "lsmod | grep kvm".

Host: i7 on ubuntu 10.10 kernel 2.6.35-23-generic Guest: Win7 64

comment:17 Changed 2 years ago by RafSchietekat

Confirmed with VT-x enabled, Ubuntu 10.04 LTS host, Virtualbox 4.1.14, Ubuntu 12.04 LTS guest. This exact combination had worked before I started to explore KVM, but then two consecutive Start attempts of the VirtualBox guest each left the system completely frozen (not even a CTL-ALT-F1 text console could be started from the keyboard, resolved by resetting the computer and suffering the fsck, the first of which had to fix a problem, SMART Status was "Disk is healthy"). The KVM guest had not been started since powering up the system, but lsmod | grep kvm showed the module loaded; I did not try only unloading the KVM kernel module, but after removing the KVM guest, uninstalling package kvm (and the packages on which only kvm depended) I could use VirtualBox again.

Suggested remedy in anticipation of a solution: display a warning if KVM is detected.

comment:18 Changed 18 months ago by jglick

FWIW I had a very similar issue with 4.1.12 on a Precise (32-bit) host: I was able to start Windows guests without problems, but whenever I tried to start a Linux (64-bit) guest my host system froze completely (no Ctrl-Alt-F1 &c.) and had to be power-cycled.

These same VMs were working fine recently; I do not recall updating either my host kernel or VBox immediately prior to this, nor making any config changes to those VMs. The one thing I did recently that seems like it might be relevant was install a VM with SmartOS.

I do not have KVM installed.

Upgrading to 4.2.4 (i.e. removing the old version from Ubuntu software sources, adding the source from virtualbox.org, and installing from that) appears to have solved the problem.

comment:19 Changed 18 months ago by jglick

Unfortunately the 4.2.4 installation  stopped loading at all after the first run so I am back to the stock 4.1.12 installation, which continues to suffer from this bug. I cannot disable VT-x since I am running 64-bit guests on a 32-bit host. (Which worked fine for months until just yesterday.)

Logs/VBox.log is empty. ~/.VirtualBox/VBoxSVC.log has no warnings or errors.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use