VirtualBox

Ticket #7471 (new defect)

Opened 4 years ago

Last modified 4 years ago

Deficiencies in linux build instructions on Lucid AMD64

Reported by: dsjstc Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords: build documentation
Cc: Guest type: other
Host type: Linux

Description

Cannot build on Ubuntu Lucid AMD64 with the existing build instructions.

Packages missing from the build requirements: libxinerama-dev libxrandr-dev python-dev makeself

Packages no longer available on Lucid: libstdc++5 python2.5-dev

Change History

comment:1 Changed 4 years ago by dsjstc

Additionally missing, but not caught by configure:

yasm texlive-latex-base

comment:2 Changed 4 years ago by dsjstc

Nope, still didn't build. Also needs texlive-latex-extra. And two fonts which are not available in the lucid repositories:

 http://www.tug.org/texlive/devsrc/Master/texmf-dist/tex/latex/ucs/ucs.sty  http://www.tug.org/texlive/devsrc/Master/texmf-dist/tex/latex/bera/beramono.sty

Need to be in /usr/share/texmf/tex/latex/, subdirectories ucs and bera, respectively. Then run texhash.

comment:3 Changed 4 years ago by dsjstc

NB: the build instructions to which I am referring are the Linux build instructions, from the official Wiki, at:

 http://www.virtualbox.org/wiki/Linux%20build%20instructions

comment:4 Changed 4 years ago by frank

Yes, and you are trying to compile the trunk which should be considered unstable. And yes, we are aware that these instructions need update. Thanks for sharing your findings.

Regarding the missing LaTeX files: Just installing texlive-latex-extra should be sufficient and there is no need to download these files manually. apt-file search ... is your friend.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use