VirtualBox

Ticket #746 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VirtualBox causes problems copying to clipboard in Ubuntu Linux -> please retry with 1.5.2.

Reported by: giannis Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

This is how you can reproduce this bug and see it for yourself. I have tested it in two different computers running the same configuration.

Host OS: Ubuntu 7.04 with all latest updates installed Guest OS: Windows XP Professional SP2

Start VirtualBox, create a new virtual machine in a new virtual hard disk. Install Windows XP Professional as a guest OS.

With Windows XP up and running in VirtualBox, and without running any other applications in Windows, go to: My Computer -> Manage.

While "compuer management" windows is open, try this:

Select a text in any application in the Host OS (Ubuntu), and 'copy' it. Try to paste the text, either on Ubuntu or in Windows XP. You will notice that nothing is copied or your selection is corrupted with invalid characters at the beginning.

Then go back to Windows XP, and close the computer management window.

Then try again to copy the selected text and then paste it. It will paste the text correctly both in Ubuntu and in Windows XP.

If you open computer management again, the problem occurs. If you close the computer management windows, the problem disapperars.

I have noticed the same bahaviour with Remote Desktop Connection. If the Remote Desktop Connection program is running, either connected to a host or not, copying is broken in the Host OS. When Remote Desktop Connection is closed, copying to clipboard is working again.

Please note that copying to clipboard is broken ONLY in the Host OS (Ubuntu). Copying from the Guest OS (windows xp) is unaffected no matter is these programs are running or not.

Also please note that while Computer Management, or Remote Desktop Connection is running, copying and pasting files in the guest OS is also impossible. Paste is disabled in context menus.

Also please note that I have found that Computer Management and Remote Desktop Connection are causing these problems, but there may be more Windows program that will cause problem, too. Maybe these two are not the only ones.

I hope to see this fixed soon. Keep up the good work.

--Giannis Tsakiris

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VirtualBox causes problems copying to clipboard in Ubuntu Linux to VirtualBox causes problems copying to clipboard in Ubuntu Linux -> please retry with 1.5.2.

This looks like one of the issues that we fixed for version 1.5.2. Could you please retry when that version is released, and reopen the ticket if you still get this issue?

comment:2 in reply to: ↑ 1 Changed 7 years ago by qadir

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to michael:

This looks like one of the issues that we fixed for version 1.5.2. Could you please retry when that version is released, and reopen the ticket if you still get this issue?

I just upgraded to VirtualBox 1.5.2, but the bug is still there. When I have Windows 2000 or XP guests with MS Office 2003 running on a Linux host, copying something into clipboard form MS Office program breaks host's clipboard exactly the same way as it did in 1.5.0. Namely, all I get when I paste stuff copied in a host window is "ŸŸ". I am running Ubuntu 7.04, I upgraded VirtualBox from the repository today. (sorry for cross-posting with #611)

comment:3 follow-up: ↓ 4 Changed 7 years ago by michael

Same comment as for #611 - did you reinstall the guest additions after you upgraded to 1.5.2?

comment:4 in reply to: ↑ 3 Changed 7 years ago by qadir

Replying to michael:

Same comment as for #611 - did you reinstall the guest additions after you upgraded to 1.5.2?

Reinstalling guest additions fixed the problem, sorry, I didn't realize I had to do it. Thank you!

comment:5 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use