VirtualBox

Ticket #611 (closed defect: fixed)

Opened 7 years ago

Last modified 5 years ago

copy/paste corruption -> fixed in VirtualBox 1.5.2

Reported by: macareno Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: copy, paste, character
Cc: Guest type: Windows
Host type: other

Description

When i have open my Virtualbox, i can't copy/paste correctly in my system host (i use Ubuntu). It only paste weird characters.

Change History

comment:1 Changed 7 years ago by michael

Could you please provide a more detailed description of how to reproduce this? In our test (32bit Gnome and KDE Ubuntu 7.04 on an AMD64) everything worked fine. Mention in particular the precise sequence of actions which caused the corruption.

For example: opened OpenOffice writer in Ubuntu, opened VirtualBox, started a Windows XP guest, opened gedit in Ubuntu, typed into gedit, selected and copied the text and pasted into OpenOffice.

comment:2 Changed 7 years ago by michael

Also mention anything in your setup which you changed from the default and which might be relevant.

comment:3 Changed 7 years ago by michael

And please make sure that you are using the version of the guest additions supplied with VirtualBox 1.5. If you installed them in a previous version of VirtualBox, you will need to update them.

comment:4 Changed 7 years ago by mathusael

Similar thing here, using Kubuntu 7.04 I'm currently trying to reproduce, but it's a bit tricky. A very particular set of events trigger the bug.

I will come back if I can have something that I can reproduce.

comment:5 Changed 7 years ago by mathusael

Ok, I have something here. Open a an XP guest Launch Excel Copy a cell Past into anything (like Kate) ==> works

Now from now on Any copy/past from any application within the host (linux) will fail (strange characters like ŸŸ).

To make this go away, I simply close Excel.

Note that this only affect the linux clipboard not the text buffer. copy from the XP guest to the Linux host will always work.

comment:6 Changed 7 years ago by mathusael

My config. is the following : Kubuntu 7.04 VirtualBox 1.5 (new install, never had any virtualbox before) Toolbox installed from this version on the guest, XP SP2 and Office XP I'm using the VT enabled switch (I have an Intel Core2).

comment:7 Changed 7 years ago by mathusael

It seems that the effect happens whenever I have an office app open on my guest. and as soon as I can close them everything works normally.

comment:8 Changed 7 years ago by michael

mathusael: thanks. We have had several similar reports, and yours is the first one which we can reproduce.

comment:9 Changed 7 years ago by niwi

Not only office applications cause the problem. In my case also iTunesHelper.exe caused it. After stopping iTunes from starting in background with every system restart the problem went away. The problem still exists while iTunes itself is running. In some not reproducible cases the problem also stayed after I closed iTunes. Unfortunately I couldn't track down the process that was causing it.

comment:10 Changed 7 years ago by socokoolaid

Running VirtualBox 1.5.0 on a Slackware 12 KDE 3.5 host with Windows 2000 Professional Corp. in VM (with VB 1.5.0's guest additions installed): Clipboard works fine, unless I have Borland Build ver 6 open in the VM. Any time it's open most text use of the clipboard on the host OS gets trashed. Quanta, KEdit, KWrite, FireFox/Konqueror address bar, all fail to paste anything but the same garbage. Gimp seems to paste images fine though. Looking at Klipper's clipboard history, you can see that the clipboard changes (cut/copies updates) are made but one trashed entry is always on top. Even using Klipper to select a previous entry. The selected clipboard entry is always 2nd and 'ŸŸ' is always first to paste.

comment:11 Changed 7 years ago by nitro322

I'm experiencing the same issue. I'm running VirtualBox 1.5 on a Gentoo host w/ KDE 3.5.7 and a Windows XP guest install. While running Windows under VirtualBox, I'm unable to copy/paste on my host OS, although copy/pasting under the guest OS works fine. As reported above. I'm getting weird non-ASCII characters in Klipper: ŸŸŸŸ. Needless to say, this is pretty frustrating.

Also, I can confirm that this issue seems to only happen with certain applications, such as Office. If I start a fresh guest instance and open Notepad, I can copy back and forth between OSes without any problems. However, as soon as I start an Office app and copy text, I lose the ability to copy/paste under the host OS. Perhaps it has something to do with copying text from a rich text capable/aware application?

comment:12 Changed 7 years ago by michael

  • Summary changed from copy/paste corruption to copy/paste corruption -> fixed in VirtualBox 1.5.2

This is fixed in version 1.5.2, due out in a few days time.

comment:13 follow-up: ↓ 14 Changed 7 years ago by wenshu

I have the same issue. I am running Ubuntu 7.04, and my guest OS is WinXP. When I set bidirectional share clipboard in VirtualBox, I can copy text form my guest OS to host(WinXP->Ubuntu), but I can not do the reverse. That's say, I can not copy text from Ubuntu to WinXP。

comment:14 in reply to: ↑ 13 Changed 7 years ago by qadir

Replying to wenshu: This is fixed in version 1.5.2, due out in a few days time.

I just upgraded to VirtualBox 1.5.2, but the bug is still there. When I have Windows 2000 or XP guests with MS Office 2003 running on a Linux host, copying something into clipboard form MS Office program breaks host's clipboard exactly the same way as it did in 1.5.0. Namely, all I get when I paste stuff copied in a host window is "ŸŸ". I am running Ubuntu 7.04, I upgraded VirtualBox from the repository.

comment:15 Changed 7 years ago by michael

You will need to reinstall the guest additions from the 1.5.2 image.

comment:16 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:17 Changed 6 years ago by papst

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still the same bug here at Kubuntu Gutsy Gibbon with VirtualBox 1.5.4

comment:18 Changed 6 years ago by MankyGitt

Seems to be a problem with Ubuntu 7.10 host running VirtualBox 1.5.6 PUEL, however I have read that there may be other bugs in the gnome clipboard manager that may be the cause. The only forum threads that discuss pasting funny characters however lead me here to the VirtualBox discussions. Other clipboard problems in Gnome seem related to Firefox/Mozilla/xulrunner where the clipboard gets cleared entirely.

There are no particular sequences that produce the bug for me: It's there on start up. It seems that the base system configuration I have is enough:

Ubuntu 7.10 Lotus Notes 8 (in Eclipse) Sun Java 5 (and 6) Firefox 2.0.0.14 with Developer Toolbar addin, FireBug, FoxMarks, Yulup VirtualBox 1.5.6 PUEL

WinXP host (new install, not a migrated client) Ubuntu Hardy (new install)

Scenarios: having just experienced this bug, and shut down VirtualBox, I now cannot reproduce the bug with the following scenarios: However it occurs during these scenarios on a clean run. I'll revisit this post and update on the next clean session where the bug appears. It seems stopping and restarting VirtualBox has rectified the problem with the clipboard for now.

  1. With VirtualBox Management console running, but no clients active:

======================================================================= Copy and paste the URL of THIS PAGE into this wiki note: result =  http://www.virtualbox.org/ticket/611

  1. Start VirtualBox WinXP client and log in:

============================================ Copy and paste the URL of THIS PAGE into this wiki note: result =  http://www.virtualbox.org/ticket/611

  1. Change WinXP client to Seamless mode (Host -L)

=================================================== Copy and paste the URL of THIS PAGE into this wiki note: result =  http://www.virtualbox.org/ticket/611

comment:19 Changed 6 years ago by itismike

[RESOLVED] Running Ubuntu 8.04 and having the same characters when I try to paste in the host: "ŸŸ"

Steps to reproduce:

1.) Opened Outlook, authenticated to RPC, found the text I was looking for (a URL from a sent message), selected it w/the cursor, right-clicked and chose Copy.

2.) Switched back to Ubuntu, opened a new tab in FF3.0b5, used ctrl-V to paste, and the "ŸŸ" appeared.

Found this article, attempted to install Guest Modules in Synaptic, realized they are for the guest(!) Noticed vBox icon in guest's task bar reported Ver. 1.5.0 (pretty old.) clicked Devices in the vBox menu > Install Guest Additions and installed ver 1.5.6r28241. Rebooted when prompted and it is now working fine.

It'd be nice if the guest additions had an auto-update feature.

comment:20 Changed 6 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

This has been fixed for sometime now. Anyone considering re-opening this ticket please update the guest additions on your guests to the latest version and try again first.

comment:21 Changed 6 years ago by awilkins

  • Status changed from closed to reopened
  • Resolution fixed deleted

Apologies, but I'm seeing this again :-)

VirtualBox 2.02

Windows XP SP2 host. Windows XP SP3 guest, guest additions installed (and reinstalled to be sure).

Accessing via RDP from Win XP SP2 running latest hotfix of RDP client (version 6.0, ships with Vista but also available as a hotfix).

Copy/paste works OK if you open the VM in a local window. If you start the VM headless and connect an RDP session, all copies appear to be the 4 byte sequence

0x9f149f14

Have verified that this is not the case with the RDP client that you find on WinXP SP2 by default. Copy/paste appears to work (same host/guest combo, used my neighbours machine for it's RDP client).

Was unable to test with current rdesktop client shipped in Ubuntu 8.04 but I may try that when I have access to an Ubuntu machine.

I'll also try it on my Vista machine to see if this problem is peculiar to the hotfix version of the RDP client.

Suggested workaround : don't use MS RDP client 6. Not an option if your client machine is Vista.

comment:22 Changed 5 years ago by frank

Please check 2.0.4, there were some clipboard-related fixes.

comment:23 Changed 5 years ago by frank

  • Guest type changed from other to Windows

comment:24 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

I will close this bug. Please reopen if this problem still happens with 2.0.6.

comment:25 Changed 5 years ago by sam_vimes

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's still happening for me with 2.0.6. When i kill all of those apple processes(ituneshelper.exe etc.) in my XP guest the clipboard works fine.

comment:26 Changed 5 years ago by awilkins

From above, it seems to happen more when there are applications that intercept the clipboard (like Office, which has a clipboard stack and a systray application that displays it's content).

I do find it mildly disturbing that Apple-cations feel the need to snoop the clipboard.

Perhaps this is down to these applications breaking the clipboard viewer chain at some time after the VBox clipboard viewer addition is installed?

I'm sure the VBox team are aware of this...  http://blogs.msdn.com/ts/archive/2006/11/16/why-does-my-shared-clipboard-not-work-part-1.aspx Why does my shared clipboard not work?

comment:27 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem persists with the latest release 2.2.2. Please don't forget to update the guest additions to 2.2.2 as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use