VirtualBox

Ticket #610 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VB 1.5 - Seamless mode and Xinerama, KDE panels

Reported by: incunabulum Owned by:
Priority: major Component: GUI/multiview
Version: VirtualBox 1.5.0 Keywords: xinerama maximize
Cc: Guest type: other
Host type: other

Description

Seamless windows are great!

1) But on my Xinerama installation (Ubuntu 7.04 as host with 2 * 1600x1200 screens using a ATI X1300 graphics card with proprietary ATI drivers in xinerama mode, Windows XP professional as guest) moving "windows" application windows is restricted to the screen the virtual machine was shown before entering seamless operation mode. I. e. I can only move windows on this screen. Moving such a guest window to the other screen does not work

2) Maximizing a guest application window does not adhere to the panels of KDE 3.5.x. In my case I have a vertical panel on the right side. Maximizing the window takes the complete screen; the panel is no longer visible. Linux applications still show the panel after maximization, i. e. the application uses the complete screen except of the panel if maximized.

Otherwise, great work, love it!

Change History

comment:1 in reply to: ↑ description Changed 7 years ago by incunabulum

Sorry, did't check the mailing list: The first issue 1) is a duplicate of bug 604. The second remains valid.

comment:2 Changed 7 years ago by jarfil

I think #604 is about some weird positioning error, while issue 1) is about correct positioning but restricted to only one Xinerama screen. This would be also my case (Ubuntu 7.04 host with 2 * 1024x768 using nVidia GeForce FX 5200 with proprietary nVidia drivers in Xinerama mode, Windows XP Professional as guest).

However, solving this issue may prove tricky:

  • if just the full Xinerama size is passed down to the guest OS, then XP's system bar would extend for the full width of all screens involved. I'd rather have XP's system bar on one screen while keeping KDE's on the other
  • detecting correctly both Xinerama screens and letting the guest OS know about which is primary, would lead to overlapping host's task bar with the guest's one

Also, this should be configurable so you could to tell VirtualBox to either:

  1. use only one screen
  2. use full Xinerama as one screen
  3. pass down multiple screens to the guest
  4. select which screen is primary independently from host setup (so that one screen would remain primary for the host, while a different screen would become primary for the guest)

Optimally, the latest should be configurable per virtual machine.

comment:3 Changed 7 years ago by emisca

I can confirm this behaviour....

How about implementing seamless windows, as windows managed by the host window manager? (something like what vmware fusion does on osx.. in contrast to parallels that has an implementation very similar to the vbox one..)

Regardless of these defects, seamless windows are great!

comment:4 Changed 7 years ago by Dsen

To incunabulum:

Concerning issue 2: As I understand this issue appears when the guest is in Seamless Mode. The question: is this issue appears then you are using xinerama only or without xinerama also? It.Et. is this KDE panel on the right side overlaps by the maximized seamless window then you are using one monitor (without xinerama)?

comment:5 Changed 7 years ago by incunabulum

@dsen, panel overlaps occur in xinerama mode, correct. I have not tested this without xinerama.

I will try to perform a single-monitor test tomorrow as long as I am sure that I do not break my X configuration. Took me long enough to actually get it working this way :-)

comment:6 Changed 7 years ago by incunabulum

@dsen, in single-monitor-mode running virtualbox in seamless mode guest windows do observe the panel sizes. Maximizing guest windows keeps of the panels.

Xinerama relate bug imho

comment:7 Changed 7 years ago by Dsen

To incunabulum:

Yes, certainly a xinerama+qt problem.

  1. Concerning 1st issue: is in this dual-monitor mode all the other application (VirtualBox, for example, in normal, non seamless|fullscreen mode) could be moved from the one monitor to another, and could be partially located on both monitors (for example in maximized mode)?
  1. Is this issue also related too VirtualBox_fullscreen_mode?

Thank you in advance.

comment:8 Changed 7 years ago by incunabulum

@dsen,

in xinerama (ATI slang: bigdektop) mode all other windows can be moved between screen or are shown partially on both screens. My guest machine in non-seamless mode can also be moved between screens. Maximize only maximizes to a single screen (which is good, may be a configuration option of KDM, the window manager)

Only in seamless mode guest windows are bound to the window the virtual box was started. The windows taskbar is only shown on this monitor (which is good, btw :-)

About 2) Fullscreen mode works. Otherwise, I am not sure what you are upt to.... Could you clarify?

ps: This bugtracker needs some email notification!

comment:9 Changed 7 years ago by incunabulum

Screenshot of seamless mode see here:

 http://www.incunabulum.de/restricted/vbox-screen-small.jpg/image_view_fullscreen

You can see the clock in the windows taskbar is hidden behind the right vertical panel.

comment:10 follow-up: ↓ 11 Changed 7 years ago by frank

Please update your E-mail in your settings. Unfortunately our trac lost some E-mail addresses a week ago.

comment:11 in reply to: ↑ 10 Changed 7 years ago by incunabulum

Replying to frank:

Please update your E-mail in your settings. Unfortunately our trac lost some E-mail addresses a week ago.

Sorry, under MyAccount I can only change my password. No email settings there. (OT, I know)

comment:12 follow-up: ↓ 13 Changed 7 years ago by Dsen

To incunabulum:

As I see, KDE taskbar is only displayed on the first monitor. Could it be configurable and displayable on both monitor? Why am I asking this, the situation is:

The Seamless Mode is like a maximization but with transparent background so it will take all the available monitor geometry (the same as would been taken in case of simple window maximization) which is got from the KDE window system. Due to the both monitor has different available geometry (first geometry less than second due to first geometry should respect the KDE taskbar and the second should not) KDE notifies the VirtualBox about geometry of the monitor where VBox was started.

It.Et. if KDE could be configurable to maximize any window not only at one monitor but on both then the seamless will use both monitors too (but in this case, as I understand, both taskbars will take both monitors, guest's at the top of host's). Could you please check if it so and post a picture if it is so?

Thank you in advance.

comment:13 in reply to: ↑ 12 Changed 7 years ago by incunabulum

Replying to Dsen:

As I see, KDE taskbar is only displayed on the first monitor. Could it be configurable and displayable on both monitor? Why am I asking this, the situation is:

Unfortunately, displaying the Taskbar over both screens is not possible. I can create an additional panel on the right screen, yet this panel is not recognized by VirtualBox either.

The Seamless Mode is like a maximization but with transparent background so it will take all the available monitor geometry (the same as would been taken in case of simple window maximization) which is got from the KDE window system. Due to the both monitor has different available geometry (first geometry less than second due to first geometry should respect the KDE taskbar and the second should not) KDE notifies the VirtualBox about geometry of the monitor where VBox was started.

Ok, I understand. I. e. starting VirtualBox (Control Center and Machine Window) on the left screen with the taskbar should get me a situation with the KDE taksbar on the bottom and the Windows taskbar located above.

Sorry, at least on my machine this is not the case. The Windows taskbar is located "above" the kde taskbar, i. e. the kde taskbar is not visible.

It.Et. if KDE could be configurable to maximize any window not only at one monitor but on both then the seamless will use both monitors too (but in this case, as I understand, both taskbars will take both monitors, guest's at the top of host's). Could you please check if it so and post a picture if it is so?

Sorry, I do not know how to configure the "maximize settings" for the KDM in xinerama mode. In my case this is something I do not need.

Thanks for looking into it...

comment:14 Changed 7 years ago by naju

As I see, KDE taskbar is only displayed on the first monitor. Could it be configurable and displayable on both monitor? Why am I asking this, the situation is:

Unfortunately, displaying the Taskbar over both screens is not possible. I can create an additional panel on the right screen, yet this panel is not recognized by VirtualBox either.

Hi, just to clarify, KDE can in fact extend a panel to both monitors, if you go into configure panel -> Arrangement, you should have the choice of Xinerama screen on the right side, and alternatively you can choose "All screens".

Can't say for sure but IMO it's probably possible to obtain the gometry of the whole xinerama virtual screen from kde like kicker (the panel) does.

comment:15 Changed 6 years ago by incunabulum

@naju, enabling the "All Screens" option for the panel - didn't know about this option, thanks - gives me a panel at the lower edge spanning both screens.

Using VB in seamless mode gives me the windows panel (taskbar) display on top (overlapping) the kde panel.

comment:16 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:17 Changed 6 years ago by frank

  • Component changed from GUI to GUI/multiview

comment:18 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Obsolete. VBox 3.2 adds better support for multiple monitors. Seamless will still be improved though.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use