VirtualBox

Ticket #7446 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Memory Leak 3.2.8 r64453 RHEL5 Host/XP Guest

Reported by: speedpacer Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I've been able to reproduce what appears to be a memory leak in 3.2.8 with a 64-Bit Red Hat 5 Enterprise Server (Gnome) as a host and a Windows XP SP3 guest, although I experienced it with a 32-Bit Windows 7 guest as well but I didn't document it and I've kept it offline since more than one guest has made the host unusable.

Nothing special set up, the host has 8GB of memory and I've allocated 1GB to the guest, one bridged adapater, 20GB HDD, everything else is default. Both systems are fully patched/updated and no other applications are running.

Here are my findings:

VirtualBox Guest Not Running


5% in use by programs 5% in use by cache

Overnight 5% in use by programs 5% in use by cache

VirtualBox Running 1 Windows XP Guest


16% in use by programs 16% in use by cache

After 15 Minutes 16% in use by programs 27% in use by cache

After 2 Hours 16% in use by programs 33% in use by cache

Overnight 22% in use by programs 77% in use by cache

Basically, the system gets bogged down and so slow in responding, that I have to reboot both the guest and the host every morning to clear it out. If there's an easier way to do that in the meantime, please let me know!

Thanks, Don Earnest

Attachments

VBox.log Download (38.4 KB) - added by speedpacer 4 years ago.
VBox.log
VBox.log.1 Download (65.4 KB) - added by speedpacer 4 years ago.
VBox.log.1
VBox.log.2 Download (70.5 KB) - added by speedpacer 4 years ago.
VBox.log.2
VBox.log.3 Download (189.1 KB) - added by speedpacer 4 years ago.
Vbox.log.3

Change History

comment:1 Changed 4 years ago by frank

A VBox.log file of such a VM session is missing.

Changed 4 years ago by speedpacer

VBox.log

Changed 4 years ago by speedpacer

VBox.log.1

Changed 4 years ago by speedpacer

VBox.log.2

Changed 4 years ago by speedpacer

Vbox.log.3

comment:2 Changed 4 years ago by speedpacer

This appears to be happening only when the guest is a member of a domain... Other than normal Netlogon, Computer Browser, and other domain related services, the only other things that are running are the Windows Update client (which is reporting to a local WSUS server), McAfee agent and CA IT Client Manager agent (software delivery, remote control, asset management), although there have been no updates, scans or software pushes during the course of the above testing. I'm going to disable each of those services one by one and monitor them overnight so I can figure out if one of those may be causing the problem. It still seems odd that any of these guest services would be using the memory cache of the host at all, let alone not releasing it back...

comment:3 Changed 4 years ago by speedpacer

After further testing, it seems as if the memory cache consumption gets progressively worse with each network service, even though they're not actually doing anything but periodically checking with their respective servers for new updates. After re-enabling Automatic Updates, I noticed a minor increase in the host cache but after re-enabling CA IT Client Manager, it became more significant and after re-installing the McAfee agent, even worse.

I'm responsible for WSUS and CA ITCM on our corporate network (FedEx) and I can verify that nothing has been pushed from WSUS or the CA IT Client Manager servers during this time but the clients are scheduled to look for new updates and/or software packages once a day. The McAfee servers are handled by a different department so I'm not sure about that.

comment:4 Changed 4 years ago by speedpacer

I should also add that we test several clients (all Windows OS's) with Windows Updates (WSUS) and CA ITCM in our lab on VMWare ESXi 4.0 servers with the same client configurations and we're not experiencing this issue, and I'm running several Windows clients on my home network, all domain members, all configured for automatic updates from a local WSUS server and all running CA ITCM agents (ClamAV instead of McAfee) as headless VirtualBox guests on Ubuntu servers and I'm not experiencing this either, so it seems to be VirtualBox/RHEL5 (with Gnome) related...

comment:5 Changed 4 years ago by faulebutter

I experience the same problem with VB 3.2.8 PUEL on F13 host with heavy network load (VMDK on an NFS share and VRDP session with video running). The VM gets killed by kernel due to memory overallocation. (I've also posted this on forums:  http://forums.virtualbox.org/viewtopic.php?f=7&t=34702&p=155557#p155557).

comment:6 follow-up: ↓ 8 Changed 3 years ago by frank

Still relevant with VBox 3.2.12?

comment:7 Changed 3 years ago by speedpacer

Just updated it, I'll watch it for a few days and let you know...

comment:8 in reply to: ↑ 6 Changed 3 years ago by speedpacer

Replying to frank:

Still relevant with VBox 3.2.12?

Yes, there doesn't appear to be any difference. I let it run over the weekend, nothing else running on the host, and it's at 22% in use by programs, 83% in use as cache...

comment:9 Changed 3 years ago by speedpacer

This appears to have been a hardware issue

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use