VirtualBox

Ticket #7363 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Virtual disk corruption

Reported by: fassito Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.2.8 Keywords: AIOMgr, pdmacFileAioMgrNormal
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I am installing Oracle Apps version 11.5.10.2 on Oracle Enterprise Linux 5 update 2 running in a virtual box vm. The host is a windows7 laptop with 8GB of RAM 2*500GB disk. The installatition takes several hours and starts out fine. After a number of hours (usually 2-3) I get an error in the vbox.log saying that something is wrong with the AIOMGR:

02:58:39.322 AIOMgr: I/O manager 0x000000030c6ca0 encountered a critical error (rc=VERR_UNRESOLVED_ERROR) during operation. Falling back to failsafe mode. Expect reduced performance

02:58:39.322 AIOMgr: Error happened in D:\tinderbox\win-3.2\src\VBox\VMM\PDMAsyncCompletionFileNormal.cpp:(1654){pdmacFileAioMgrNormal}

02:58:39.322 AIOMgr: Please contact the product vendor.

THe full log is attached.

When this error appears in the log the VM gets very slow until it freezes and cannot be used anymore (graphical ui inaccessible, shutdown does not work...). THe only thing left to do is to kill it. After the restart the filesystem is corrupt and I have to start from scratch.

I have spent the last week trying to get around this by testing different configurations of the VM: SATA vs IDE, cache vs no cache, fixed size vs growing disks, single file system vs multiple filesystems, upgrade from 326 to 328. But all of them always end with the same error.

I checked existing tickets and the forums and could not find anything similar.
Could you please help me with this.

Thanks,

Torsten

Attachments

APPSR11-2010-08-20-08-17-48.log Download (48.5 KB) - added by fassito 4 years ago.
APPSR11-2010-08-20-08-17-48.2.log Download (48.5 KB) - added by fassito 4 years ago.
APPSR11-2010-08-21-21-46-45.log Download (52.4 KB) - added by fassito 4 years ago.
APPSR11-2010-08-22-13-28-23.log Download (51.6 KB) - added by fassito 4 years ago.

Change History

Changed 4 years ago by fassito

Changed 4 years ago by fassito

Changed 4 years ago by fassito

Changed 4 years ago by fassito

comment:1 in reply to: ↑ description Changed 4 years ago by fassito

I tried the same under VMWare player and there is worked without any problem

Torsten

comment:2 follow-up: ↓ 3 Changed 4 years ago by aeichner

Thanks for the report. The error code (VERR_UNRESOLVED_ERROR) means that the error code returned by Windows couldn't be converted to an internal one, so this doesn't give a hint why it fails unfortunately. I could provide a special build which has more logging enabled if you want. You can also try to enable the host I/O cache in the controller settings as a workaround until the problem is fixed.

comment:3 in reply to: ↑ 2 Changed 4 years ago by fassito

As I said in my description I had tried it with the host I/O cache enabled but the result did not change, I still got the corruption. Ok for the special build if it does not mean that I have to deinstall my current installation. Can I install it in parallel?

Replying to aeichner:

Thanks for the report. The error code (VERR_UNRESOLVED_ERROR) means that the error code returned by Windows couldn't be converted to an internal one, so this doesn't give a hint why it fails unfortunately. I could provide a special build which has more logging enabled if you want. You can also try to enable the host I/O cache in the controller settings as a workaround until the problem is fixed.

comment:4 Changed 4 years ago by mdione

I experience similar problems using VirtualBox under Debian Sid (3.2.8-dfsg-1), Arch (3.2.8) and Gentoo (3.2.8). I'm willing to test the special build.

comment:5 Changed 4 years ago by cemo

Exactly same problem during installation of guest. VBox version: 3.2.8 r64453 Host: Windows 7 Ultimate Guest: Windows Server 2008

comment:6 Changed 4 years ago by rasker

I also had the same problem upgrading to 3.2.8 on Windows 7 64bit. To add some more information this problem only affects the sata controller with the host i/o caching turned off. The IDE controller works ok with or without host caching. Might be an idea to set the host caching to be on by default for the sata controller in the next release or until this issue is resolved.

I only have a couple of virtual machines so I uninstalled virtualbox, removed any configuration files + network adapters, reinstalled from scratch and re-setup the virtual machines just to exclude any previous version conflicts.

thanks

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use