VirtualBox

Ticket #7364 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Windows 98 SE crashes very frequently (triple fault)

Reported by: raffaellod Owned by:
Priority: critical Component: VMM/RAW
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Some recent change in VirtualBox has made Windows 98 SE completely unusable: it will crash within a few minutes of interaction (idling seems not to be an issue).

To be on the safe side, I tried starting a new virtual disk and reinstalling from scratch, but nothing changed; it’s still extremely unstable.

It seems not to be related to:

  • HW virt: my processor doesn’t support that;
  • mouse: crashes even if I never use the mouse, from guest boot to the crash;
  • graphics: crashes with VBE driver as well as default VGA driver;
  • network cards: one (NAT) or two (NAT + vboxnet), no apparent difference;
  • network activity: crashes happen in situations where network is certainly not used;
  • disk activity: I managed to complete a full defrag (about 10 minutes) with no crash - of course it crashed soon afterwards as I started doing other things;
  • IDE DMA: I didn’t even need to test this, as it was off by default in the new guest installation, and I got two guru meditations before I could enable the DMA :)

It may be related to:

  • (guest) task switching: it’s really the only think in common to the various crashes I can think of.

It is certainly related to recent VirtualBox versions (probably 3.2). I don’t remember this being an issue at all back in VirtualBox 3.1 times (of course, the occasional guru meditation always used to be possible, it’s still Windows 98), though I haven’t used the Win98 guest in a while, so I’m not sure which 3.2.x release introduced the regression (or improved standards compliance, which screwed poor Win98 :)

I attach an handful of guru meditation logs, all due to triple fault; some are from the guest that used to work okay (Win98SE, fully Windows Update’d, VBE video driver), some are from the cleanly installed new guest (Win98SE, no updates, no added drivers).

Please let me know if there’s any further details I can provide. I understand you don’t officially support Windows 98, but I’d like to keep on using only VirtualBox for all my virtualization needs.

Attachments

VBox.log.1 Download (141.4 KB) - added by raffaellod 4 years ago.
VBox.png.1 Download (6.0 KB) - added by raffaellod 4 years ago.
VBox.log.2 Download (270.9 KB) - added by raffaellod 4 years ago.
VBox.png.2 Download (14.6 KB) - added by raffaellod 4 years ago.
VBox.log.3 Download (248.4 KB) - added by raffaellod 4 years ago.
VBox.png.3 Download (9.6 KB) - added by raffaellod 4 years ago.
VBox.log.4 Download (274.5 KB) - added by raffaellod 4 years ago.
VBox.png.4 Download (12.1 KB) - added by raffaellod 4 years ago.
VBox.log.5 Download (258.3 KB) - added by raffaellod 4 years ago.
VBox.png.5 Download (16.7 KB) - added by raffaellod 4 years ago.
VBox.log.6 Download (263.1 KB) - added by raffaellod 4 years ago.
VBox.png.6 Download (20.4 KB) - added by raffaellod 4 years ago.
VBox.log.7 Download (156.8 KB) - added by raffaellod 4 years ago.
VBox.png.7 Download (16.9 KB) - added by raffaellod 4 years ago.
VBox.log.8 Download (248.5 KB) - added by raffaellod 4 years ago.
VBox.png.8 Download (16.6 KB) - added by raffaellod 4 years ago.
2010-08-31-13-25-58.047-VirtualBox-2119.log Download (295 bytes) - added by henk506 4 years ago.
Vbox3.log
Vbox3.log Download (248.6 KB) - added by henk506 4 years ago.
The actual vbox log. (accadently posted the wrong one the first time.)
VBox_fault-caused-by-keyboard.log Download (293.7 KB) - added by jvd897 4 years ago.
VBox_fault-caused-by-mouse.log Download (269.0 KB) - added by jvd897 4 years ago.
VBox_incomplete-reboot.log Download (56.5 KB) - added by jvd897 4 years ago.
VBox_incomplete-shutdown.log Download (56.3 KB) - added by jvd897 4 years ago.

Change History

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

Changed 4 years ago by raffaellod

comment:1 Changed 4 years ago by raffaellod

A few further notes:

I use (fixed size) VMDK disks so that I can mount on the host (with the guest turned off, of course) the partitions contained within the disk image itself, using a shell script I wrote; I haven’t used VMware in the last... 8 years? :)

In case you’re wondering, the screenshot for log 2 is from me dragging the Device Manager window around, like crazy, just to trigger a guru meditation. And it worked...

Also, this discussion on the forum seems to be related, and it’s also very recent, although the users reporting the issue seems to be new as well:

 http://forum.virtualbox.org/viewtopic.php?f=7&p=151489

comment:2 Changed 4 years ago by raffaellod

In the receipt e-mail I received, I read in the last line, in the signature: “VirtualBox Open Source Edition”. It’s not, I’m using the PUEL Edition (though none of its features, in this case).

comment:3 Changed 4 years ago by raffaellod

After further investigation, I think I’m getting closer to the source of these triple faults.

Crashes only always happen when using either input device (keyboard, mouse, USB tablet); since the keyboard triggers the error much less frequently (albeit still way too frequently and randomly), I came to suspect the problem is interrupt-related. This would explain why mouse and tablet crash much more easily: what I can do in a few keystrokes (a few interrupts), I can do moving the mouse and clicking (tens or hundreds of interrupts).

Actually, I’m not sure if mouse devices are interrupting or polled. In the latter case, this explanation is totally wrong, of course.

Though the facts are still there: a Win98 guest, busy (registry search, disk defrag, browsing a self-reloading web page) but without input, does not cause a guru meditation, while using a keyboard can easily do that, and using a mouse will certainly trigger one very quickly.

Changed 4 years ago by henk506

Vbox3.log

Changed 4 years ago by henk506

The actual vbox log. (accadently posted the wrong one the first time.)

comment:4 in reply to: ↑ description Changed 4 years ago by radar57

Replying to raffaellod:

Some recent change in VirtualBox has made Windows 98 SE completely unusable: it will crash within a few minutes of interaction (idling seems not to be an issue).

Hello I can confirm this, having exactly the same problem, but in Windows95 Machines. I have Version 3.2.8 r64453 of Virtualbox. Host is Ubuntu 10.04 (lucid) Kernel Linux 2.6.32-24. On two Windows95 installs i get the same guru meditation crashes (fatal error in recompiler cpu: triple fault). As with raffaellod it happens after some seconds or a minute, a bit later when i use the keyboard, and rather soon when i use the mouse. This type of crash has not happened in my earlier versions.

comment:5 in reply to: ↑ description Changed 4 years ago by jvd897

Same problem for me as well. Host is Windows 7 x64 and guest is Windows 95. As with the other users, this problem occurs most frequently when I use the mouse, but sometimes it happens with the keyboard too. And sometimes the guest hangs indefinitely when it's shutting down, forcing me to kill power to the VM, though this might be a separate problem.

Will post logs soon.

Changed 4 years ago by jvd897

Changed 4 years ago by jvd897

Changed 4 years ago by jvd897

Changed 4 years ago by jvd897

comment:6 Changed 4 years ago by propellerhead.001

Hi, i've worked out a way in which i've managed to get 98 to run, it's a bit heath robinson and not as efficient as i'd like, although i've a different host, win7. basically i've set up a virtual machine running XP Pro, and installed Virtual Box 1.6 onto that and then created a win98 machine, not pretty i'll admit, but if you were to store the Disk Image used for the 98 machine in a folder shared between the XP machine and the original host then you should still be able to access from the original host.

as i said, not pretty, and not efficient but it does work :)

comment:7 Changed 4 years ago by sandervl73

  • Priority changed from blocker to critical

comment:8 Changed 4 years ago by jvd897

I'm very pleased to share that I upgraded to VirtualBox 3.2.10 (r66523) today, and I no longer have problems with my Windows 95 VM. This ticket wasn't listed in the Changelog ( http://www.virtualbox.org/wiki/Changelog), but I suspect that whatever fixed it has something to do with the first item listed there: "V8086 mode fix for legacy DOS/Windows guests with EMM386 (3.2.8 regression)".

Anyways, I've spent at least fifteen minutes in my Windows 95 VM today, moved the mouse violently and done some typing, and I have had absolutely no crashes -- so it seems like something has been fixed!

comment:9 follow-up: ↓ 10 Changed 4 years ago by sandervl73

Can the original reporter confirm this?

comment:10 in reply to: ↑ 9 Changed 4 years ago by raffaellod

Replying to sandervl73:

Can the original reporter confirm this?

Confirmed. As of 3.2.10, the triple fault doesn’t seem to occur any more.

Thanks for the fix!

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use