VirtualBox

Ticket #7313 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

4-CPU debian 5.0 guest gives: "BUG: soft lockup - CPU#[n] stuck for 61s - [procname:procid]"

Reported by: nickj Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host is 64 bit Ubuntu 10.04, running VirtualBox 3.2.8. Guest is Debian 5.0, 64 bit.

Guest was set up with 1 CPU, but since my host has a Quad Intel processor, I decided to try increasing it to 4 CPUs on the guest. Running with 4 CPUs gave errors like "BUG: soft lockup - CPU#[n] stuck for 61s - [procname:procid]" on the guest's console (will attach screenshot of this shortly), which doesn't sound like it can be a good thing. I then ran unixbench on the guest, and whilst this was running, the guest hung, and had to be forcibly shutdown.

I then brought the number of CPUs down from 4 to 2, and re-ran unixbench. The "BUG: soft lockup" messages were gone, and the VirtualBox did not hang.

So, there seems to be a problem with 4 CPUs, at least for me, that causes "BUG: soft lockup - CPU#[n] stuck for 61s - [procname:procid]" errors, and that _possibly_ also causes freezing under some situations.

Attachments

Screenshot-Bling (Debian 5.0) [Running] - Oracle VM VirtualBox.png Download (29.7 KB) - added by nickj 4 years ago.
screenshot of soft lockup messages
VBox.log.1 Download (66.8 KB) - added by nickj 4 years ago.
virtualbox log
Screenshot-Bling (Debian 5.0) [Running - with two CPUs] - Oracle VM VirtualBox.png Download (19.8 KB) - added by nickj 4 years ago.
screenshot of soft lockup messages, with 2 CPUs.
VBox.log Download (66.6 KB) - added by nickj 4 years ago.
virtualbox log, with 2 CPUs.
Screenshot 3-CPU Ludo-vm (64-bit Debian 5.0) [Running] - Oracle VM VirtualBox v3.2.8.png Download (21.6 KB) - added by nickj 4 years ago.
Screenshot of 3-CPU 64-bit Debian 5.0 Running in VirtualBox v3.2.8

Change History

Changed 4 years ago by nickj

screenshot of soft lockup messages

Changed 4 years ago by nickj

virtualbox log

comment:1 follow-up: ↓ 2 Changed 4 years ago by sandervl73

Well, it's hard to say what's the problem. One thing must be said though: you are asking for problems if you assign 4 CPUs to a guest when you only have 4 on your host.

comment:2 in reply to: ↑ 1 Changed 4 years ago by nickj

Replying to sandervl73:

One thing must be said though: you are asking for problems if you assign 4 CPUs to a guest when you only have 4 on your host.

That's not at all obvious from the current UI. The GUI currently gives a warning if you try and exceed the number of real CPUs, but it gives no warning if you try and use the number of CPUs that you actually have.

Perhaps it would be best to give the warning if ( number of assigned CPUs > 1 && number of assigned CPUs >= physical CPUs ). Currently it only seems to warn on ( number of assigned CPUs > physical CPUs ).

Changed 4 years ago by nickj

screenshot of soft lockup messages, with 2 CPUs.

Changed 4 years ago by nickj

virtualbox log, with 2 CPUs.

comment:3 Changed 4 years ago by nickj

Same error just encountered with 2 CPUs in the guest, in a 4-CPU host machine. This happened after rebooting the guest, during bootup. Screenshot & log are attached above.

comment:4 follow-up: ↓ 5 Changed 4 years ago by bulletxt

Are you by chance running a Java Virtual machine process?

Changed 4 years ago by nickj

Screenshot of 3-CPU 64-bit Debian 5.0 Running in VirtualBox v3.2.8

comment:5 in reply to: ↑ 4 Changed 4 years ago by nickj

Replying to bulletxt:

Are you by chance running a Java Virtual machine process?

I do have a JVM process that runs in the guest sometimes, but it is strictly on-demand (it gets invoked by a web app when needed in response to a user action), and I don't _think_ it would have been happening at the time of these errors (although I can't be 100% certain for 4-CPU log). Certainly it does not run on bootup, so the 2 CPU error on bootup would not be caused by this. Additionally, I have just powered off the guest, set it to 3 CPUs, powered it back on, running virtualbox 3.2.8, and got the same soft lockup error (screenshot attached above) whilst booting up. So it can definitely happen without a JVM running on the guest. To date it happens with the guest set to have 2 CPUs, 3 CPUs and 4 CPUs. The only configuration where I have not seen it happen so far is 1 CPU.

comment:6 Changed 4 years ago by bulletxt

What kind of ubuntu kernel are you running? If you are on kernel generic, try the server one or vice versa and let's see what happens..

comment:7 Changed 4 years ago by nickj

That helped!

The host was using kernel generic, and changed to server:

$ uname -a
Linux redux 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010 x86_64 GNU/Linux
$ sudo aptitude install linux-image-server linux-headers-2.6.32-25-server
$ reboot
$ uname -a
Linux redux 2.6.32-25-server #44-Ubuntu SMP Fri Sep 17 21:13:39 UTC 2010 x86_64 GNU/Linux
$ sudo /etc/init.d/vboxdrv setup

The guest virtual machine then ran okay with 2, 3 and 4 CPUs, without any soft-lockups. I have not seen any soft lockups so far with the host running the server kernel.

So, what does this mean? I'm presuming it implies that either VirtualBox needs to be updated to run okay on the generic kernel, or that the generic kernel needs to be updated to run VirtualBox.

comment:8 Changed 4 years ago by sandervl73

Hard to say. Looks like some host scheduling weirdness or a timing related problem.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use