VirtualBox

Ticket #7309 (closed defect: worksforme)

Opened 4 years ago

Last modified 7 months ago

BSOD on Windows7 host after installing virtualbox

Reported by: hlslaughter Owned by:
Priority: blocker Component: host support
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

After installing 3.2.8 yesterday and rebooting, I got a BSOD.

I restored my computer to a previous point and was able to boot again. I had installed several applications so I wasn't sure which the culprit was. However, after installing virtualbox a *second* time, I was able to reproduce the BSOD. Again, reverting / uninstalling virtualbox, my machine boots again.

System details attached as image.

I am happy to provide logs.... etc... but I'm not all that familiar with debugging windows crap.

I absolutely love virtualbox and really need it for work. :)

Attachments

2010-08-11_1613.png Download (25.8 KB) - added by hlslaughter 4 years ago.
details of host os

Change History

Changed 4 years ago by hlslaughter

details of host os

comment:1 Changed 4 years ago by hlslaughter

Also, the BSOD presented me with the error: driver_irql_not_less_or_equal

comment:2 Changed 4 years ago by misha

Please attach a  minidump for the crash here

comment:3 Changed 4 years ago by hlslaughter

i've found the file MEMORY.DMP in C:\Windows that seems to correspond to the crash, however, Winblows won't let me copy or change permissions on it (guess i need the $1000 Windows version to do basics like that).

I guess to get a 'minidump' i'd have to install virtualbox again and crash my machine :) I'd rather not do that. I'd be happy to provide the MEMORY.DMP file, however, if I could figure out how to get read access to it...

comment:4 Changed 4 years ago by ddn

change UAC settings to low... or start command line as ADMINISTRATOR mode now use takeown.exe internal utility

ex: takeown.exe C:\windows\memory.dmp

:)

comment:5 Changed 4 years ago by hlslaughter

I don't know how to change file permissions or UAC on windows other than to try to edit via file properties, which doesn't work.

Hah, I opened up a cygwin shell as Admin and did a chmod 777 on the file, which then gave it permissions of 666 :) Nothing on windows works, what a POS. But I can probably attach MEMORY.DMP now. I hope it helps. Virtualbox is one of the apps that makes windows useable for me.

comment:6 Changed 4 years ago by misha

First of all, is your system configured to create a minidump or a full/kernel memory dump on crash?
In the former case (which is the default), the minidump files should be located under %SystemRoot%\Minidump\ To figure out that go to start menu -> right-click "Computer" -> Properties -> "Advanced system settings" -> in "Advanced" tab click "Settings" in "Startup and Recovery" group -> observe settings under "Write debugging information"

comment:7 Changed 4 years ago by hlslaughter

i have it set for minidump now, but at the time of the last 2 crashes, it wasn't. all i have is this one large dump.

tried to upload it. but didn't realize how large it was and it failed to upload.

here it is:

 http://devbee.com/pub/MEMORY.zip

comment:8 Changed 4 years ago by ddn

windows may not generate minidump if some of those are occured:

  1. page file size is larger than 4gb
  2. BSOD is related to disk I/O subsystem drivers (to prevent data loss minidumps will not be generated)
  3. if you have larger than 2gb of RAM, full memory dump is not available through GUI.
  4. no minidump subdirectory found under <%sysdrive%>\WINDOWS directory

comment:9 Changed 4 years ago by hlslaughter

i don't really have time to provide additional info on this.

i just thought it was relevant that virtualbox causes a BSOD on startup on a pretty common system.

last thoughts... just that the only thing "unusual" about my system is that it's running windows7 64bit. i was able to reproduce the problem by reinstalling virtualbox after a system restore, so i do think it's a legit bug.

comment:10 in reply to: ↑ description Changed 3 years ago by chromax

Same here with XP SP3.

During Installation the BSOD appears with "IRQ driver less or equal". Tried two times on a dell adamo with CULV processor. Maybe thats the problem.

comment:11 Changed 3 years ago by Technologov

This usually happens if you have some incompatible drivers installed on your Windows host. We need to find what is it.

See Wish #6057

My recommendation: Boot into Safe Mode, Uninstall VBox, re-install VBox without USB and without networking components.

Does it works?

-Technologov

comment:12 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use