VirtualBox

Ticket #7193 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Keys missing on the keyboard -> duplicate of #2595

Reported by: quantenbein Owned by:
Priority: major Component: installer
Version: VirtualBox 3.2.6 Keywords: keyboard
Cc: Guest type: Windows
Host type: Linux

Description (last modified by michael) (diff)

Hi everybody,

I tried to install a Windows guest system on my Suse Linux 11.2 host for several times. Everything works fine except that several keys of my keyboard are not recognized in the VM. All the numbers, for example, but also some other keys. Some are switched, too: „q” becomes „-“, for example. I first thought I had made a mistake somewhere, until I read this:

00:00:00.720 VirtualBox 3.2.6 r63112 linux.x86 (Jun 25 2010 17:37:12) release log
00:00:00.720 Log opened 2010-07-18T12:54:11.836150000Z
00:00:00.720 OS Product: Linux
00:00:00.720 OS Release: 2.6.31.12-0.2-default
00:00:00.720 OS Version: #1 SMP 2010-03-16 21:25:39 +0100
00:00:00.720 DMI Product Name: Satellite M50
00:00:00.720 DMI Product Version: PSM51E-01H010GR
00:00:00.721 Host RAM: 1005MB RAM, available: 571MB
00:00:00.721 Executable: /usr/lib/virtualbox/VirtualBox
00:00:00.721 Process ID: 12121
00:00:00.721 Package type: LINUX_32BITS_OPENSUSE_11_1
00:00:00.932 SUP: Loaded VMMR0.r0 (/usr/lib/virtualbox/VMMR0.r0) at 0xfbf51020 -
ModuleInit at 00000000fbf65a90 and ModuleTerm at 00000000fbf65a60
00:00:00.932 SUP: VMMR0EntryEx located at 00000000fbf65930, VMMR0EntryFast
at 00000000fbf64940 and VMMR0EntryInt at 00000000fbf64790
00:00:00.954 File system of '/home/Quantenbein/.VirtualBox/HardDisks/Test.vdi' is ext4
00:00:00.988 VBoxSharedClipboard mode: Bidirectional
'''00:00:01.017 Failed to recognize the keyboard mapping or to guess it based on
00:00:01.017 the keyboard layout.  It is very likely that some keys will not
00:00:01.017 work correctly in the guest.  If you would like to help us improve
00:00:01.017 the product, please submit a bug report, giving us information
00:00:01.017 about your keyboard type, its layout and other relevant
00:00:01.017 information such as whether you are using a remote X server or
00:00:01.017 something similar. 
00:00:01.017 The keycode-to-scancode table is:
0=0,1=0,2=0,3=0,4=0,5=0,6=0,7=0,8=0,9=0,10=0,11=0,12=0,13=0,14=0,
15=0,16=0,17=0,18=0,19=0,20=0,21=0,22=0,23=0,24=53,25=17,26=18,
27=19,28=20,29=21,30=22,31=23,32=24,33=16,34=0,35=0,36=0,37=0,
38=30,39=31,40=32,41=33,42=34,43=35,44=36,45=37,46=38,47=39,48=40,
49=0,50=0,51=0,52=45,53=44,54=46,55=47,56=48,57=49,58=50,59=0,60=0,
61=25,62=0,63=0,64=0,65=0,66=0,67=0,68=0,69=0,70=0,71=0,72=0,73=0,
74=0,75=0,76=0,77=0,78=0,79=0,80=0,81=0,82=0,83=0,84=0,85=0,86=0,
87=0,88=0,89=0,90=0,91=0,92=0,93=0,94=0,95=0,96=0,97=0,98=0,99=0,
100=0,101=0,102=0,103=0,104=0,105=0,106=0,107=0,108=0,109=0,110=0,
111=0,112=0,113=0,114=0,115=0,116=0,117=0,118=0,119=0,120=0,121=0,
122=0,123=0,124=0,125=0,126=0,127=0,128=0,129=0,130=0,131=0,132=0,
133=0,134=0,135=0,136=0,137=0,138=0,139=0,140=0,141=0,142=0,143=0,
144=0,145=0,146=0,147=0,148=0,149=0,150=0,151=0,152=0,153=0,154=0,
155=0,156=0,157=0,158=0,159=0,160=0,161=0,162=0,163=0,164=0,165=0,
166=0,167=0,168=0,169=0,170=0,171=0,172=0,173=0,174=0,175=0,176=0,
177=0,178=0,179=0,180=0,181=0,182=0,183=0,184=0,185=0,186=0,187=0,
188=0,189=0,190=0,191=0,192=0,193=0,194=0,195=0,196=0,197=0,198=0,
199=0,200=0,201=0,202=0,203=0,204=0,205=0,206=0,207=0,208=0,209=0,
210=0,211=0,212=0,213=0,214=0,215=0,216=0,217=0,218=0,219=0,220=0,
221=0,222=0,223=0,224=0,225=0,226=0,227=0,228=0,229=0,230=0,231=0,
232=0,233=0,234=0,235=0,236=0,237=0,238=0,239=0,240=0,241=0,242=0,
243=0,244=0,245=0,246=0,247=0,248=0,249=0,250=0,251=0,252=0,253=0,
254=0,255=0
00:00:01.024 ************************* CFGM dump *************************
[...]

I can send the rest of the log file if necessary. I do not know exactly what information to give you concerning my hardware. It’s a TOSHIBA „Satellite M50-215“, delivered in Germany with a QWERTZ keyboard. I do not know if it makes any difference, but I mention it just in case: I’m using a NEO keyboard layout on my host system, not the standard German one. Please tell me if you need any further information.

Do I have to get a new laptop before I can use VirtualBox?

Thank you for any advice, best,

René

Attachments

VBox log Download (59.6 KB) - added by quantenbein 4 years ago.
Log file

Change History

Changed 4 years ago by quantenbein

Log file

comment:1 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)
  • Summary changed from Keys missing on the keyboard to Keys missing on the keyboard -> duplicate of #2595

This ticket is a duplicate of #2595. It could be fixed by using the XKB extension to get information about the keyboard, but due to the small number of people affected, I'm afraid that it is unlikely to be done in the near future.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use