VirtualBox

Ticket #7081 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Routed networking to hostonly if extremely slow after upgrade to 3.2.6 => Fixed in 3.2.8

Reported by: mightyzen Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

In our setup VMs use host-only networking. VPN and external traffic is forwarded using iptables to the VMs. After upgrade from 3.2.4 to 3.2.6 this traffic became real slow:

From an host connected through the vpn with 3.2.4:

scp root@10.101.2.101:/var/lib/aptitude/pkgstates .
pkgstates  100% 2069KB   2.0MB/s   00:01

On 3.2.6:

scp root@10.101.2.101:/var/lib/aptitude/pkgstates .
pkgstates  100% 2069KB  15.9KB/s   02:10

On the host itself communication to the VMs is fast. Slow networking only occurs when routed (FORWARDed) through iptables.

Host is 64bit Lucid (running on i7 920 with 24GB ram), guests are 32 bit karmics.

Downgrading to 3.2.4 solved the speed problem, but the extensive logging came back (Ticket #6872). May be the fix for 6872 is related to this issue?

Attachments

checksum.patch Download (14.0 KB) - added by aleksey 4 years ago.
corrected_checksum.patch Download (14.8 KB) - added by aleksey 4 years ago.

Change History

comment:1 Changed 4 years ago by bodo

yeap, exactly the same observations and exactly the same conclusions :-) (btw. I opened bug 6872)

my own research in here:  http://forums.virtualbox.org/viewtopic.php?f=7&t=31614

comment:2 Changed 4 years ago by ante

I have host only networked VM machines on Ubuntu server 9.04 with IP tables forwarding. Upgrade from version 3.1 to 3.2.6 bring extremely slow network speeds. Downgraded back to 3.1 and everything works OK.

comment:3 Changed 4 years ago by aleksey

Did you use e1000 as the guest NIC? Can you try virtio-net instead?

comment:4 Changed 4 years ago by ante

Intel PRO/1000 MT Server. I will try virtio-net this weekend.

comment:5 Changed 4 years ago by bodo

as far as i remember i tried with virtio as well and it was equally rubish, but not 100% sure so if ante wants to check as well it would be good. also virtio drivers for windows 2008 x64 suck to say the least (stability issues), so virtio-net is not an alternative really.

comment:6 Changed 4 years ago by ante

I've upgraded Virtualbox to 3.2.6 and set network adapters to virtio.Linux guests are good now, normal network speeds.

I have problems with Windows guests, can not install virtio drivers for W2008 64bit server. Another problem with Windows guest is slow network speeds when accessing these servers from internet, around 1.5-3.0Mbit while host has 100Mbit dedicated internet connection and what is interesting Linux guests don't have such problems. I noticed this Windows guest problems also with 3.1 version and with AMD and Intel network adapters. I think 3.0 version was good and was not affected with this capped internet speeds for Windows guests.

comment:7 Changed 4 years ago by ante

I did another test with my Windows guest, when I change networking to NAT internet speed is good. Host only networking is affected with this bug. Virtio driver is better than other types but as I said speed is still far from from good.

comment:8 Changed 4 years ago by mightyzen

I'm using Intel PRO/1000 MT Desktop. It's not easy for me to change vb versions as the system is operational. I'm running 3.2.4 at the moment (with the extensive logging problem). During the testing of 3.2.6, I found communications between hosts and guests to be at full speed. Only forwarded connections suffered. This would lead me to think that the problem is more host related than guest. Unless the different guest NICs have (fundamental) different ways to communicate with the host environment of course. And that some modification between 3.2.4 and 3.2.6 started this.

comment:9 Changed 4 years ago by aleksey

The problem was caused by checksum computation code. I'l provide a patch shortly.

comment:10 Changed 4 years ago by ante

I moved one of my guest Windows installation to another non-production serve and bug is still there :). Waiting for patch now ...

Changed 4 years ago by aleksey

comment:11 Changed 4 years ago by frank

Aleksey added the patch. Please make sure that no VM is running, apply the patch (the location is usually /usr/src/vboxnetflt-3.2.6), recompile the host kernel modules with

/etc/init.d/vboxdrv setup

and the start your VM.

comment:12 Changed 4 years ago by ante

Patch didn't help. Same as before patch. I applied patch correct and did recompile host kernel modules as you described.

Internet speed over NAT is maximal (800KB/s), host only interface is 5x times slower (160 KB/s).

comment:13 Changed 4 years ago by ante

I also tested different versions of Virtualbox (3.2.4, 3.0 and 3.1) but always had low internet speeds in windows guests.

comment:14 Changed 4 years ago by frank

ante, then your problem is different from the original reporter of this ticket. He (mightyzen) reports that his performance problems started after upgrading from VBox 3.2.4 to VBox 3.2.6 and the patch should address this issue.

comment:15 Changed 4 years ago by mightyzen

Unfortunately the patch doesn't work for me either. I upgraded again to 3.2.6 and applied the patch:

root@node16 /usr/src # patch -p0 < checksum.patch 
patching file /usr/share/virtualbox/src/vboxnetflt/include/VBox/pdmnetinline.h

root@node16 /usr/src # /etc/init.d/vboxdrv setup
 * Stopping VirtualBox kernel module
 *  done.
 * Removing old VirtualBox netadp kernel module
 *  done.
 * Removing old VirtualBox netflt kernel module
 *  done.
 * Removing old VirtualBox kernel module
 *  done.
 * Recompiling VirtualBox kernel module
 *  done.
 * Starting VirtualBox kernel module
 *  done.

Forwarded network traffic still limited to about 16KB/s

scp root@10.100.2.100:/var/lib/aptitude/pkgstates .
pkgstates             100% 2340KB  16.4KB/s   02:23    

Now back to 3.1.8.

Changed 4 years ago by aleksey

comment:16 Changed 4 years ago by aleksey

mightyzen, I've attached the updated patch (one file was missing in the previous version of the patch). Could you try again, please?

comment:17 Changed 4 years ago by mightyzen

Works for me now. Thanks.

comment:18 Changed 4 years ago by frank

  • Summary changed from Routed networking to hostonly if extremely slow after upgrade to 3.2.6 to Routed networking to hostonly if extremely slow after upgrade to 3.2.6 => Fixed in 3.2.8

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use