VirtualBox

Ticket #7009 (closed defect: fixed)

Opened 4 years ago

Last modified 6 months ago

Starting VM with Intel-VT enabled freezes system

Reported by: Linuxhippy Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

When starting a VM on my laptop with Intel-VT enabled, the host freezes immediatly. As workarround I can disable VT in BIOS.

I experience the problem with: VirtualBox-3.2.4 and 3.1 Fedora-12 and Fedora-13 + rawhide-2.6.34

Because the system freezes immediatly after starting the VM, log files are empty. I'll attach a log file generated when VT was disabled.

Attachments

VBox.log Download (71.9 KB) - added by Linuxhippy 4 years ago.
vmware.log Download (71.7 KB) - added by Linuxhippy 3 years ago.

Change History

Changed 4 years ago by Linuxhippy

comment:1 Changed 4 years ago by frank

I assume that you can re-enable VT-x in your BIOS but disable the VT-x/AMD-V checkbox in the VM settings. Could you test this as well? Did you ever install an older version of VirtualBox on this machine?

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

comment:3 Changed 4 years ago by Linuxhippy

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Sorry for the late response, was quite busy lately. I updated to VirtualBox-3.2.8 + Linux-2.6.34.3 and the problem still persists.

As soon as the VirtualBox logo disappears in the VM-Window the whole system freezes, disabling VT in Bios or using VirtualBox's checkbox helps. Disabling "Nested Pages" while leaving "IVT" turned on did not help.

comment:4 Changed 4 years ago by Linuxhippy

And yes, I remember I tried VirtualBox-3.1.? some time ago and experienced the same problem.

comment:5 Changed 4 years ago by frank

Were you ever able to execute any other VMM on your host working in VT-x mode? We have some reports about freezes in VT-x mode, some of them were solved by a BIOS update.

comment:6 Changed 4 years ago by Linuxhippy

Yes, VMWare-Player works with VT-x enabled.

The machine is a Tecra-A8 Laptop with one of the first Core2Duos (stepping 6 / B2), but has a recent BIOS.

Thanks, Clemens

comment:7 Changed 4 years ago by Linuxhippy

So is there anything I can do to get this problem fixed, like providing information or running test-cases?

comment:8 Changed 4 years ago by frank

  • Component changed from other to VMM/HWACCM

comment:9 Changed 4 years ago by sandervl73

How sure are you that VMWare Player used VT-x on your system?

comment:10 Changed 4 years ago by Linuxhippy

Pretty sure

comment:11 Changed 4 years ago by sandervl73

Either you're 100% sure or you're not. :) Select hardware virtualization in the setting dialog and upload the VM session log please.

comment:12 Changed 4 years ago by Linuxhippy

Either you're 100% sure or you're not

You asked how sure I am, not wether or not. I know I had VT-x enabled, but I didn't read the logs to validate wether it was really used.

Select hardware virtualization in the setting dialog and upload the VM session log please.

Doesn't work, VirtualBox crashes the system instantly, there are no logs after the crash.

comment:13 Changed 4 years ago by Linuxhippy

By the way, still happens with 3.2.10 + 2.6.34.7. So what can I do to bring this foreward?

comment:14 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.2.4 to VirtualBox 3.2.10

comment:15 Changed 3 years ago by sandervl73

I've asked you for the VMWare log of the session which you say uses VT-x. Please attach that.

comment:16 Changed 3 years ago by Linuxhippy

Still happens with VirtualBox-4.0.2, on a fresh Fedora-14 installation (2.6.35.11-83.fc14.i686).

vmware log attached.

Changed 3 years ago by Linuxhippy

comment:17 follow-up: ↓ 18 Changed 3 years ago by enteon

Can confirm this bug on Debian Squeeze 32 Bit (2.6.32) ; VirtualBox OSE 3.2.10 and 4.0.2 ; Thinkpad T60 T7200 CPU, latest BIOS.

Using 32 Bit Windows kernel (installed and Installation DVD) 7 and XP.

Even more weird: NO freeze IF there is no battery present. In which case the BIOS won't allow any faster CPU multiplicator than the slowest (1GHz, fastest would be 2GHz). Even though VT-x is enabled!

But as soon as the CPU may switch its frequency I have to disable VT-x in order to run any of the Windows kernels.

There is nothing in /var/log/messages except for "'VirtualBox' uses 32-bit capabilities (legacy support in use)", which was pretty obvious to me.

comment:18 in reply to: ↑ 17 Changed 3 years ago by enteon

Nevermind, happened in KVM too so i figured out that my CPU got too few volts. My bad.

comment:19 Changed 3 years ago by Linuxhippy

This is one of those typical bug-reports. One of those which make me regret I spend my time again and again.

I file it, then I am asked about tons of information (in this case I set up VMWare, just to get the log file) - and when there is finally nothing left which would stop investigation the report just rots and nobody cares.

comment:20 Changed 3 years ago by mhanor

You have not provided any information that can be analyzed, the cause of your hangs is not contained in the files you provided. If the devs can't reproduce the issue, they can't tell what's going wrong.

Try to monitor the live vbox.log file, the linux system logs (e.g. /var/log/kern.log, daemon.log, messages and dmesg), while starting the VM, from a local console window (tail -f to follow), or over a ssh session, or (even better) over a serial (COM) console. Run VB headless, so you can run from the full-blown textmode linux console, and not from X.

Also, you can try to learn how to debug a fozen linux kernel. Search on google for "debugging linux hangs", "linux hard lockup", "linux magic SysRq key" and other similar key words/combinations. Here's a some useful links, things should be similar for Fedora:
 http://en.wikibooks.org/wiki/Linux_Guide/Freezes#Alt.2BSysRq
 http://www.av8n.com/computer/htm/kernel-lockup.htm

comment:21 Changed 6 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.3.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use