VirtualBox

Ticket #6946 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Virtualbox Unexpectedly Crashes since 3.2.0

Reported by: kidault Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.4 Keywords: crash
Cc: Guest type: Windows
Host type: Windows

Description

When run certain programs in the WinXP home guest, the virtualbox will crash, but not affect other guest that is running at the same time.

For example:

  1. When double click a dwg file, lunching the Zwcad( an Autocad aternative developed by a chinese company)
  2. open a certain web page in IE8(a oracle erp web page on intranet, not accessable on Internet)

Disable 2d or 3d accerlate and VT-x support doesn't help.

When crash happened, Changing the seamless mode to window mode would help.

Bellow is four most latest crash information given out by the win7 pro, and their corresponding log filename

WorkXP-2010-06-08-11-05-04

问题签名:

问题事件名称: APPCRASH 应用程序名: VirtualBox.exe 应用程序版本: 3.2.2.0 应用程序时间戳: 4c079c92 故障模块名称: QtOpenGLVBox4.dll 故障模块版本: 4.4.3.0 故障模块时间戳: 49d69fc8 异常代码: c0000005 异常偏移: 00001c90 OS 版本: 6.1.7600.2.0.0.256.48 区域设置 ID: 2052 其他信息 1: b804 其他信息 2: b80454cc42ecac28e0b25e0611d32a5e 其他信息 3: 1390 其他信息 4: 13902aba80f19841bcf4c75fd6474693

WorkXP-2010-06-08-12-48-50.log

问题签名: 问题事件名称: APPCRASH 应用程序名: VirtualBox.exe 应用程序版本: 3.2.2.0 应用程序时间戳: 4c079c92 故障模块名称: QtOpenGLVBox4.dll 故障模块版本: 4.4.3.0 故障模块时间戳: 49d69fc8 异常代码: c0000005 异常偏移: 00001c90 OS 版本: 6.1.7600.2.0.0.256.48 区域设置 ID: 2052 其他信息 1: b804 其他信息 2: b80454cc42ecac28e0b25e0611d32a5e 其他信息 3: 1390 其他信息 4: 13902aba80f19841bcf4c75fd6474693

WorkXP-2010-06-09-12-57-49.log

问题签名:

问题事件名称: APPCRASH 应用程序名: VirtualBox.exe 应用程序版本: 3.2.4.0 应用程序时间戳: 4c0ce872 故障模块名称: QtOpenGLVBox4.dll 故障模块版本: 4.4.3.0 故障模块时间戳: 49d69fc8 异常代码: c0000005 异常偏移: 00001c90 OS 版本: 6.1.7600.2.0.0.256.48 区域设置 ID: 2052 其他信息 1: b804 其他信息 2: b80454cc42ecac28e0b25e0611d32a5e 其他信息 3: b73f 其他信息 4: b73fa153c68b725edfb86b319f56b045

WorkXP-2010-06-09-13-02-46

问题签名: 问题事件名称: APPCRASH 应用程序名: VirtualBox.exe 应用程序版本: 3.2.4.0 应用程序时间戳: 4c0ce872 故障模块名称: QtOpenGLVBox4.dll 故障模块版本: 4.4.3.0 故障模块时间戳: 49d69fc8 异常代码: c0000005 异常偏移: 00001c90 OS 版本: 6.1.7600.2.0.0.256.48 区域设置 ID: 2052 其他信息 1: b804 其他信息 2: b80454cc42ecac28e0b25e0611d32a5e 其他信息 3: b73f 其他信息 4: b73fa153c68b725edfb86b319f56b045

联机阅读隐私声明:

 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0804

如果无法获取联机隐私声明,请脱机阅读我们的隐私声明:

C:\Windows\system32\zh-CN\erofflps.txt

Attachments

Virtualbox_log.zip Download (44.6 KB) - added by kidault 4 years ago.
Vbox log files
WorkXP-2010-06-10-09-41-24.zip Download (12.1 KB) - added by kidault 4 years ago.
Win XP-2010-06-10-12-16-49 Aborted.log Download (41.2 KB) - added by Bones 4 years ago.
eLive_gui.jpg Download (35.2 KB) - added by kidault 4 years ago.
The eLive client gui after starting up. This a IM client base on MSN live messenger

Change History

Changed 4 years ago by kidault

Vbox log files

comment:1 follow-up: ↓ 3 Changed 4 years ago by frank

Does it still crash if you disable 2D and/or 3D for this VM? Does it crash with VBox 3.2.4?

comment:2 Changed 4 years ago by kidault

crash caused by new program

Happened when i was launching eLive im client.(an IM client provided by China Telecom)

WorkXP-2010-06-10-09-41-24.log

crash information provided by host win7pro

问题签名:
问题事件名称: APPCRASH
应用程序名: VirtualBox.exe
应用程序版本: 3.2.4.0
应用程序时间戳: 4c0ce872
故障模块名称: QtOpenGLVBox4.dll
故障模块版本: 4.4.3.0
故障模块时间戳: 49d69fc8
异常代码: c0000005
异常偏移: 00001c90
OS 版本: 6.1.7600.2.0.0.256.48
区域设置 ID: 2052
其他信息 1: b804
其他信息 2: b80454cc42ecac28e0b25e0611d32a5e
其他信息 3: b73f
其他信息 4: b73fa153c68b725edfb86b319f56b045

联机阅读隐私声明:

 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0804[[BR]]

如果无法获取联机隐私声明,请脱机阅读我们的隐私声明:

C:\Windows\system32\zh-CN\erofflps.txt

comment:3 in reply to: ↑ 1 Changed 4 years ago by kidault

Replying to frank:

Does it still crash if you disable 2D and/or 3D for this VM? Does it crash with VBox 3.2.4?

I'm using 3.2.4 for several days, this problem is still there.

Disable 2D and 3D seems not help. I will spend a little more time to test it.

Changed 4 years ago by kidault

Changed 4 years ago by Bones

comment:4 Changed 4 years ago by Bones

I have the same or a similar problem. Host: Ubuntu 10.04, Guest: Win XP. VBox 3.2.4. When using a 2D vector graphic drawing program (General Cad), the guest aborts on loading the program. Seems to work when running in a window, rather than seemless mode, seems to work if not using 2D video acceleration. Also seems to work if first load the guest on a previous version of Vbox, then install V3.2+ and run.

comment:5 follow-up: ↓ 8 Changed 4 years ago by Entity

I also experience this bug since 3.2.0. With both 3D and 2D enabled seems to happen more often. With only 2D enabled it happens less, but still happens.

A note: opening windows live messenger in Windows XP is one of the things that cause the crash when only 2D enabled.

comment:6 Changed 4 years ago by kidault

Last week, I kept to launch the programs that had caused the guest crash problem in window mode and return to seamless mode after they have launched successfully. It worked well.

This morning, I did some experiment. I started the eLive IM client while The guest was in seamless mode. The guest crashed

I started the guest again(in seamless mode), ran the eLive, and the guest crashed again.

I started the guest the third time, returned to window mode, ran the eLive. It didn't cause the guest to crash this time.

2d and 3d support is always on.

Now I think the VB on my machine must have some problem with the seamless mode, not with 2d or 3d support.

What can I do to provide more informoation?

Changed 4 years ago by kidault

The eLive client gui after starting up. This a IM client base on MSN live messenger

comment:7 follow-up: ↓ 9 Changed 4 years ago by kidault

In the same guest session, it will not cause the guest to crash if I close the eLive program(not just minimize to tray) and re-launch it.

comment:8 in reply to: ↑ 5 Changed 4 years ago by kidault

Replying to Entity:

I also experience this bug since 3.2.0. With both 3D and 2D enabled seems to happen more often. With only 2D enabled it happens less, but still happens.

A note: opening windows live messenger in Windows XP is one of the things that cause the crash when only 2D enabled.

eLive is based on windows live messenger.

comment:9 in reply to: ↑ 7 Changed 4 years ago by kidault

Replying to kidault:

In the same guest session, it will not cause the guest to crash if I close the eLive program(not just minimize to tray) and re-launch it.

The eLive program is re-launched while the guest is in seamless mode.

comment:10 Changed 4 years ago by kidault

This problem seems to have been fixed in 3.2.6

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use