VirtualBox

Ticket #6863 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Ubuntu 10.04 64-bit host cannot install fresh Win7Pro 64-bit guest

Reported by: boltronics Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.0 Keywords: 10.04 windows installation 0x80FF0000
Cc: Guest type: Windows
Host type: Linux

Description

Steps to reproduce:

  1. Install Ubuntu 10.04 64-bit.
  2. Install VirtualBox 3.2 from the official repository.
  3. Create a new VM from scratch. Use all defaults, except select "Windows 7 (64 bit)" as the guest. I also increased my dynamic disk to 120 GB instead of 20 GB, but don't expect that would matter. Install the guest from either an ISO or a DVD image (I tried both ways).
  4. Go through the installation selecting the defaults.

As soon as you get to the section "Installing features", (or thereabouts) you will always get the error "Windows could not set the offline locale information 0x80FF0000". The installation will fail.

I'm running on an LGA1366 i7 with 6Gb of RAM and hundreds of GB free space on the host.

The above procedure works in VirtualBox 3.1, so this would be a regression.

Attachments

win7pro-64.log Download (3.1 KB) - added by boltronics 4 years ago.
VBoxManage showvminfo "Windows 7 Professional (64 bit)" --details --machinereadable > ~/win7pro-64.log
VBox.log Download (38.7 KB) - added by mikke 4 years ago.
Installation of 64bit Windows 7 Home Premium
temp win7 (64 bit)-2010-06-11-18-49-07.log Download (70.7 KB) - added by boltronics 4 years ago.
Original reporter's vbox.log file.

Change History

Changed 4 years ago by boltronics

VBoxManage showvminfo "Windows 7 Professional (64 bit)" --details --machinereadable > ~/win7pro-64.log

comment:1 Changed 4 years ago by Technologov

Duplicate of bug #6742

boltronics: disable "Nested Paging" until fix is released. (VM settings->System->Acceleration)

-Technologov

comment:2 Changed 4 years ago by boltronics

Strange... after installing successfully on 3.1, I upgraded again to 3.2 and launched the same VM. Nested paging was on by default... and it boots fine.

So I only need to disable Nested Paging for the installation, and then I can re-enable it?

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 4 years ago by boltronics

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Confirming that this is not a duplicate.

Upgraded to VirtualBox 3.2.2, performed the same steps as above and it failed (so 3.2.2 didn't fix the issue, as expected anyway from #6742).

Then I started re-installing Windows 7 again in the same VM, but with Nested Paging turned off. This option had no effect, and the problem remained.

The only work-around at this point is to install using 3.1. Once installed, Windows runs fine in 3.2 or 3.2.2 (AFAICT). If this is the same bug as #6742, why do the machines run normally after installation?

comment:5 Changed 4 years ago by Technologov

Then please provide vbox.log (you have provided only VM details log).

-Technologov

comment:6 Changed 4 years ago by frank

It is also possible that the guest runs at normal speed after the guest additions are active.

comment:7 Changed 4 years ago by boltronics

Hi Frank. Not sure exactly what you mean, as I'm not concerned at all with performance (in this bug report, at least). I just needed to install Windows 7 64-bit (which I achieved by downgrading, installing and then upgrading).

Sorry I haven't had a chance to redo the installation and generate the log. I note that 3.2.4 was just released too so I'll test with that when I can. For all I know it's already fixed.

Changed 4 years ago by mikke

Installation of 64bit Windows 7 Home Premium

comment:8 Changed 4 years ago by mikke

I have a similar problem with 64bit Windows 7 Home Premium. However, this problem seems to be related to SATA storage. If I manually move the hard disk to IDE controller, the installation seems to proceed further.

Changed 4 years ago by boltronics

Original reporter's vbox.log file.

comment:9 Changed 4 years ago by frank

boltronics, is your VM disk image located on an ext4 partition? If so, then this is a known issue (ext4 bug). And enabling the host cache keeping it attached to the SATA controller would fix the problem as well.

comment:10 Changed 4 years ago by boltronics

Interesting. It could very well be. I'll check it out tomorrow, and test your work around. Thanks.

comment:11 Changed 4 years ago by mikke

Confirmed: Windows 7 Home Premium 64bit was successfully installed using SATA controller with host cache enabled.

comment:12 Changed 4 years ago by boltronics

Confirming here too. I was using ext4 and enabling host I/O cache on the SATA controller allowed the installation to complete. Good analysis.

Mind linking the ext4 bug report here? It wasn't clear to me which ext4 bug it was.

An incompatibility with ext4 has pretty big implications, as I imagine installing VB on Ubuntu (which uses ext4 by default) is quite common. I also wonder what other guest OSs would see problems due to the host using ext4.

I see now why my Win7 install succeeded in VB3.1 - it configured the guest with the PIIX4 IDE controller by default. In the next VB release, can we detect a known-broken ext4 version and disable the host I/O cache checkbox to ensure it cannot be unticked (or pop-up a warning or some such)? Alternatively/in addition, perhaps a broken ext4 install should default to using the old IDE controller instead?

Even if this ext4 bug was fixed today and a new version of ext4 released, would all popular distributions immediately backport patches to fix it (or provide an update to the latest version)? If not, perhaps the most user-acceptable solution would be to implement one of those [horrible, I agree] workarounds?

comment:13 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

VBox 3.2.6 contains a workaround. It will warn the user and automatically enable the host I/O cache if the disk image is located on an ext4 partition or an xfs partition. Regarding the kernel bug: There are already patches available but we still have to evaluate them. And surely it will still take some time until the bug is finally fixed in the kernel.

comment:14 Changed 4 years ago by boltronics

Thanks Frank. Does the job nicely.

comment:15 Changed 4 years ago by frank

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use